Results 1 to 4 of 4
  1. j$hort's Avatar
    Posts
    203 Posts
    Global Posts
    204 Global Posts
       #1  
    Hello all, just ran into a problem with my Treo 600. This weekend it suddenly went to a white screen. I figure I'd just reset it and all would be fine. After soft reset the white screen is displayed. I decided to try to do a hard reset, it does not respond, screen stays white and cannot be turned off with power button. I tried to drain the battery and recharge. When connecting the power cord the white screen is displayed and cannot be turned off. So any charge or power connection and the screen is white and no way to turn it off. The only way to get the screen off is to let it run out of power.

    Has anyone run into similar or have any ideas?
  2. j$hort's Avatar
    Posts
    203 Posts
    Global Posts
    204 Global Posts
       #2  
    After further investigation which involved testing my screen, board, etc using another device I have determined that the main board is toast. I am planning a 680 purchase and I guess after 3 1/2 years of use it is time to say goodbye to the Treo 600. I parted it out and have listed parts on ebay under the same user name you see here.

    I am a GSM (Tmo) user...any other recommendations on devices..this is a good time to do some comparison shopping...
  3. #3  
    Another faithful T600 user bites the dus”
  4. j$hort's Avatar
    Posts
    203 Posts
    Global Posts
    204 Global Posts
       #4  
    Hey Vet,

    Dont count me out yet! My next move is the 680, but I am open to alternatives as I shop. The definates are GSM (Tmo, where I have the $5/mo unlimited email deal) and Palm OS. The 600 lasted me 3.5 years and is being parted out on ebay. The only pervious device that is/was still working for me is my original Visor!

    Lets hear all your competitors folks....

Posting Permissions