Results 1 to 15 of 15
  1.    #1  
    I bought the battery and charged it for 12hours. it charges to 94%. I have tried the battery reset and also tried the battey on 2 different 680s with the same result.
    I need help, the Treo doesn't seem to register that I have a 1300amh battery.
  2. #2  
    First the case. Now the battery. Hang in there, Man.

    d-
  3.    #3  
    At least its not vaja made battery, it would cost $1000 and they say its not for frequent use.
  4. #4  
    Are you sure it isnt reaching 100% and then gradually discharging? It is pretty well established that this happens with the 680 and 12 hours is a lot longer than needed to get to 100%. If you arent sure, try plugging it back in again and remove it from the charger when the LED goes green.
  5.    #5  
    Come to think of it, that is what happened. Why does it do that?
  6.    #6  
    This is nuts. With screen brightness all the way up, chatter running and music playin. My treo has been at 0% for 2 hours. LOL
  7.    #8  
    your links aren't working. The original battery didn't last that long for me after it displayed I was extremly low
  8. #9  
    Quote Originally Posted by smileyboy View Post
    Come to think of it, that is what happened. Why does it do that?
    seems to be a failure to continue to trickle charge after reaching 100%, thus causing the battery to start draining as if it was unplugged.
  9. #10  
    Just curious, but no other problems but this one? No heat or expansion problems? Thanks!

    P.S. I just saw other threads that say the 680 may have a trickle problem.
    Last edited by The Phone Diva; 02/11/2007 at 04:07 AM.
    HP has officially ruined it's own platform and kicked webOS loyalists and early TouchPad adopters to the curb. You think after you drop it like a hot potato and mention it made no money and is costing you money, anyone else wants it??? Way to go HP!!

    And some people are fools to keep believing their hype. HP has shown they will throw webOS under the bus and people are still having faith in them??? News flash: if it's own company won't stand behind it, it's finished!
  10. TLCC's Avatar
    Posts
    46 Posts
    Global Posts
    52 Global Posts
    #11  
    I have the Seidio 1300 mah battery as well. I usually wake to a 90% charge. I unplug and plug in again to 99% then go on with my day. I must say that I am getting better performance with the Seidio battery than I was with the original Palm battery.
  11.    #12  
    so what's up with mine? I woke up to 0% this morning. did a few resets, battery resets and such with no change in % levels. Seidio u there? Have any suggestions?
  12. #13  
    Quote Originally Posted by smileyboy View Post
    so what's up with mine? I woke up to 0% this morning. did a few resets, battery resets and such with no change in % levels. Seidio u there? Have any suggestions?
    That is a weird one. Call 832-204-1118 and ask for Kelvin. He's one of our best technical support people and should be able to take care of you.

    Thanks
  13.    #14  
    Thank you. my replacment is on its way.
  14. TLCC's Avatar
    Posts
    46 Posts
    Global Posts
    52 Global Posts
    #15  
    funny thing, my 1300 mah Seidio battery will not hold a charge. I plugged it up this morning like always but today it was down to 47% by noon. What? This is a first since I have had my 680. It completely drained by 2:00. I put my original Palm battery in and things are back to normal. Have I used the life of this battery since 1/19/07? This does not seem right. I am charging the battery now and we will see what happens.

Posting Permissions