Page 1 of 2 12 LastLast
Results 1 to 20 of 23
  1.    #1  
    I have a problem with Wordsmith that they can not recreate and it does not happen on my wife's Visor! could someone verify if it happening on their Visors.


    Wordsmith 1.11a

    When I use the 'save as' command to convert a Wordsmith document, to a .doc(Plain Text - Palm Doc)with a new name, I get a fatal error message:

    Select Wordsmith Doc
    Select Save/Save As
    Rename doc
    Select Plain Text (Palm Doc)

    Fatal Error Message:
    MemoryMgrNew.c,
    Line 3101,NillID
    Reset


    The Visor has to be reset, but the new doc is converted.
    I am using a Visor Deluxe with OS 3.1H3. The problem occurs with Hacks on or off. On my Visor NO DATA IS LOST!

    Thanks for your help.

    Martin
    Last edited by MartinS; 03/27/2001 at 06:34 PM.
  2. #2  
    I just tried it and guess what? I'm getting the same error message!!! It happens whether or not I select compression, too. I can, however, do a Save As a Palm DOC without an error if I don't rename the file.

    Blue Nomad, are ya listening???
    .
    .....
    MarkEagle
    .....<a href="http://discussion.treocentral.com/tcforum/index.php?s=">TreoCentral</a> | <a href="http://discussion.visorcentral.com/vcforum/index.php?s=">VisorCentral</a> Forum Moderator - Forum Guidelines
    .....Sprint PCS Treo 650
    .....God bless America, my home sweet home...
  3. #3  
    The good news is Blue Nomad responded to my email in less than an hour!!! (they are the best when it comes to customer service and support!).

    The bad news is that they can't reproduce the error on a Palm or in the emulator. From their reply:
    I haven't been able to repeat this here on Palm's or on the Palm emulator. It may be a conflict with another program you have or a hack. Try removing/disabling all hacks and other text/doc programs and see if this makes any difference.
    I tried it myself on POSE running the Visor ROM and could not reproduce the error.

    I am confident that if there's a fix (there's got to be, right?) the fine folks at Blue Nomad will make it right.
    .
    .....
    MarkEagle
    .....<a href="http://discussion.treocentral.com/tcforum/index.php?s=">TreoCentral</a> | <a href="http://discussion.visorcentral.com/vcforum/index.php?s=">VisorCentral</a> Forum Moderator - Forum Guidelines
    .....Sprint PCS Treo 650
    .....God bless America, my home sweet home...
  4. #4  
    Works fine on my up to date platinum. hmmm...

    Mark - I LIKE BLUE NOMAD! They are really cool people!
    -Michael Ducker
    TreoCentral Staff
  5. #5  
    Originally posted by MarkEagle
    I tried it myself on POSE running the Visor ROM and could not reproduce the error.
    Well, I spoke too soon

    It seems to be related to the OS version on the VDx. In the emulator, running OS v3.1H, I could not reproduce the error. However, after applying the Handspring "patch" to OS v3.1H3M, I'm now getting the same error on the emulator that I get on the VDx (OS v3.1H3). I've sent this information off to Blue Nomad...

    MartinS, are you using a VDx with the HS patch installed? What model and OS version is your wife using? This might help them narrow it down.

    Since miradu2000 doesn't get the error on his Platinum running OS 3.5.whatever, I'm convinced it has to do with the "patched" 3.1H3 (or 3.1H3M) OS.

    For those that don't know, the 3.1H3M is the patch for the bad RAM issue on the VDx. Luckily, mine doesn't need it while the emulator does.
    .
    .....
    MarkEagle
    .....<a href="http://discussion.treocentral.com/tcforum/index.php?s=">TreoCentral</a> | <a href="http://discussion.visorcentral.com/vcforum/index.php?s=">VisorCentral</a> Forum Moderator - Forum Guidelines
    .....Sprint PCS Treo 650
    .....God bless America, my home sweet home...
  6.    #6  
    Both my wife and I are using OS v3.1H3. I get the problem she does not !

    I will investigate further.

    Cheers

    Martin
  7.    #7  
    FOUND IT!

    I backed everything up on to a backup module and then deleted all my programs one at a time. With nearly 5Mb this took some time! Between each delete I tried the 'save as' command in WordSmith.

    I deleted the Stowaway Keyboard program (ver 1.2) Tried the save as and did not get the crash.

    I then backed up the Visor to its original state. Tried the save as and Crash!

    I then just deleted the Keyboard program Tried again and everything worked fine.

    This is repeatable every time. With the Keyboard program I get the crash. Without it I do not. I will try it on my wife's Visor tonight.

    Hope this helps

    Martin
  8.    #8  
    Further to my FOUND IT email

    I checked my wife's Visor and she has the Keyboard program! So whilst it may be part of the problem on my machine it isn't causing her problems. So I continued to delete programs on my Visor but this time leaving the Keyboard program on. I found that by deleting IR Link I also cured the problem. So there is another lead to follow!

    She does not have IR Link on her Visor.

    I dont know if it helps but I understand you can not use the Stowaway and the IR port at the same time, so this may have something to do with the problem,


    Cheers

    Martin
  9. #9  
    There is an updated keyboard driver for the visor and targus keyboard. It is version 1.5 and it's available from www.thinkoutside.com/support. Please try this driver and see if it has any effect on this problem!

    Thanks,

    Bobby Genest
    Blue Nomad Sales & Support Team
    www.bluenomad.com
  10.    #10  
    I have just upgraded to the new drivers for the Stowaway Keyboard V 1.5. I am now getting the IRLink box flashing every 30 seconds no matter which program I am in.

    The problem described above still happens.

    It would appear that WS/IRLINK/Stowaway Drivers do not like each other.

    Cheers

    Martin
  11. #11  
    Sounds like there may be an issue with IRlink? I found some info(quote below)from: http://www.iscomplete.org/IrLink15/irlinkf3.htm


    "HandSpring Visor Users
    Many users tried IrLink v1.5 without reading the user document which caused their device to Lock Up and had to perform a Hard Reset in order to recover the Visor. The problem is coming from the installation of AMX.prc, IrLib.prc, and SerIrPnl.prc from 3Com's IR Enhanced Update (IREU). Please just load the SerIrCommLib.prc from IREU. IrLink will take care of the IR control for you."

    I'm not sure if this is related to the problem we are having here, but it seemed to be important on their site..
    http://www.iscomplete.org/IrLink15/linksupp.htm

    "You will need SerIrCommLib.prc from 3Com IR enhanced driver. DO NOT LOAD AMX.prc, IrLib.prc, and/or SerIrPnl.prc on your Visor. It will crash your device totally and you will need a hard reset to make it works again. "

    Perhaps the IRlink isn't the latest version or the correct associated file isn't installed?

    Thanks,

    Bobby Genest
    Blue Nomad Sales & Support Team
    www.bluenomad.com
  12. #12  
    Originally posted by Blue Nomad
    Sounds like there may be an issue with IRlink
    I'm not using IRLink on my VDx, but I do believe the referenced error has something to do with the serial drivers. The HS update fixes something in the serial library. From the readme file:
    - Serial Modem and Hotsync Fix
    This fix corrects an issue where a Visor may have difficulty performing a HotSync operation with a serial cradle when a modem SpringBoard module is installed.
    .
    .....
    MarkEagle
    .....<a href="http://discussion.treocentral.com/tcforum/index.php?s=">TreoCentral</a> | <a href="http://discussion.visorcentral.com/vcforum/index.php?s=">VisorCentral</a> Forum Moderator - Forum Guidelines
    .....Sprint PCS Treo 650
    .....God bless America, my home sweet home...
  13. #13  
    Thanks Mark, we are doing some testing now and hope to figure this out soon. Thanks to Martin for bringing this to our attention! We'll be posting as soon as we learn anything.

    Best Regards,

    Bobby Genest
    Blue Nomad Sales & Support Team
    www.bluenomad.com
  14. #14  
    I discovered a symptom of the problem with WordSmith1.11a tonight. I am using the Stowaway driver 1.5, and I also have IRLink installed, but have no problems with it. It was installed long before WS. However, I noticed the following: If I open a document then try to go to another app - I have problems with that app. Doesn't matter if I use the Launcher or a hack to switch programs. It also doesn't matter if I turn the Visor off. If I open a doc, then I'll get the error.

    What I get is a Fatal Exception and soft reset button whever I try to delete a record in ActionNames / Datebook+ / Todo, or Shadowplan. I also have lockups in Four.Zero in the same conditions. I think other programs may have locked as well, but I have not fully tested these. I have written an email to BlueNomad Support, but it won't be sent until I sync tomorrow. Hope this helps. Incedentally, I never had this problem with the initial release of WS, only the last two upgrades. It doesn't appear to have anything to do with the Stowaway driver.
  15. #15  
    Hello Brandon,

    This sounds a lot like the problem that was fixed with 1.11a. That is when exiting wordsmith and going into another app, a fatal error would happen when a dialog box was opened. For example "are you sure you want to delete this item?..archive on hotsync?" Please try the following:

    To cleanly install the program, you will have to delete the prior palm version first. Make sure you have your registration code saved somewhere and copies of all documents that have formatting and that you have been syncing with WordSmith.

    Use the palm's delete app to get all of WordSmith off of the handheld. This includes any WrdS_docs files and WrdS_open files you may have on the palm. Then download and install the whole program on desk and palm as if you never had it. You will need to enter in registration code on the handheld if you were registered before.

    You can download the latest version of WordSmith from here:

    http://www.bluenomad.com/ws/prod_wor..._download.html

    If you still have problems, please let us know.

    Thanks,

    Bobby Genest
    Blue Nomad Sales & Support Team
    www.bluenomad.com
  16. #16  
    That appears to have fixed it - I had to do a complete uninstall of WS, then reinstall it and my docs. For certain, I am not getting the same consistant errors I was last night. Thanks for your help! Others should try this step to attempt resolution of their problems.
  17. #17  
    I was having a variety of woes with 1.1 and 1.11, but just as I was preparing an exhaustive test report of all of the goofy little things that were happening, BlueNomad released 1.11a, and now my little Visor is happy again!

    By the way, I think Wordsmith is one of those extremely rare "Killer Apps", and Blue Nomad's support is second to none. Keep up the good work, guys!
    --
    ThirdMan
  18. #18  
    I couldnt delete it as it came up with a dialog box then had a fatal exception. I installed over 1.11 and so far have had no problem.
    My Treo has more memory than I do.
  19. #19  
    Originally posted by Blue Nomad
    If you still have problems, please let us know.
    I did a full uninstall/reinstall of 1.11a but it had no effect on the original plain text saving error.
    .
    .....
    MarkEagle
    .....<a href="http://discussion.treocentral.com/tcforum/index.php?s=">TreoCentral</a> | <a href="http://discussion.visorcentral.com/vcforum/index.php?s=">VisorCentral</a> Forum Moderator - Forum Guidelines
    .....Sprint PCS Treo 650
    .....God bless America, my home sweet home...
  20.    #20  
    Well Blue Nomad have cured the problem for me. They sent me an update today with a fix.

    I still have an incompatibility issue with IRLink and the new Stowaway driver (1.5)........but WordSmith is working beautifully!

    I am really impressed with their customer support! Its a shame there are not a few other developers like them.

    Cheers

    Martin
Page 1 of 2 12 LastLast

Posting Permissions