Results 1 to 6 of 6
  1.    #1  
    Hello,

    New member...I did a bunch of searches on this, couldn't find anything, so...

    I believe the charging port on my Treo 650 is somehow physically worn. It seems impossible to hold the charger. At first I thought it was the charger itself, but I bought a brand new one and have the same issue. I really don't want to lose this phone, I love it and have had it for about 6 months. I can wiggle the plug to get it to the charging icon, but it will never remain for more than a second or two. I think my next step is to open it up, but I'm in search of some solutions once I get there!

    Has anyone dealt with this? Sorry if this has been brought up before, and I somehow missed it.

    Thanks again!
  2. #2  
    I havnt. You may want to take a look around online for replacemnt parts. Even ebay for a damaged treo 650 that you could use parts from.

    Taking the treo apart is not hard at all, I' just did it with two of them (replaced keypads to a newer looking grey/silver) and i was able to do it in under 45 minutes.

    Just have a clean work environment.
  3.    #3  
    This is actually a great suggestion, thanks. I had the whole thing apart yesterday to investigate, and you're right, not much to it. I'll investigate some damaged ones.

    Thanks!
  4. #4  
    I just had my Treo replaced under warranty for exactly the same issue.
  5.    #5  
    Really? Interesting....

    It really seem to come out of nowhere..... It was working great, then...bam....
  6. #6  
    Quote Originally Posted by Raythe54 View Post
    Hello,

    New member...I did a bunch of searches on this, couldn't find anything, so...

    I believe the charging port on my Treo 650 is somehow physically worn. It seems impossible to hold the charger. At first I thought it was the charger itself, but I bought a brand new one and have the same issue. I really don't want to lose this phone, I love it and have had it for about 6 months. I can wiggle the plug to get it to the charging icon, but it will never remain for more than a second or two. I think my next step is to open it up, but I'm in search of some solutions once I get there!

    Has anyone dealt with this? Sorry if this has been brought up before, and I somehow missed it.

    Thanks again!

    My 650 has the same issue, but my phone is almost two years old. I too thought it was the charger, but I can charge it with my car charger with no problems.

Posting Permissions