Results 1 to 15 of 15
  1.    #1  
    I am a TMobile user and got this phone unlocked yesterday (Yay GSMPhoneSource!)

    Anywho, everything works fine on it, I put in the GPRS info and it will go get mail, I can surf the internet, and I can make and receive calls, but for some odd reason, it will randomly stop working, and I get that message. A reboot will fix it, but that's not a good thing.

    Any ideas anyone? Bad SIM card? Time to move from the CNG ROM to the ROW perhaps?
  2. #2  
    i know it sounds silly, but on other phones, i've had to take the sim card out and put it back in. I wonder if its possible that the SIM needs to be reseated in the slot.
  3. fondoo's Avatar
    Posts
    200 Posts
    Global Posts
    325 Global Posts
    #3  
    i've been debating about purchasing a 680. the palm store has an unlocked 680 for $399. unbranded. now with cingular 2yr contract $199. i can pay an additional $30 to unlock it on the website. do you think its worth the $30 to unlock it yourself? once unlocked, does the tmobile or cingular still show up?
  4. #4  
    Cingular will unlock it for free, why do you want to pay 30 bucks?

    It will still have the cingular garbage on the phone after you unlock. It's a different version of software in ROM.
  5.    #5  
    I took out my SIM card and reseated it ... but it still gives me the woes.

    I notice that it's really only when I'm about to do something on the voice side of things (the data tends to not have a problem at all) ... like when I'm sending an SMS it will suddenly say "No signal" and then I get the lovely "Check SIM Card" ... reboot and its fine.

    Think it is the SIM card from TMobile? Or might it be the firmware? I surely hope it's not hardware related, that would bite.

    Any other ideas?
  6. fondoo's Avatar
    Posts
    200 Posts
    Global Posts
    325 Global Posts
    #6  
    from what i read on howardchui.com forum. they dont unlock everyones treo 680. even if they do, your roaming when in another country. i dont plan to use their roaming service. its cheaper to use asia's sim cards.


    Quote Originally Posted by bigcatny View Post
    Cingular will unlock it for free, why do you want to pay 30 bucks?

    It will still have the cingular garbage on the phone after you unlock. It's a different version of software in ROM.
  7. fondoo's Avatar
    Posts
    200 Posts
    Global Posts
    325 Global Posts
    #7  
    bishop: was it easy to unlock your treo on gsmphonesource?

    Quote Originally Posted by The Bishop View Post
    I took out my SIM card and reseated it ... but it still gives me the woes.

    I notice that it's really only when I'm about to do something on the voice side of things (the data tends to not have a problem at all) ... like when I'm sending an SMS it will suddenly say "No signal" and then I get the lovely "Check SIM Card" ... reboot and its fine.

    Think it is the SIM card from TMobile? Or might it be the firmware? I surely hope it's not hardware related, that would bite.

    Any other ideas?
  8.    #8  
    Quote Originally Posted by fondoo View Post
    bishop: was it easy to unlock your treo on gsmphonesource?
    Yes, I emailed him my IMEI and said it was a 680 at 7pm central, and by 11pm central I had my unlock code.

    By the way, I had a bad sim. Who knew? Check SIM Card error message .... bad sim .... I'm a moron.
  9. #9  
    Glad you figured out the issue.

    I got the "check SIM" message after I dropped my 680 on a tile floor - pulled the sim out and pushed it back in again and the phone has been fine since, must have been knocked out of place by the fall.
  10. #10  
    I'm having this problem with my t-mobile sim card on a brand new unlocked 680. I'll make a call and 90% of the time it'll drop and i'll have a "check sim", i'll have to pull the sim and re-insert it to get back up and running. OR my phoen will drop service, and not try at all to get service back until i turn the phone off then back on again.

    How could my sim card work perfectly fine in my 650, then all of a sudden give me these troubles in my 680? Do you think it could be that the sim card just has bad contact with the board? should I put some "tape" behind it to get it to push up against the phone more?

    why oh why does this have to happen
    Last edited by Matthew_Love84; 02/03/2007 at 01:16 AM.
  11. #11  
    My wife has seen this once, I haven't yet.. It's just a contact issue, perhaps similar to the old issue where one had to pad the sim tray on the 650.

    Maybe something similar would work.. Take a postit or something, fold it two layers deep, just smaller than the sim. put it in the slot under the card. Hopefully it won't get stuck ;-)
  12. #12  
    Quote Originally Posted by fondoo View Post
    i've been debating about purchasing a 680. the palm store has an unlocked 680 for $399. unbranded. now with cingular 2yr contract $199. i can pay an additional $30 to unlock it on the website. do you think its worth the $30 to unlock it yourself? once unlocked, does the tmobile or cingular still show up?
    Prefer the 650. Even pay a premium for it if necessary.
  13. #13  
    Quote Originally Posted by jsgreen View Post
    Glad you figured out the issue.

    I got the "check SIM" message after I dropped my 680 on a tile floor.....
    Don't do that.
  14. #14  
    Quote Originally Posted by Matthew_Love84 View Post
    I'm having this problem with my t-mobile sim card on a brand new unlocked 680. I'll make a call and 90% of the time it'll drop and i'll have a "check sim", i'll have to pull the sim and re-insert it to get back up and running. OR my phoen will drop service, and not try at all to get service back until i turn the phone off then back on again.

    How could my sim card work perfectly fine in my 650, then all of a sudden give me these troubles in my 680? Do you think it could be that the sim card just has bad contact with the board? should I put some "tape" behind it to get it to push up against the phone more?

    why oh why does this have to happen

    When my sim went bad I dropped by the t-mo store and they gave me a new one without question or charges. Just get another chip.
  15. #15  
    why would it work in my 650 without a hitch, but then give me all this drama ith my 680?

Posting Permissions