Installed the bundled version of DTG8 over my DTG7, didn't install the new programs on my Treo 650, but DTG no longer runs on my 650! Says that "this version wasn't designed for your device". WTF? I didn't upgrade the Treo 650's DTG at all. Upgrading the 650's DTG to v8 gets me the same message. Is there a workaround for this?

Works fine on my 680. Both are synced to the same computer under different users.