Results 1 to 19 of 19
  1. kmorris's Avatar
    Posts
    137 Posts
    Global Posts
    138 Global Posts
       #1  
    Well, like the rest of you I've been pretty excited awaiting the delivery of my unlocked 680....according to the Palm site my status is still a whopping 'order received'. Oh well.

    I don't know about you, but reading all these recent posts about 680 'issues' is starting to make me a bit nervous! Obviously no device is without flaws, but I really would hate to start off with a $400 device that has rumored volume, lagging, resetting, etc. issues. Guess that's what the 30-day trial is for!

    Gee, if this one doesn't work out, what's next? I already sold my Blackberry 8700g and am borrowing my mom's old Motorola v60 til the Treo arrives!
  2. #2  
    The one that is the most worrisome to me is the lag issue. I have seen that on other devices and it is severely annoying! The volume thing seems to be a fairly isolated issues, as some are saying it is much improved over the 650, and the resetting is probably due to 3rd party software and to be expected at this early stage.

    I absolutely despise WM5, but if the 680 doesn't work out I may have to go to a Blackjack or the Nokia E62. But I'm still optimistic that the 680 will be fine . . . if I ever actually get it!
  3. OnTheFly's Avatar
    Posts
    99 Posts
    Global Posts
    104 Global Posts
    #3  
    Issues? I really can't complain about issues. I have had no resets (other than day one with old OS4 software, which I have since updated) and as you can read from my post in the loudness thread, my phone is loud and incredibly clear. never had a phone so clear w/ such good reception. Never. My only "issue" is with poor video streaming, but without 3G what can I expect. No problems - I LOVE IT
    (ps - been using it for over a week!)
  4. #4  
    The lag issue is annoying and I have no 3rd party apps installed yet. So far, it doesn't happen that often. Annoying but tolerable.
  5. kmorris's Avatar
    Posts
    137 Posts
    Global Posts
    138 Global Posts
       #5  
    Quote Originally Posted by OnTheFly View Post
    Issues? I really can't complain about issues. I have had no resets (other than day one with old OS4 software, which I have since updated) and as you can read from my post in the loudness thread, my phone is loud and incredibly clear. never had a phone so clear w/ such good reception. Never. My only "issue" is with poor video streaming, but without 3G what can I expect. No problems - I LOVE IT
    (ps - been using it for over a week!)

    You're making me feel better! Good to hear your experience has been positive!
  6. #6  
    I was just about to pick one up for my wife, and now, I am going to wait. I would not be able to tolerate the lag; this really makes me appreciate a well working 650.
    at&t Treo 680, SW 2.11-ATT
    Cingular Treo 650 Unlocked, SW 1.17-CNG/FW 1.51
  7. #7  
    Isn't it possible that it is only a Cingular-branded 680 issue?

    Can anyone in the UK advise if they have a lag on their Palm unlocked 680s?
  8. PFman's Avatar
    Posts
    25 Posts
    Global Posts
    258 Global Posts
    #8  
    Quote Originally Posted by vks3 View Post
    Isn't it possible that it is only a Cingular-branded 680 issue?

    Can anyone in the UK advise if they have a lag on their Palm unlocked 680s?
    UK - unlocked - used it extensively today and no lag - sent 20+ text messages and 4 or 5 emails plus entered appointments and other items - no lag

    Have a crucial 2gb sd card and have loaded google maps, bewjewelled and some expense software from handango to try.....
  9. Danitaz's Avatar
    Posts
    295 Posts
    Global Posts
    296 Global Posts
    #9  
    Quote Originally Posted by mistercoffee1 View Post
    I was just about to pick one up for my wife, and now, I am going to wait. I would not be able to tolerate the lag; this really makes me appreciate a well working 650.
    Oddly enough, my T650 has a lag issue as well, which I've gotten used to over time - so I'm not sure that it's something totally "new" - I think it has to do with how much you use your Treo that makes you notice it - since mine is in my hand about 8 hours a day <g>, I'm sure that I notice EVERY time it lags or does something odd. It will be interesting to see if the 680 makes me crazy - but I doubt it.

    Danita
  10. #10  
    Quote Originally Posted by kmorris View Post
    ...but I really would hate to start off with a $400 device that has rumored volume, lagging, resetting, etc. issues.
    After a few days with it, I've noticed none of those issues.

    Compared to the 650 I had: volume is louder and clearer, lagging is about the same as the 650, and I've had no resets so far.

    The one thing I have noticed is that battery life is shorter compared to the 650.

    G
  11. #11  
    Quote Originally Posted by GeorgeP View Post
    The one thing I have noticed is that battery life is shorter compared to the 650.
    At the end of the day, what does your Battery meter read, and how does that compare with your 650 given the same usage?

    Quote Originally Posted by Danitaz
    Oddly enough, my T650 has a lag issue as well, which I've gotten used to over time - so I'm not sure that it's something totally "new"
    Interesting commments about the 650, mine has NEVER lagged (knock on wood). And it's not like I don't use it.
    at&t Treo 680, SW 2.11-ATT
    Cingular Treo 650 Unlocked, SW 1.17-CNG/FW 1.51
  12. #12  
    I've seen this lag a few times also, but it's much much less frequent than the on 700p. Certain things on the 700p would cause huge lags. Run Backupman then go into Blazer. Anywhere from 5 -15 second white screen lag. I don't see any lag in doing the same thing on the 680 (just like the 650).
    Main Phone: Treo 270/600/650/700w/700p/750v/Motorola Q/iPhone
    Tried but sold: Motorola Q/Nokia E61/700wx/HTC TyTN/Treo 680
  13. #13  
    The one thing I have noticed is that battery life is shorter compared to the 650.
    this is expected, the battery is smaller than the one that comes in the 650.
    Felipe
    On the road to 5,000 posts
    Life is what happens between Firmware releases.
  14. #14  
    Quote Originally Posted by mistercoffee1 View Post
    At the end of the day, what does your Battery meter read, and how does that compare with your 650 given the same usage? .
    Hard to say because I often keep it connected to a usb sync cable, which also charges it. My very unscientific guess is that I'm getting between 1/2 and 2/3 of what I was getting with the 650 (based on movement of the battery meter).

    I've read conflicting things about care of lithium batteries. Some sources say that even lithium batteries benefit from a few initial full charge/discharge cycles (charge to 100%, then run to cut-off point). Other sources say, it's best just to keep it topped off. But there seems to be general agreement that a periodic full discharge of a lithium recalibrates the meter.

    Quote Originally Posted by mistercoffee1 View Post
    Interesting commments about the 650, mine has NEVER lagged (knock on wood). And it's not like I don't use it.
    Be careful now, you don't want go and jinx yourself

    I saw the lag very rarely with the 650, and have only noticed it once that I remember on the 680.

    G
  15. #15  
    Been using it a full day in business non stop.
    Fantastically AWESOME!!!!!!!!!!!!!!!!!!
    Bravo I say. And the sound quailty.................it is the best, really crystal clear and NO buzzing.....
    Only thing is that it did not work consistently with the BT headset Motorola H700 now back using the 850. Awesome
  16. #16  
    When I was getting my 650 (I had to wait a few weeks to scrape together $250) I was reading this forum thinking "do I really want to get this thing??" from all the posts about crashes, resets, bad hardware, bad keyboards, etc..

    I've never had a problem from my 650 aside from the occasional crash from dbcache (fixed in recent FW) or bad software.

    I suspect the same is true for the 680; the noise is a lot louder than reality.
  17. #17  
    In my experience, there is a certain percentage of upgraders who don't follow directions; they also tend to be quite vocal.
  18. #18  
    I haven't had any problems and I didn't do anything special moving from my 650. I deleted a couple of programs that I thought might not work. Hotsynced my 650, then hotsynced my 680 with the same userid.


    I have noticed the lag.
    If I throw a stick, will you go away?
  19. #19  
    Don’t know what to do ….

    I haven’t upgraded my Treo 600 to the 650 and decided to skip the 650. The 650 is HORRIFIC, it lags so much compared to the 600. When you switch from apps to apps, sometimes it’s just sitting there and yoru tapping on every app to see what’s going on. Next thing you know, something happens ... it runs threw all the apps you’ve tapped. If you take a look and have a race with the switching to camera mode, the 600 is instant and the 650 takes 2 – 3 secs. I’m assuming it takes too long to process things, b/c of the high res screen. I really don’t get it though, the CPU was boosted 2x faster. Finally, this drove me nuts … sometimes if your wireless mode is on and there’s has not been any activity, you look at it again and it says you missed 10 calls.

    I’ve borrowed 2 diff units of the 650 from my boss, and tested it for 2 weeks each, and for all the reason above, I didn’t upgrade. Thank God, my Treo 600 ran perfectly, even from today. I’m starting to get the classic buzzing now, but hey … I’ve had this unit for 2.5yrs now and getting a replacement battery on the weekend.

    I’m really exited about the 680, but reading the battery life and more lag time then the 650, I really don’t know what to do. No way in hell will I go with Window’s Mobile Treo. You think Palm is gonna fix the battery life in the next generation of 680? Is the lag gonna be fixed or not? The specs are pretty close to 650.

    Any advice will be appreciated.

Posting Permissions