Page 2 of 2 FirstFirst 12
Results 21 to 26 of 26
  1. iDG
    iDG is offline
    iDG's Avatar
    Posts
    37 Posts
    #21  
    Quote Originally Posted by RichieB View Post
    Please note that this autocorrect hack for the Treo 680 can cause random characters using the Alt key as I reported here. I'm not sure why, but this file is also responsible for the Alt key characters.
    The malfunction is caused by the fact that the "replacement" HsExtensions2.0_enUS.prc may be moved around in memory due to the NVFS weirdness. I've written a small program that after the reset locks all the resources in memory, fixing the problem.

    But I can't seem to upload it as attachment...
  2. #22  
    Quote Originally Posted by iDG View Post
    The malfunction is caused by the fact that the "replacement" HsExtensions2.0_enUS.prc may be moved around in memory due to the NVFS weirdness. I've written a small program that after the reset locks all the resources in memory, fixing the problem.
    Oh, but your program doesn't really address the reseting problems I've seen, right?

    // Egholm
  3. #23  
    Quote Originally Posted by Egholm View Post
    So, swedenliketreo - we need a new update, now with the recent 680 1.12 update :-)
    SergioA beat you to it - here:
    http://discussion.treocentral.com/sh...d.php?t=160110

    // Egholm
  4. #24  
    Quote Originally Posted by iDG View Post
    The malfunction is caused by the fact that the "replacement" HsExtensions2.0_enUS.prc may be moved around in memory due to the NVFS weirdness. I've written a small program that after the reset locks all the resources in memory, fixing the problem.

    But I can't seem to upload it as attachment...
    Hi iDG, I can confirm that even with the new Centro (I've made a customized HsExtensions2.0_enUS.prc to get rid of "i"->"I" and "il"->"I'll") each time the system flushes the DBCache (that seems smaller than the one of the Treo680) to make space for big programs (e.g. TomTom) the "random characters using the Alt key" syndrome is back; the only way to solve this is to soft reset...

    I'm trying to find a way to lock HsExtensions2.0_enUS.prc in memory...

    RescoLock (freeware at http://www.resco.net/palm/locker/default.asp) lets you lock HsExtensions2.0_enUS.prc, I've done it right now; will let you know if it works :-)

    Ciao for now!

    Sergio

    PS: can you give us more details about your small program?
    Last edited by SergioA; 03/19/2008 at 03:47 AM.
  5. #25  
    I've been using a RescoLock-ed hacked version of HsExtensions2.0_enUS.prc on my Treo 680 for a month or so. I've had no more problems with the alternative characters. Great tip, thanks iDG / SergioA.
  6. #26  
    Quote Originally Posted by SergioA View Post
    RescoLock (freeware at http://www.resco.net/palm/locker/default.asp) lets you lock HsExtensions2.0_enUS.prc, I've done it right now; will let you know if it works :-)
    Ops, it doesn't work... On my Centro, each time the system flushes the DBCache (or at least I think so, about 30 secs of delay when launching big apps), the random characters are back...

    Sergio
Page 2 of 2 FirstFirst 12

Posting Permissions