Results 1 to 13 of 13
  1.    #1  
    I am seeing this behavior that Marc is unable to reproduce. I wanted to see if others are seeing it. I am running Chatter 2.2b23.

    I have 3 accounts:
    EX plugin
    my ISP (POP3)
    Gmail (POP3)

    I don't know if having an IMAP account affects this behavior.
    I have scheduled qsyncs set up to happen every 15 minutes. My Treo's data connection is almost always on.

    If I have Chatter running and turn off the screen (red button), then the scheduled syncs do not take place. If the screen is off with some other application (or Applications launcher) running, the syncs happen correctly. The syncs also happen correctly if the screen is on, regardless of which application is on-screen.

    Am I alone in this?
    --
    Aloke
    Cingular GSM
    Software:Treo650-1.17-CNG
    Firmware:01.51 Hardware:A
  2. #2  
    My wife polls one POP and one IMAP account and it does its thing. I poll two IMAP accounts and it does its thing. Ben
  3.    #3  
    Have you specifically checked this by invoking Chatter and then switching the screen off?
    --
    Aloke
    Cingular GSM
    Software:Treo650-1.17-CNG
    Firmware:01.51 Hardware:A
  4. #4  
    I currently have 1 IMAP account online and 1 POP account (Gmail) polining every 30 mins. All works as it should, screen on, off, etc...
    CGordonn
    SPCS Treo 700p
    Virginia Beach, VA but home will
    always be Honolulu, HI
  5.    #5  
    Sigh!

    Mine just stays put if chatter is on-screen when I switch the screen off.

    As soon as I wake up the Treo (and disable the keyguard), it logs-in and proceeds to catch up with the queued sync that it never did.

    Maybe this is a ROM-specific thing. Mine is listed in my signature.
    --
    Aloke
    Cingular GSM
    Software:Treo650-1.17-CNG
    Firmware:01.51 Hardware:A
  6. #6  
    Do you have "No Doze" checked in the Performance prefs? Just a thought.

    Marc
  7.    #7  
    No. Here are my settings:

    Performance:
    Nothing checked
    Latency: More
    Updates to Server: Fast
    Signal reqd : Good Signal

    System:
    Everything checked except "Default to Butler" and "Keep LED off"

    Connections:
    Only "Trust SSL Cert." is checked
    --
    Aloke
    Cingular GSM
    Software:Treo650-1.17-CNG
    Firmware:01.51 Hardware:A
  8.    #8  
    To preserve my sanity, more than anything else, I decided to do a real and thorough test of this problem:

    In everything described below, switch Treo off = switch off the screen with the red button.

    1. I backed up my Treo, emptied the Backup Folder
    2. Did a hard reset and synced back to the same hotsync name. Now I have a sqeaky clean Treo with no 3rd party software whatsoever.
    3. Installed Chatter 2.2b26
    4. It discovered my mailboxes on the SD card and offered to import them. I politely declined and deleted the mailbox from the card. I now have a queaky clean Chatter, with all default settings.
    5. It went to the screen to define an account. I set up the EX server account. It is an offline account. The only option I set was to Qsync it every 10 minutes. This is the only account I created, for now.
    6. I left Chatter on-screen and switched off the Treo (red button). Let's see if that works.
    7. It just did!! Success! Just to be thorough, I'll leave Applications on-screen and turn off the Treo. Let's see if that sync occurs.
    8. Yup. It just did.
    9. Now I'll check the box to store all messages on the SD card. I then use the Mailbox utilities to re-load the mailbox. I don't tknow that this should matter, but I had set up my accounts this way (to store msg on SD card) and I might as well verify that this does or does not make a difference. I leave Chatter on-screen and turn off the Treo. And wait.
    10. Aaargh! it did not!!! The scheduled time came and the Treo did not sync on time. As soon as I switched the screen on and disabled the keyguard, it initiated the sync, 3 minutes late. Let's try this one more time .. leave chatter on-screen and turn off the Treo. and Wait.
    11. Again, the sync DID NOT take place at the expected time. I wait 5 minutes to make sure .. then trun on the Treo, disable the keyguard, and Bingo! the sync occurs. Now what?
    12. I clear the "Store on SD card" box and re-load the mailbox. Will the behavior correct itself? Leave chatter on-screen and switch off. We wait and find out.
    13. It did not sync on time :-(. It did when I turned on the Treo.
    14. I delete the mailbox and set it up again. This time, like before, I DO NOT check the "Store on SD Card" box. I only change the setting to sync it every 10 minutes. It re-downloads my e-mails. I switch off the screen and wait.
    15. That did not fix it. The syncs are not ocurring with Chatter on-screen and screen switched off.
    16. I switch out of Chatter to Applications and get a reset! MemoryMgr.c Line:3877, Invalid chunk ptr.
    ----------------
    16. Another hard reset, sync, reinstall Chatter. I'll experiment now with a POP3 account to see it's behavior.
    17. I set up my ISP (Generic POP3) and the ONLY setting I change is to make it qsync every 5 minutes. The mailbox is empty (there were no unread messages on the server). Leave Chatter on-screen and switch off the Treo.
    18. Yes!! It syncs on time! Let's try this one more time... Chatter is on-screen and the screen is switched off.
    19. It did. Now, I check the "Store on SD card" box. Will it sync?
    20. It did. I re-download the mailbox (Mailbox utilities). And wait.
    21. It synced! I now send myself a test e-mail from Outlook Express. This will populate the mailbox with a message on the next sync.
    22. It synced in the background. I now have an e-mail in the mailbox. The mailbox is being stored on the SD card. Will it sync in the backgroud? We wait.
    23. It syncs.
    So what's the bottom line? POP3 account did not exibit the bug. Maybe that was because the mailbox was empty during most of the tests?
    ----------------
    24. Another hard reset, sync, reinstall of Chatter.
    25. This time, I'll define the POP3 account and select the "store on SD card" from the get-go. So, the only changes to settings are that and sync every 5 minutes.
    26. I have 3 messages on the server.
    25. Sync in the background is NOT working!!
    26. Confirmed that if Chatter is on-screen and screen turned off, the sync does not occur. To repeat: this is a POP3 account with mailbox stored on the card.
    -------------
    Final test will be of an EX account with store on card set from the get-go.
    27. Set up the EX account with "store on SD card" checked and sync every 5 minutes. The server has e-mails, so the mailbox (stored on card) has a few e-mails. Will it sync on time?
    28. It DOES NOT sync on time.

    Summary: In it's simplest terms:
    a) On a clean Treo (Hard reset follwed by fresh install of Chatter2.2b26, all default settings),
    b) with EX account and with POP3 account,
    c) if the mailbox is stored on the SD card, and has some messages in it,
    d) if Chatter is left on-screen and the screen is turned off
    e) then Chatter will not sync when it is supposed to
    f) It will sync if the screen is turned back on and keyguard is disabled.
    g) It will sync if some other application is on-screen and the screen is turned off
    h) It will sync if the screen is on, regardless of which application on-screen.

    I will now restore the Treo to the state it was before I started this testing.
    Hopefully my 4 hours of labor (of love) will help Marc figure out what's going on...
    --
    Aloke
    Cingular GSM
    Software:Treo650-1.17-CNG
    Firmware:01.51 Hardware:A
  9. #9  
    Does "No Doze" affect the behavior? Try turning it on.

    Marc
    Last edited by Chatter; 11/26/2006 at 11:07 PM.
  10.    #10  
    That seems to have fixed the problem!!

    What the heck does this option do? It should be checked by default, IMO.
    --
    Aloke
    Cingular GSM
    Software:Treo650-1.17-CNG
    Firmware:01.51 Hardware:A
  11. #11  
    Maybe so; but very few devices seem to suffer from this problem. I'll think about it.

    Marc
  12.    #12  
    It was interesting that this behavior was triggered by mailbox getting stored on the SD card..

    Checking "No doze" has increased my battery consumption a little bit.
    --
    Aloke
    Cingular GSM
    Software:Treo650-1.17-CNG
    Firmware:01.51 Hardware:A
  13. #13  
    Your battery consumption is probably up because it's working properly.

    Marc

Posting Permissions