Results 1 to 17 of 17
  1.    #1  
    Well I just got an unlocked treo 650 for tmobile and I'm having some problems with it.

    I insert my SIM card and it recognizes the network with no problems and I can make calls, but I can't seem to be able to receive calls or msgs .... they just wont go trough... I even tried calling my phone from another phone and it goes straight to the voicemail as if the phone was off... but the phone option on the treo is on the ON position.
    Am I doing something wrong ? or missing something ?

    Also, like in my previous phones (blackberry 7100g and RAZR) I was able to retrieve my inbox SMS msgs from my SIM card, but I can't find a way to do it with the treo.

    Any help is greatly appreciated.
  2. #2  
    The switch is to turn the ringer off (silent mode). When the Treo screen is displayed, hold down the red phone button to the right of the D Pad for several seconds. This will turn the phone radio on. To turn the phone radio off, you hold the red button down again for several seconds.

    There are apps that will turn your radio on automatically at boot. I used Chatter email to do it in my case when I had a 700p.
    Treo 600 > Treo 650 > Treo 700p > Treo 700wx -> Mogul -> Touch Pro
    You may like to flash, but your phone shouldn't. LED Killer
  3. #3  
    Disregard my last posting as I see you can make calls. I've only experienced issues like that when I got a new SIM. The phone would dial, but calls would try to go to the old SIM for about 30 minutes after the switch.
    Treo 600 > Treo 650 > Treo 700p > Treo 700wx -> Mogul -> Touch Pro
    You may like to flash, but your phone shouldn't. LED Killer
  4. ion++'s Avatar
    Posts
    299 Posts
    Global Posts
    310 Global Posts
    #4  
    As for SMS i do not think you can access any of your saved SMS messages, but any new and unread messages will be copied to your messaging application. At least that how it works for me.

    About phone calls. Press the phone button and switch to the phone application.
    Press the menu button and choose the options menu.

    select "Call Barring" and press the [ GET STATUS] button.
    It should say "None" in both. Press [ OKAY ] button.

    press [ MENU ] button, choose the options menu
    Select "Call Preferences" and press the [ GET STATUS ] button.

    After that it should be self explination, but you'd probably want

    "dont forward calls"

    When busy +voicemail
    not answered +voicemail
    off/no service +voicemail

    [ ] Disable call waiting (not chosen)
    [ ] Block outgoing caller ID (not chosen)

    At least thats my setup.
  5. #5  
    Quote Originally Posted by ion++ View Post
    <snip>
    Press the phone button and switch to the phone application.
    Press the menu button and choose the options menu.

    select "Call Barring" and press the [ GET STATUS] button.
    <snip>
    So are these options only available on an unlocked 650? (I'm using a Cingular 650)
  6.    #6  
    Thanks for the replies guys.

    Tried the phone again and this time magically there was a message that said that i could transfer all my sms messages to the phone....

    but as far as the incoming calls and messages still the same .... i checked the settings that ion posted and everything seems fine.

    So I can make calls but not receive any .... anything else i'm missing ??

    thanks a lot !
  7. ion++'s Avatar
    Posts
    299 Posts
    Global Posts
    310 Global Posts
    #7  
    Quote Originally Posted by JimmyD View Post
    So are these options only available on an unlocked 650? (I'm using a Cingular 650)
    I dunno, but my treo is unlocked bought from a Danish webshop, i suppose they got it from a distributor who got it from Palm. My software is Treo650-1.20-ENA

    phone app, press [ MENU ] button, choose options, choose phone info
  8. ion++'s Avatar
    Posts
    299 Posts
    Global Posts
    310 Global Posts
    #8  
    Quote Originally Posted by dimartin84 View Post
    Thanks for the replies guys.

    Tried the phone again and this time magically there was a message that said that i could transfer all my sms messages to the phone....

    but as far as the incoming calls and messages still the same .... i checked the settings that ion posted and everything seems fine.

    So I can make calls but not receive any .... anything else i'm missing ??

    thanks a lot !
    Try with a different simcard, possibly from a different phone company and test if that works.
    Try your simcard in a different treo, or a different phone.
    Call your phone company and ask them. Maybe the simcard is not fully transfered.
  9. #9  
    Quote Originally Posted by ion++ View Post
    I dunno, but my treo is unlocked bought from a Danish webshop, i suppose they got it from a distributor who got it from Palm. My software is Treo650-1.20-ENA

    phone app, press [ MENU ] button, choose options, choose phone info
    ahhh... maybe I just need to update my software... I'm running: Treo650-1.15-CNG

    ok... enough about my issues... sorry to temporarliy hijack this thread... back to dimartin84's incoming call problems.
  10.    #10  
    Well ... I just called Tmobile and they weren't much help .... they first said that because then don't support the 650... I called again and they just said they couldm't help me because the phone was a cingular phone.
  11. ion++'s Avatar
    Posts
    299 Posts
    Global Posts
    310 Global Posts
    #11  
    Quote Originally Posted by dimartin84 View Post
    Well ... I just called Tmobile and they weren't much help .... they first said that because then don't support the 650... I called again and they just said they couldm't help me because the phone was a cingular phone.
    Well try the other things i suggested. A different simcard in your phone, and a different treo.
  12.    #12  
    Quote Originally Posted by ion++ View Post
    Well try the other things i suggested. A different simcard in your phone, and a different treo.
    unfortunately I don't know anybody with a treo.... I did try my roomate's tmobile sim car on my treo and it has the same problem... I also know my sim is working cause I have it on my blackberry right now since the treo is not working for me.

    any more ideas ? ... thanks for all the help so far !
  13. ion++'s Avatar
    Posts
    299 Posts
    Global Posts
    310 Global Posts
    #13  
    Did you try actually changing the forwarding to voicemail, test that, change it back and test again? Try with all forward options.

    Is your roommates simcard from the same phone company? Where did you get your treo from? I would try more simcards from other companies.

    I would try a full hard reset that returns the treo to the factrory ROM. Read on palms site how to do that.
  14.    #14  
    Quote Originally Posted by ion++ View Post
    Did you try actually changing the forwarding to voicemail, test that, change it back and test again? Try with all forward options.

    Is your roommates simcard from the same phone company? Where did you get your treo from? I would try more simcards from other companies.

    I would try a full hard reset that returns the treo to the factrory ROM. Read on palms site how to do that.
    yep .. tried changing the settings and got nothing.

    My roommate's SIM is from the same provider (Tmobile) and actually a newer SIM than mine and still have the same problem.

    Unfortunately I don't know anybody else around me that uses SIM card .. most of them have verizon or sprint.

    Tried de hard reset and still nothing .
  15.    #15  
    any more suggestions guys ??
  16. #16  
    You need to contact Palm support.
    <br>
    "What counts most in creating a successful team is not how compatible its players are, but how they deal with incompatibility." - Sports Illustrated
  17. #17  
    My T-Mo was doing exactly that at first and a new SIM card fixed it.

Posting Permissions