Results 1 to 4 of 4
  1.    #1  
    Sorry for generating a new thread in this already crowded discussion section, but I'm having a specific problem with my Plantronics Discovery 655 headset and was looking for some help. My problem lies in the fact that the connection generated between my Treo 700p and my 655 headset fails to broadcast my voice. So, I can hear everyone talking to me, but they can't hear me. I tested to see if it was the mute function on the headset or just a low audible volume, but it was neither of those. After checking with the Plantronics website and their connection guide, I noticed that my Treo skips a step. The Plantronics website says that at the end of the connection process there should be a final screen that allows me to choose what kind of bluetooth device I am connecting; whether it be a headphones system, headset system, etc. Besides the lack of this final screen, I also checked the Palm website and saw that Palm says the Treo 700p does not officially support the Plantronics 655 headset.
    Any help or advice anyone can give me on this issue would be greatly appreciated.
  2. #2  
    Mine works fine with my treo 650. Maybe your mic is clogged?
  3.    #3  
    No, I tested the headset another phone, some sort of motorola, and it connected fine and worked properly.
  4. #4  
    I've had a similar problem with my Jabra BT500. Try turning bluetooth off on the phone, then reenabling it. If that doesn't do the trick, try removing the trusted device and try again. It appears that when the headset is turned off, the phone sorta half forgets that the headset is there. Thus resulting in the "I can hear them, but they can't hear me" thing.

Posting Permissions