Page 16 of 25 FirstFirst ... 61112131415161718192021 ... LastLast
Results 301 to 320 of 481
  1. #301  
    I use cygwin under windows because at the moment Universe requires multilink to compile. I am trying to get multilink to build under the MacOS X (and it should also build under linux) so that I don't have to boot into Windows to compile. So far I have been unsuccessful in getting multilink to compile under MacOS X.
    Maybe that is a small way I can help out for now. If I can get multilink to work on Linux it should work on OS X for you. Do you have a pointer to the version you are using as a starting point?

    Well, I grabbed (the latest?) multilink 0.3 and adding these 3 lines to the top of multilink.c lets it compile:
    /* what it took to get multilink 0.3 to compile on opensuse 10.2 */
    /* BUT! I don't have an app to try it; if it doesn't work I can find one and try it */
    #define _raw_size rawsize
    #define false 0
    #define bfd_get_section_size_before_reloc(section) ((section)->_raw_size)

    Let me know if getting it to work correctly on OSX is that easy :-)
    Last edited by kedl; 03/13/2007 at 02:15 PM.
  2. drensin's Avatar
    Posts
    39 Posts
    Global Posts
    41 Global Posts
    #302  
    The browser is great. Works on my Treo 650 now. Pretty fast if I eliminate loading pictures. I can tell that as the refinement process continues, this will be an exemplary tool that WE'VE ALL BE WAITING FOR! Thanks.

    A couple comments:
    when loading a page, the five way works, going one line at a time, but the page bar doesn't until everything's loaded....

    also, consider for a future add the ability to check, in preferences, if we want the five way down to go a line or page at a time.

    pardon my naivete, but would you briefly explain private browsing?

    thanks, great work.
  3. #303  
    nice work, your web browser was mentioned in PDA Essentials and is mentioned as one of the better browsers. That's huge. congrats.
  4.    #304  
    Quote Originally Posted by kedl View Post
    Maybe that is a small way I can help out for now. If I can get multilink to work on Linux it should work on OS X for you. Do you have a pointer to the version you are using as a starting point?

    Well, I grabbed (the latest?) multilink 0.3 and adding these 3 lines to the top of multilink.c lets it compile:
    /* what it took to get multilink 0.3 to compile on opensuse 10.2 */
    /* BUT! I don't have an app to try it; if it doesn't work I can find one and try it */
    #define _raw_size rawsize
    #define false 0
    #define bfd_get_section_size_before_reloc(section) ((section)->_raw_size)

    Let me know if getting it to work correctly on OSX is that easy :-)
    Thanks.

    I think my issue was getting a libbfd to work. I had to get the binutils and the prc-tools source and compile them together and then use the results with multilink. Unfortunatly, I could not get prc-tools to compile fully.

    I'll play with it some more.
  5.    #305  
    Quote Originally Posted by smileyboy View Post
    nice work, your web browser was mentioned in PDA Essentials and is mentioned as one of the better browsers. That's huge. congrats.
    As in the PDA Essentials Magazine!! I'll have to check that out this weekend.

    If they mention it as one of the better browsers they will love the next RC. It will be much faster.
  6.    #306  
    Quote Originally Posted by drensin View Post
    The browser is great. Works on my Treo 650 now. Pretty fast if I eliminate loading pictures. I can tell that as the refinement process continues, this will be an exemplary tool that WE'VE ALL BE WAITING FOR! Thanks.

    A couple comments:
    when loading a page, the five way works, going one line at a time, but the page bar doesn't until everything's loaded....

    also, consider for a future add the ability to check, in preferences, if we want the five way down to go a line or page at a time.
    Ok. I'll look into that. Are you in the mode with the pointer or plain scrolling?

    pardon my naivete, but would you briefly explain private browsing?

    thanks, great work.
    Private browsing will mask cookies, history and the cache. If it is enabled it you can browser to different websites (like normal) and then when you disable it it will remove all traces of the sites that you just browsed to. It is like the private browsing feature on Safari.
  7. #307  
    Quote Originally Posted by dkirker View Post
    Thanks.

    I think my issue was getting a libbfd to work. I had to get the binutils and the prc-tools source and compile them together and then use the results with multilink. Unfortunatly, I could not get prc-tools to compile fully.

    I'll play with it some more.
    I downloaded your src and it compiles under Linux (with a bunch of fiLeNaMe changes), but it doesn't like the objects when multilink runs. So, my fix may not be good enough. (error is:"Found non-object in archive" for all .a and .o files). I'll keep looking at that too.
  8.    #308  
    Quote Originally Posted by kedl View Post
    I downloaded your src and it compiles under Linux (with a bunch of fiLeNaMe changes), but it doesn't like the objects when multilink runs. So, my fix may not be good enough. (error is:"Found non-object in archive" for all .a and .o files). I'll keep looking at that too.
    What filenames did you change?
  9. drensin's Avatar
    Posts
    39 Posts
    Global Posts
    41 Global Posts
    #309  
    Quote Originally Posted by dkirker View Post
    Ok. I'll look into that. Are you in the mode with the pointer or plain scrolling?

    I'm in scrolling mode. I haven't much used the pointer.

    Private browsing will mask cookies, history and the cache. If it is enabled it you can browser to different websites (like normal) and then when you disable it it will remove all traces of the sites that you just browsed to. It is like the private browsing feature on Safari.
    Not familiar with Safari, but in essence it cleans out cookies/history/cache automatically...thanks.

    another suggestion: I think a signal strength indicator would be helpful. It's the only thing I like about Blazer --

    Again, I really like Universe. I've been sitting on the sidelines, jealous of the beta-testers. I've already deleted Opera Mini (I used desktop Opera and love it!). Blazer's sidelined; even WebPro, the version ported from the TX (I think); Xiino also.

    Finally: Will we have to delete Universe-URL everytime there's an update? Will there be a way to save bookmarks between updates?
  10. #310  
    Quote Originally Posted by dkirker View Post
    What filenames did you change?
    I was in a hurry just to get things to compile so I didn't keep an exhaustive list; but there were a lot to change. I can delete my version and start over and build a complete list. But since you compile in Windows, it doesn't care about case. I don't have it installed in a fat filesystem so Linux cares. Some of the prc includes and some of your files didn't agree with what the filesystem shows (Common/stuff.h is not the same as common/Stuff.h in Linux, it is the same in Windows).

    I am able to completely compile/link/run the program now. But I see it is the version prior to your 650 fix and debug remove so it crashes on my 650 after counting to 6.

    Do you have the current version available to download? I can install it and fix/tell you what the filenames to update are.
  11. #311  
    Okay, I don't know what I did, but Universe would will no longer let me get on treo.discussion.treocentral.com I signed on with the browser and posted a comment, then closed the browser, and then every time I tried to load this site it soft reset on me! I could get to other sites fine, but every time I went to this site's mobile version, it would reset. I tried clearing the cache, cookies, and history but to no avail. I then went into Filez and deleted the Cookie Jar, and that didn't work. I finally went into FileZ and deleted the Universe Cache and that got me going again. I'm guessing the Clear cache and Clear History and Clear Cookies buttons don't really work as they're supposed to. I dunno. I'm just glad I can browse again!
  12.    #312  
    Quote Originally Posted by drensin View Post
    Not familiar with Safari, but in essence it cleans out cookies/history/cache automatically...thanks.

    another suggestion: I think a signal strength indicator would be helpful. It's the only thing I like about Blazer --

    Again, I really like Universe. I've been sitting on the sidelines, jealous of the beta-testers. I've already deleted Opera Mini (I used desktop Opera and love it!). Blazer's sidelined; even WebPro, the version ported from the TX (I think); Xiino also.

    Finally: Will we have to delete Universe-URL everytime there's an update? Will there be a way to save bookmarks between updates?
    No, you will not have to delete the Universe-Urls file all of the time. That was because of the NVFS bug that the latest version fixes (basically, with the last version, a user would install Universe, run it and it would create the URL database. then their device would crash, and the URL database would be wiped clean because the changes had not been saved. Now the changes are saved).
  13.    #313  
    Quote Originally Posted by Musicman247 View Post
    Okay, I don't know what I did, but Universe would will no longer let me get on treo.discussion.treocentral.com I signed on with the browser and posted a comment, then closed the browser, and then every time I tried to load this site it soft reset on me! I could get to other sites fine, but every time I went to this site's mobile version, it would reset. I tried clearing the cache, cookies, and history but to no avail. I then went into Filez and deleted the Cookie Jar, and that didn't work. I finally went into FileZ and deleted the Universe Cache and that got me going again. I'm guessing the Clear cache and Clear History and Clear Cookies buttons don't really work as they're supposed to. I dunno. I'm just glad I can browse again!
    Hmmm. Strange. I'll have to see if I can reproduce this.

    If you can reproduce this, try clearing the cache, then exiting the browser.

    It might be an NVFS thing.
  14.    #314  
    Quote Originally Posted by kedl View Post
    I was in a hurry just to get things to compile so I didn't keep an exhaustive list; but there were a lot to change. I can delete my version and start over and build a complete list. But since you compile in Windows, it doesn't care about case. I don't have it installed in a fat filesystem so Linux cares. Some of the prc includes and some of your files didn't agree with what the filesystem shows (Common/stuff.h is not the same as common/Stuff.h in Linux, it is the same in Windows).

    I am able to completely compile/link/run the program now. But I see it is the version prior to your 650 fix and debug remove so it crashes on my 650 after counting to 6.

    Do you have the current version available to download? I can install it and fix/tell you what the filenames to update are.
    Try the link on the website again. I realized today after I was testing out part of the new HTTP engine (which I might add is pretty fast) that I had not properly named the new sources.
  15. #315  
    Well, I am trying to reproduce the error. So far I haven't been able to. Got a random reset when I signed in to the forum, but this time I'm on and able to post it looks like. We'll see if it still works when I come back.
  16. hofs1's Avatar
    Posts
    460 Posts
    Global Posts
    473 Global Posts
    #316  
    Quote Originally Posted by drensin View Post
    Not familiar with Safari, but in essence it cleans out cookies/history/cache automatically...thanks.

    another suggestion: I think a signal strength indicator would be helpful. It's the only thing I like about Blazer --
    i asked for the signal meter durring beta testing but it wasnt a big deal then but now that the browser is going live i think its time donald revisits it now that the data spinner thing goes on each tab i do beleive the signal meter would fit well in the old spinner spot the only other thing needed to KILL blazer would be css to make things look pretty cause we all know people want things just all nice and fuzzy.
  17. #317  
    http://www.roughlydrafted.com fails to load with a Bad Request error "Your browser sent a request that this server could not understand. The request contained invalid charecters following the protocol string."

    Apache/1.3.33 Server as www.roughlydrafted.com port 80

    Otherwise, getting better.
    Last edited by Group51; 03/13/2007 at 06:44 PM. Reason: err
  18. #318  
    OK, the newer version compiles and runs.
    Here are the changes (no diff for these small changes) to your code internally. I will have to reinstall the tools to get the rest of the include file changes because I created a ton of links to get them to work.

    disable sony since I don't have their SDK:
    - comment out Makefile lines containing sony
    - comment out line src/config.h containing sony

    fix src case:
    - src/wmls.c: change Url.h to URL.h
    - src/Cache.c: change cache.h to Cache.h
    - src/Pointer.c: change HyperLinks.h to Hyperlinks.h
    - src/FiveWay.c: comment out vchrHardRockerCenter add #include <common/system/HsKeyCommon.h> to #ifdef HAVE_PALMONE_SDK section
    - res/Universe.rcp: change loadImagehires.bmp to loadImageHires.bmp
    - res/Universe.rcp: change topLeftcornerlores.bmp to topleftcornerlores.bmp
    - add -L/palmdev/palmOneSDK/lib/m68k-palmos-coff/ to Makefile in MULTILINKFLAGS

    fix tools case:
    (later)


    I'll also mention that mobetube.com doesn't work right and I haven't had a chance to really start looking at the code yet. A search results in a broken URL (about:blank?search_query=stuff)

    Also, I use mail.charter.net for my email and is a framed page. Does this browser even do frames? Only the main frame loads first, then after I login, if I select messages just that frame appears and the page keeps refreshing every few seconds moving thru my entire mailbox like I had pressed "next page" over and over! Again, haven't had time to actually look at the code yet; just got it compiling :-)
  19.    #319  
    Quote Originally Posted by hofs1 View Post
    i asked for the signal meter durring beta testing but it wasnt a big deal then but now that the browser is going live i think its time donald revisits it now that the data spinner thing goes on each tab i do beleive the signal meter would fit well in the old spinner spot the only other thing needed to KILL blazer would be css to make things look pretty cause we all know people want things just all nice and fuzzy.
    You must have read my mind GET OUT!!! Sorry, I don't like people playing with my head

    Believe me, JavaScript and CSS are on the map. I am currently working Universe so that it will be able to handle these medias.
  20.    #320  
    Quote Originally Posted by kedl View Post
    OK, the newer version compiles and runs.
    Here are the changes (no diff for these small changes) to your code internally. I will have to reinstall the tools to get the rest of the include file changes because I created a ton of links to get them to work.

    disable sony since I don't have their SDK:
    - comment out Makefile lines containing sony
    - comment out line src/config.h containing sony

    fix src case:
    - src/wmls.c: change Url.h to URL.h
    - src/Cache.c: change cache.h to Cache.h
    - src/Pointer.c: change HyperLinks.h to Hyperlinks.h
    - src/FiveWay.c: comment out vchrHardRockerCenter add #include <common/system/HsKeyCommon.h> to #ifdef HAVE_PALMONE_SDK section
    - res/Universe.rcp: change loadImagehires.bmp to loadImageHires.bmp
    - res/Universe.rcp: change topLeftcornerlores.bmp to topleftcornerlores.bmp
    - add -L/palmdev/palmOneSDK/lib/m68k-palmos-coff/ to Makefile in MULTILINKFLAGS

    fix tools case:
    (later)


    I'll also mention that mobetube.com doesn't work right and I haven't had a chance to really start looking at the code yet. A search results in a broken URL (about:blank?search_query=stuff)

    Also, I use mail.charter.net for my email and is a framed page. Does this browser even do frames? Only the main frame loads first, then after I login, if I select messages just that frame appears and the page keeps refreshing every few seconds moving thru my entire mailbox like I had pressed "next page" over and over! Again, haven't had time to actually look at the code yet; just got it compiling :-)
    I am surprised that those miss-typed names weren't caught...

    No, no frames. I am working on a new engine that can support multiple html "pages" in one window (i.e. frames and iframes).

    I look at mobetube.

    Some of that code is pure ugly and I hate being the one that wrote some of it. I am working on redoing that too. Basically I am earthquake proofing a building.

Posting Permissions