Results 1 to 5 of 5
  1.    #1  
    I purchased one of these probably about 2mo ago:

    http://www.newegg.com/Product/Produc...82E16820211309

    I popped it in my Treo 650 then I never used it for a couple months.. Unfortunatly, I dont use my Treo much.. So anyway, today I decided I was going to start getting things in order on it so I can use it exclusively and it seems as if the SD card has died on me. The Treo recognizes the card when I put it in and it shows some files on it.. Well, I try to format the card and it says "Format Failed".. I tried to format it on my laptop and it fails. I've tried to install software on it and it fails. I checked and its not in write only mode...

    Did I get what I paid for or might there be something else wrong??
  2. gw1
    gw1 is offline
    gw1's Avatar
    Posts
    58 Posts
    Global Posts
    60 Global Posts
    #2  
    Could just be a dud card - I'd try warranty replacement
  3. #3  
    Make sure the switch is in the "unlocked" position.
  4.    #4  
    Quote Originally Posted by o_town_racer View Post
    Make sure the switch is in the "unlocked" position.
    It was..

    I just went a bought a new card yesterday and all is working find.. Guess I got a crappy card.. Unfortunatly, its passed the 30 days and I didn't keep the packaging for it so I cant return it.
  5. #5  
    Quote Originally Posted by bobbykokinos View Post
    Unfortunatly, its passed the 30 days and I didn't keep the packaging for it so I cant return it.
    Did you try warranty replacement? Most good cards have a minimum of a 5 year warranty, and some have *LIFETIME* warranties.

    -TR1
    Handspring Prism ---> PalmOne Treo650

Posting Permissions