Results 1 to 3 of 3
  1.    #1  
    Syncing Outlook email, contacts and calendar used to work just fine. However, I get the following error when I sync the calendar: "There was a problem syncing events."

    When I click on the "Details" button, it says: "AirSAMStateMachine.c 2327 1509 Server returned error for lost command. Status:5".

    Can someone help me figure out a solution?

    Thanks.
  2. #2  
    FWIW, I've just developed this with Versamail 3.5 on a Treo 650, except my problem is with contact sync. Hmm.

    LATER. . . .

    Courtesy of Mr. Google, here is an answer for those of us with this problem.

    http://fivepoundsflax.blogspot.com/2...d-dreaded.html

    The author says that "Status:5" means that the problem is in the server.

    He also said he solved his problem by deleting the Exchange email account on his Treo and putting it back. (Which by definition means that the error message is a big fat giant lie because if you change the client software and solve the problem you don't really have a server problem at all, do you?).

    I deleted my Exchange account on my Treo. Set up the Exchange account again. Everything did its normal OTA sync. Happy days.

    STILL LATER . . . .

    A Treocentral thread on the dreaded AirSAMStatemachine.c problem. http://discuss.treocentral.com/archi.../t-105417.html. The "delete account from the Treo and put it back" solution seems to be popular.
    Last edited by Tastypeppers; 11/14/2006 at 02:50 PM. Reason: Found the answer to the problem
  3. #3  
    Quote Originally Posted by Tastypeppers View Post
    A Treocentral thread on the dreaded AirSAMStatemachine.c problem. http://discuss.treocentral.com/archi.../t-105417.html. The "delete account from the Treo and put it back" solution seems to be popular.
    Tried this as well. No joy. My experience:

    Quote Originally Posted by benex View Post
    My error code is different: AirSAMStateMachine.c 540 3. Email and contacts synced fine, the problem was the calendar. It always stopped before completing the progress bar and showed me a 540 3. The solution: Removal of all reocurring events (holidays, anniversaries). I turned all this events into one time events.
    My experience is similar, but with no joy at end. Treo 680, VersaMail 3.5.3, latest ActiveSync update installed.

    First time I ran the sync, everything worked fine. After installing the ActiveSync update, only my e-mail syncs. The calendar does not sync. any more.

    Again, e-mail is fine, but no event sync. I get this message: AirSAMStateMachine.c 3704 1509 Server returned error for last command. Status:5

    Of course, status 5 would indicate its a server error, but the syncing was working just an hour ago and before installing my active sync update, so that seems unlikely.

    Soft and hard resets have been tried. I have also deleted all recurring items in the calendar. No joy.

    Also, another, quite bad things is that after syncing my calendar with the exchange server the first time, all my Treo events from the last month went up to the exchange account, but were also *DELETED* from the Treo! What? Glad I have a backup.

Posting Permissions