Results 1 to 17 of 17
  1.    #1  
    I bought the Jabra JX10 for my 700p based on the suggestions of many members here, but it looks like I'm going to send it back. Everyone I've talked to so far has said that sound quality is terrible - the complaint seems to be that the headset is clipping the beginnings and ends of my words. Since I mainly wanted a headset for the road, I'm thinking I might have to pass on it. I really like the size, comfort, weight and audio quality on my end, but if everyone I talk to has to constantly ask me to repeat myself it doesn't really do me a lot of good. Assuming I do return it, what other headsets are out there that work reasonably well with the 700p, and have good audio quality? I don't mind something larger with a boom if the sound quality is good. Any suggestions welcome.
  2. eharty's Avatar
    Posts
    245 Posts
    Global Posts
    780 Global Posts
    #2  
    I am having the same problem with mt Treo 650 and JX10. So far, the Plantronics Voyager 510 has the best sound quality but it does have a connection lag of a couple of seconds. Not great but the best I have found with the 650.
  3. #3  
    You can't beat the AX2 Pro for in-ear headsets.
  4. wbwjr's Avatar
    Posts
    440 Posts
    Global Posts
    441 Global Posts
    #4  
    I have had no complaints with my JX-10. Maybe you should exchange it and try another JX-10. It really is a fabulous headset.
  5. #5  
    I have the same problem as Rufo. Same problem with two different X10's. The clipping occurs in noisy environments, but in a quiet room its fine. I've used it on a Treo 650, Treo 700P and Nokia E61. the clipping was evident on all of the phones. I finally gave up on it.
  6. #6  
    Quote Originally Posted by jcatan View Post
    I have the same problem as Rufo. Same problem with two different X10's. The clipping occurs in noisy environments, but in a quiet room its fine. I've used it on a Treo 650, Treo 700P and Nokia E61. the clipping was evident on all of the phones. I finally gave up on it.
    DSP = clipping in noisy environments. Always.
  7. #7  
    My favorite headset is the Sony HBH-610. The DSP settings seem just right. There is some background noise evident, although greatly reduced, but it never clips. The perfect compromise for me. Connection is instant on outgoing calls and nearly so on incoming calls on all my phones. It has great battery life and is very comfortable with the Jabra ear gel attached. I also have a Samsung WEP200 and it is also very good, but only in relatively quiet environments.
  8. #8  
    Quote Originally Posted by jcatan View Post
    My favorite headset is the Sony HBH-610. The DSP settings seem just right. There is some background noise evident, although greatly reduced, but it never clips. The perfect compromise for me. Connection is instant on outgoing calls and nearly so on incoming calls on all my phones. It has great battery life and is very comfortable with the Jabra ear gel attached. I also have a Samsung WEP200 and it is also very good, but only in relatively quiet environments.
    Can you use your 610 with just the Jabra eargel and without the ear hook? Got a pic of it?
  9. #9  
    I returned my JX10 yesterday because the speaker had distortion. I had no complaints about outgoing sound.
    Treo 650 on Sprint / Palm Case / 1 GB SanDisk Ultra II SD Card
  10.    #10  
    2000 Man, the AX2 Pro intrigues me, but my soldering skills are, let's say, zero to none. Is there anyone who's building them that I could purchase one from?

    Other then that, I'm seriously considering giving the Voyager 510 a spin - I know there's complaints with the connection lag, but I'm still thinking it's worth a shot. When does the connection lag come in - is it just a second or two when you answer an incoming call? Is it better/worse if you answer from the headset as opposed to the Treo?
  11. #11  
    Lag is noticed when a call comes in and rings on the phone before it does in the BT earpiece. The same is seen when you place a call and it takes time for the call to be routed automatically to your headset. You also get lag when transferring a call that you started on the handset to the headset.
  12.    #12  
    Quote Originally Posted by 2000 Man View Post
    Lag is noticed when a call comes in and rings on the phone before it does in the BT earpiece. The same is seen when you place a call and it takes time for the call to be routed automatically to your headset. You also get lag when transferring a call that you started on the handset to the headset.
    So basically it takes two seconds for the headset to start ringing... once the headset starts ringing and I pick up the call, is the voice communication instantaneous, or is there another two second delay?
  13. #13  
    Quote Originally Posted by 2000 Man View Post
    Can you use your 610 with just the Jabra eargel and without the ear hook? Got a pic of it?
    I use it with the clear Jabra ear gels and no hook. It's very secure with good sound volume.
  14. #14  
    Quote Originally Posted by rufo View Post
    So basically it takes two seconds for the headset to start ringing... once the headset starts ringing and I pick up the call, is the voice communication instantaneous, or is there another two second delay?
    What you're describing is a 2 second delay. Is it as bad when you place the call or just when receiving calls.
  15. eharty's Avatar
    Posts
    245 Posts
    Global Posts
    780 Global Posts
    #15  
    Quote Originally Posted by jcatan View Post
    I use it with the clear Jabra ear gels and no hook. It's very secure with good sound volume.
    I tried the 610 with my 650 and had way too much static and a range of only about 2 feet.

    BT experiences with the Treo sure are variable. Are all phones this inconsistent or just Treos?
  16. #16  
    Quote Originally Posted by eharty View Post
    I am having the same problem with mt Treo 650 and JX10. So far, the Plantronics Voyager 510 has the best sound quality but it does have a connection lag of a couple of seconds. Not great but the best I have found with the 650.
    I have a 700p and am using a Plantronics 320. My main problem with it is that is consistently disconnects, after either making or receiving a call. I can easily reconnect it by just pushing the power button, but it is still annoying. I am considering the Voyager 510 because the consensus seems to be that it has the best overall sound quality, even in noisy environments, and it does not have the troublesome DSP technology. I think that I can avoid the connection lag with the 510 by setting my Treo auto answer to "immediately." (I don't mind answering my calls immediately.)

    My question is - does the 510 stay connected with a 700p or will it also disconnect after calls?
  17. #17  
    The 510 should disconnect. The 655 (other than slight hardware modifications which were sorely needed) is identical to the 645 except they fixed the 700p disconnect issue. I'd expect a firmware update or a replacement for the 510.

Posting Permissions