Results 1 to 8 of 8
  1.    #1  
    OK, I thought I was OK with the 645 for the most part, but this connection lag is starting to get to me. I've now missed a couple calls altogether because I was driving and the headset failed to answer the call completely! That's really unacceptable, especially when my little POS moto headset virtually NEVER had a connection problem... it didn't even have a minor lag! I've also had several calls where by the time it went through, the person on the other end was going "Hello? You there?" because my headset was still trying to get through.

    So the question is, is this just a problem with my particular headset, or is it time to try a new model? Since I bought it from Treocentral, I have no qualms with sending it back for my money back if it's just the model, but I doubt I'll dwell very long if I'm not completely satisfied with the performance. Should I contact the company? I KNOW it's not my treo, because again, it worked fine with my little motorola HS850!
  2.    #2  
    Feel free to chime in if your 645 DOESN'T have connection issues with the Treo 650
  3. #3  
    I have the 645 and the same problems. I already packed it up and went back to using my Jabra 250
  4. #4  
    Search next time. The Discovery headsets (640, 645 and Ultralight) all have the lag.
  5. #5  
    Regarding the lag issue, have you guys tried going to Preferences-Handsfree and setting Auto Answer to "Immediately"? I did that some time ago and my headset answers right away. However, it is a Plantronics 320 and not a 640 or 645. It may be that the 320 does not have a lag issue anyway, regardless of the Preferences setting. My 320 does have a disconnect issue, which occurs consistently after I make or receive a call.
  6. #6  
    I forgot to mention: I have a Treo700p with Verizon.
  7. #7  
    Quote Originally Posted by RetiredPA
    Regarding the lag issue, have you guys tried going to Preferences-Handsfree and setting Auto Answer to "Immediately"? I did that some time ago and my headset answers right away. However, it is a Plantronics 320 and not a 640 or 645. It may be that the 320 does not have a lag issue anyway, regardless of the Preferences setting. My 320 does have a disconnect issue, which occurs consistently after I make or receive a call.
    Most people don't want to answer every call immediately though.
  8.    #8  
    True, I don't even want the headset to pick up automatically, in case i don't want to answer the call or I'm not in the room!

Posting Permissions