Results 1 to 3 of 3
  1. 4ster's Avatar
    Posts
    238 Posts
    Global Posts
    293 Global Posts
       #1  
    Hi everyone.

    My Treo 650, purchased new from Sprint in January 2006 now has a loud static-like cracking noise when on a call. This happens all the time, indoors or out, on headphone, speakerphone, or earpiece, no matter who I call. It also happens after a hard-reset with nothing 3rd party installed.

    I am within Palm's warranty and I have insurance through Sprint.

    Any suggestions on where to go from here or what to expect would be appreciated.

    Peace,

    4s
    Safety and happiness can only come from individuals, classes, and nations being honest and fair and kind to each other.
    - C.S. Lewis
  2. 4ster's Avatar
    Posts
    238 Posts
    Global Posts
    293 Global Posts
       #2  
    Also,

    My Sprint store, where I got the Treo, has moved to a new location under the Embarq moniker, and they have the same employees and everything, but sell NOTHING Treo. for Sprint stuff, their website is telling me to go to a kiosk at the mall. What is up with that?
    Safety and happiness can only come from individuals, classes, and nations being honest and fair and kind to each other.
    - C.S. Lewis
  3. 4ster's Avatar
    Posts
    238 Posts
    Global Posts
    293 Global Posts
       #3  
    Well, this morning, the problem is gone. How weird. I guess it was a network thing?
    Safety and happiness can only come from individuals, classes, and nations being honest and fair and kind to each other.
    - C.S. Lewis

Posting Permissions