I tried adding the BB content to my 650 but it did not work so I had to take it off. But now when I try to syn my work e-mail using the Exchange Server I get the following message:

MIDataLib.Lib is an older version. Please upgrade to aat least version 3.5.

I have reinstalled the Cingular 1.17 upgrade and that does not help. All other POP e-mail works fine.

How can I upgrade that file so I can get my exchange e-mail?

Thanks