Page 1 of 2 12 LastLast
Results 1 to 20 of 31
  1.    #1  
    Are you unhappy with your treo 700p and think it is defective? Do you plan to return it to palm for a new one? If so, please let us know why you returned it and when you get the new one, tell us if you notice any differences...

    Thanks!
  2. #2  
    Screen-brownish tint
    Volume-hiss
    Camera-crappy picture is low lighting conditions

    And yes other 700p are better, in my own hand I compared mine to others that were on display.
    Treoing & Loving it
  3.    #3  
    I am considering returing mine becasue the screen has a brownish hew to it and Blazer has been crashing very often. Also there are looong pauses between applications(even on a fresh reset of the original software). So I am considering an exchange for another treo 700p.

    In the phone app it says:

    Software: Treo700p-1.08-SPNT
    Hardware: A
  4. mal5z's Avatar
    Posts
    137 Posts
    Global Posts
    142 Global Posts
    #4  
    Mine was a true lemon. Sent it back for the rather obvious reason described in the following thread. Otherwise, I was happy with it, though. Hopefully I won't get two lemons in a row.

    http://discussion.treocentral.com/sh...d.php?t=116289
  5. #5  
    W and Home key both stick / require too much force to press, sent for replacement.
  6. #6  
    whats the odds of getting a better one if I wait til next week?
    Fred
    Cingular 680
  7. #7  
    Mine is going back due to a defective microphone which impairs me from recording audio in camcorder or voice memo modes.

    Also had several resets or freeze-ups. Hope the next one is bettter.
  8. #8  
    I was told that I would have to return it and place a new order if it was defective. That kind of sucks because I was gonna have to spend some time without a Treo while the new one comes back.

    Al
  9. #9  
    I had to replace my first one because it stopped being able to connect to the network after a few hours of use. New one works fine.
  10. #10  
    I had to replace my first one today because the earpiece speaker sounded like crackling and popping, too me forever to find a sprint store that had any 700's available, they seem to all be sold out almost everywhere
  11. #11  
    Quote Originally Posted by Dr.Grace
    I had to replace my first one because it stopped being able to connect to the network after a few hours of use. New one works fine.
    What carrier-- Verizon or Sprint.

    Mine (Verizon) often disconnects from data. Blazer also often is unable to connect to pages with the message " The page you requested cannot be displayed. The web site you are trying to access may be temporarily unavailable ....." Another click or two typically then works. I don't know if these symptoms are typical or specific to my unit.
    Psion 3a > Palm Vx w/ Omnisky > Blackberry 850 > Treo 300 > Treo 600 > Treo 650 > Treo 700P > Apple iPhone
  12. #12  
    My original unit from Palm, which I purchased at full price, had defective BT (couldn't pair with my headsets). I returned it, and ordered a replacement from Sprint Retentions for $399.

    The replacement is working flawlessly for me, and I saved $$$.
  13. #13  
    Quote Originally Posted by MobileGuy
    What carrier-- Verizon or Sprint.

    Mine (Verizon) often disconnects from data. Blazer also often is unable to connect to pages with the message " The page you requested cannot be displayed. The web site you are trying to access may be temporarily unavailable ....." Another click or two typically then works. I don't know if these symptoms are typical or specific to my unit.
    You are not alone, my friend. I think this is a Verizon server issue. Yesterday, I called in for voicemail and heard the recording that "all circuits are busy" at least 4 times. Sweet. And I "upgraded" from TMo for this?
  14. #14  
    Sprint - Bad "d" key. They swapped it out no problem, and the next one appears to be great. I used BBVFS, and the backup/restore was seamless. (Turn off BT during backup as there is a compatibility issue with two 700p BT stack files if BT is on. Only relevant until a BBVFS update is released.)
  15. webdave's Avatar
    Posts
    369 Posts
    Global Posts
    755 Global Posts
    #15  
    My red power button was sticky. I was able to get a free advanced exchange from Palm.
  16. #16  
    Quote Originally Posted by MobileGuy
    What carrier-- Verizon or Sprint.

    Mine (Verizon) often disconnects from data. Blazer also often is unable to connect to pages with the message " The page you requested cannot be displayed. The web site you are trying to access may be temporarily unavailable ....." Another click or two typically then works. I don't know if these symptoms are typical or specific to my unit.
    Verizon.

    You're describing a different problem from what caused me to return my first 700p (that one would just hang on "Network Search" on the phone screen when I started the radio).

    But I get this problem you're describing too sometimes. It seems like Blazer at times thinks a wireless connection is already made, but it isn't.
  17. #17  
    I returned my 700p. I just received it today. My w, s and z keys did not work. I am waiting for my replacement.
  18. #18  
    Just returned mine today. It would get stuck into Extended Network. I would travel outside my "Home" area to extended network land and upon returning the phone still said extended network hours later. The phone also came to crawl for speed. It woud take a full 10 count to switch from the phone app to the Palm side. I could get it out of this by powering the phone down and back on or doing a soft reset. What a pain. So I caleed they said turn it in and get a new one. That makes 1 treo 650 and two 700p in just two weeks. My worry free tryout stops in the am. So we will wait and see. Except for my horrible bad luck the devices ROCK!
    Palm Pro > Plam VII > m130 > T3 > T5 > LifeDrive > Treo 650 > Treo 700p > 700w
    Holly crap who knew these Treo thingys were so cool!
  19. #19  
    im DEFINATELY returning mine after what it did today... basically when i make/receive calls, i wont hear anything on the other side, not to mention the speakerphone button is totally gone when a call is in progress. I just dont get it..... i tried hard resetting numerous times and it still does it. I am just so upset at how buggy and screwed up this 700p is compared to my 650
  20. #20  
    New to Treo, I purchased a Sprint 700p on Sunday to take on road for a month long job visiting many cities. Thought it would be a great trial to test in different markets.
    I loved it for the first two hours. Then it froze. Tryed a soft and hard reset. Still froze.Then Called Sprint only to find they have no customer service after certain hours. Left the battery out overnight, then replaced it back, still frozen.
    Got on a plane to LA then called Sprint. I was told by a tech that there was a hardware problem and to return. I called six stores and none had the 700p.
    Took it in to the nearest Sprint store were I retuned it for a full credit and cancelled my Sprint account. Glad I kept my cingular phone active. I will try again in a month.
Page 1 of 2 12 LastLast

Posting Permissions