Results 1 to 7 of 7
  1.    #1  
    After being happier than can be the first couple days I had it (got it on the first), the touchscreen stopped working after a soft reset. Reset it a couple more times and decided to finally do a hard reset.

    Still doesn't work. I'm asked to calibrate the touchscreen and it's just not working. I put on a screen protector but I know that that can't be the problem.

    Is it time to give Sprint customer service a call and ask for a new phone?

  2. #2  
    Quote Originally Posted by chasely
    I put on a screen protector but I know that that can't be the problem.

    Actually, that *may* be the problem. Try without the protector first. Sometimes, if under the screen edge, the protector could cause this. If it acts the same without the protector in place, then simply return for a new unit.
    --Steve

    Visor-->Treo 600-->Treo 650-->Treo 700P-->Treo 800W-->Palm Pre-->HP Touchpad

    My DVD Collection
    My Media Room
    GovTwit Directory
    Twitter: @dslunceford
  3. #3  
    yes, stop wasting your time with a messed up treo
    Jimmie Geddes
  4. #4  
    yep... i had the same issue with a 650 and a screen protector... try it w/o first...
    -jscott
  5.    #5  
    So...it was the screen protector...lol
    Last edited by chasely; 06/04/2006 at 03:38 AM.
  6. #6  
    You mean the screen protector, right?
  7.    #7  
    Quote Originally Posted by IsLNdbOi
    You mean the screen protector, right?
    Yep...and I edited the original post so nobody gets confused.

Posting Permissions