Page 7 of 7 FirstFirst ... 234567
Results 121 to 138 of 138
  1. ehosey2's Avatar
    Posts
    309 Posts
    Global Posts
    776 Global Posts
    #121  
    Okay, I got Softick Audio Gateway version 1.06 to function on my Sprint Treo 650 with the stock ROM 1.13A using the HBH-DS970. So, when set to internal, I am able to make outgoing calls using the Treo's phone button with no problem, as well as the headset's call button, tapping that button twice which enables the redial of the last number function in the headset's call history. Interestingly, when I hang up from the call using the Treo's buttons, there is no abnormal behavior. But when using the call / hang up button on the headset, if the next button I press on the Treo is the home button, it goes into a soft reset every time. Any other button I press , say calendar, except for once out of the 10 times I did this, no reset occurred. I'd guess a bug in the bluetooth application maybe ?

    SAG 1.06 the other day for some reason was not functioning at all for me but I reinstalled it and am testing again. I have not had any chance to thoroughly test incoming call functionality using SAG 1.06 yet, but one thing in my opinion I have noticed is when using 1.06 that while I thought the music streams in 1.05 sounded excellent, they actually sound even fuller and a bit louder. There has been no skipping of music at all using SAG 1.05 or 1.06 and this includes streaming Shoutcast at 128k as well as MP3's. AVRC seems to work really well with this headset as all the music playback feature buttons on the HBH-DS970 ( play, pause, skip track, previous track, volume, etc. ) all work with no problem.

    So, as I receive phone calls later today I'll be able to test call handling more using 1.06, and will comment after further testing. All in all, I too am happy with what Softick is able to provide at this point for their A2DP / AVRC solution and look forward to further improvement. And, in my opinion this headset is a fantastic piece of gadgetry.

    ---------------------------------------
    Merlin S620 EVDO
    Treo 650 Sprint 1.13A
    Sony Ericsson HBH-DS970 with SAG 1.06 in test mode !
  2. #122  
    Testing Report: June 25, 2006 12:00PM CDT
    Devices: Sony Ericsson HBH-DS970
    Treo 650 Sprint 1.13A custom ROM

    I suspected that AeroPlayer was causing some problems, so I limited my testing to not actually streaming audio from AeroPlayer, but just connecting SAG on it's own and streaming Treo sound effects (button press beeps mostly).
    Updated: I have now tested this procedure and found that it works just as well if I'm streaming music via AeroPlayer or TCPMP or just the Treo's system sounds.

    I returned to testing SAG 1.06

    I found that the headset would switch to handsfree profile (normal headset operation) for the first incoming call after a soft reset, but after that it would never switch correctly. In fact, I would hear my assigned ringtone through the headset instead of Sony Ericsson's built-in ringtone suggesting that SAG was just streaming all audio from the Treo instead of switching to normal headset-call operation. At first the only thing I could find that would fix this situation was a soft reset. However, I've found another set of operations that fixes the problem and sheds some light on what I believe is causing the instability in SAG.

    Assuming that the phone has been reset so that it is a "fresh" as possible, and that the HBH-DS970 has been paired to the Treo (in what Sony Ericsson calls "singlepoint mode" for further information read the HBH-DS970 manual), and that SAG has been configured correctly:
    1. Connect to the headset via SAG by selecting "Remote"
    2. When a call comes in, the Treo will display "No Caller ID", and the HBH-DS970 will show the correct Caller ID number.
    3. Answer the call using the Treo's Green button.
    4. End the call using the Treo's Red button.
    5. Immediately go back into SAG, and select "Remote", let SAG connect, then select "Internal"
    6. Place an outbound call.
    7. After the headset has connected as a regular headset (indicated by the headphones-bluetooth icon on the Treo), hangup using the Treo's Red button.
    8. Relaunch SAG and connect by selecting "Remote".
    9. When the next call comes in, the Treo will handle it correctly as it did in step 2.

    I've tested this process several times and it worked every time. I believe this sheds light on the underlying problem. I believe the bug lies in how SAG tries to start playing music again after a call has ended. I believe it gets into a condition where it does not know that the first call was ended, and so continues to wait for an internal call-ended-signal. By enabling and disabling SAG, then placing a call, I believe this resets SAG's internal waiting loop. In my experience with the Treo I have never seen an app sucessfully return to the application it was running prior to a call. TomTom Navigator has claimed to have had this feature for a long time, and it has never worked for me. Perhaps GSM Treos work with this, but none of my CDMA Treos ever have.

    As described in Step 2. for SAG, when a call arrives, it passes the Caller ID information to the headset, but it does not seem to pass it to the Tero's internal call-handling system. As a result the Caller ID shows up the headset's display, but the Treo only knows a call is coming in, and reports "No Caller ID". If SAG is disabled, and a call comes in, but the Treo and the headset receive the Caller ID information correctly.

    Finally, I noted that all call interaction in my testing was through the Treo's buttons, and not the headset's "Call" button. So far, in SAG 1.06 and 1.05, using this button always causes a freeze. 1.04 did handle the "Call" button correcly, but the audio performance was so diminished compared to the other versions that I opted to test with 1.06. Also, I believe providing Softick with feedback on the latest version makes debugging simpler for them.

    I've posted this entire message to Softick as a bug report - I hope it helps them and any other users on this board.

    Conrad
    Last edited by Conrad; 06/25/2006 at 04:11 PM.
  3. ehosey2's Avatar
    Posts
    309 Posts
    Global Posts
    776 Global Posts
    #123  
    Conrad,

    Thank you for the update. I'm still using SAG 1.06 and will be trying everything you have tested and note my test results soon. As a side note, I have had marginal success using TCPMP. Some of the videos played though TCPMP have had the audio stream perfectly to the headset while others create a crackling sound before freezing my Treo, at which point I have to pull out the battery to reset it. Not sure why as to the reason but am still investigating. So far though overall I am pleased with the HBH-DS970, and look forward to further improvements with the SAG application enhancing my 650's bluetooth useage.

    ---------------------------------------
    Merlin S620 EVDO
    Treo 650 Sprint 1.13A
    Sony Ericsson HBH-DS970 with SAG 1.06 in test mode !
  4. ehosey2's Avatar
    Posts
    309 Posts
    Global Posts
    776 Global Posts
    #124  
    Here's another update. I performed the steps previously mentioned above in Conrad's post.
    1. Performed a fresh soft reset.
    2. Connected to the headset in " remote " mode but didn't stream music.
    3. The incoming call shows the caller ID om my Treo, sounds the sony ringer
    in the headset, but no number of incoming call on the Sony LED.
    4. Answered incoming call with green button of Treo.
    5. Ended call using red button of Treo.
    6. Immediately connected to " remote " in SAG, the switched to " internal. "
    7. Placed outgoing call, hearing the Sony beeps and sounds.
    8. Ended call using Treo red button.
    9. Caller ID was displayed as normal on the Treo and Sony LED.

    So, this is no different than from what I previously have experienced since testing began.

    Now, here are the problems I've encountered with SAG 1.05 and 1.06 while using the following :
    Treo 650 Sprint 1.13A stock ROM
    Pocket Tunes Deluxe
    HBH-DS970

    1. With SAG in " remote " mode and with music being streamed from Pocket
    Tunes, everytime an incoming call is received the caller ID on the Treo is
    displayed, the music pauses, but no phone number of the incoming caller
    is displayed on the Sony LED. I can answer the call using the Treo's green
    button as normal and end the call using the red button as normal.
    2. If I try answering the incoming call with the headset button, the Treo
    freezes everytime.

    So, unless I am mistaken, it seems from the previous post from Conrad, the incoming number to his Treo is displayed everytime on his Sony LED as well as his Treo screen with his work around fix but this is without any music being streamed. And on mine, only the Sony LED is displayed when SAG is set to " internal " mode. Jeez, this is a bit complicated. But man, with half of the call handling capabilities working and the excellent audio streams using the headset, I can live with this as it should hopefully only be a matter of time before the Softick crew fixes all this. I'll still be persistently testing and will provide further updates as I'm able. Thank you for reading to those that are interested.

    ---------------------------------
    Merlin S620 EVD0
    Treo 650 Sprint 1.13A
    Sony Ericsson HBH-DS970 with SAG 1.06 in test mode !
  5. #125  
    Thanks for posting your update ehosey2! Great work!

    Quote Originally Posted by ehosey2
    So, unless I am mistaken, it seems from the previous post from Conrad, the incoming number to his Treo is displayed everytime on his Sony LED as well as his Treo screen with his work around fix but this is without any music being streamed. And on mine, only the Sony LED is displayed when SAG is set to " internal " mode. Jeez, this is a bit complicated. But man, with half of the call handling capabilities working and the excellent audio streams using the headset, I can live with this as it should hopefully only be a matter of time before the Softick crew fixes all this. I'll still be persistently testing and will provide further updates as I'm able. Thank you for reading to those that are interested.
    Sorry, just to be specific:
    When SAG is enabled (set to "Remote") and I've completed my procedure, the Caller ID is displayed on my headset's LCD, but the Treo displays "No Caller ID".
    When SAG is disabled (set to "Internal"), the Caller ID is displayed on the headset LCD and on the Treo as well.

    I've done a a short series of tests with SAG disabled ("Internal") and have found the HBH-DS970 functions exactly like my HBH-660 when I use it this way. In general, I feel confident in saying that, without SAG enabled, the HBH-DS970 works superbly as a run-of-the-mill headset. In fact, the microphone is really excellent.

    In testing, I'm focusing on identifying how the headset performs in stereo mode and am only comparing various conditions with SAG enabled (set to "Remote").

    I can now say that the procedure that I outlined works the same if I'm streaming music via AeroPlayer or not as well as via TCPMP or not.

    Would any other users who have A2DP headsets please test this procedure to see if the problems that you're seeing with your headsets go away when you do this?

    Conrad
  6. #126  
    Motorola is releasing one now too. Looks similar to Sony's BRM1D:

    http://www.slashphone.com/106/4611.html

    It has a FM tuner, an integrated microphone, and a screen for viewing caller ID info., RDS for FM stations that support it and for viewing pairing status. It also allows you to pair it with two devices simultaneously.
    Last edited by IsLNdbOi; 06/27/2006 at 10:18 PM.
  7. #127  
    looks promising. so lets hope it comes out sooner then later in 3rd Qtr.
  8. #128  
    I hope it's easier to find and cheaper than the BRM1D.
  9. #129  
    Has SAG been fixed to work on the 700p?
    "So long and thanks for all the Treos!"
  10. dvdmon's Avatar
    Posts
    599 Posts
    Global Posts
    866 Global Posts
    #130  
    Quote Originally Posted by BabelFish
    Has SAG been fixed to work on the 700p?
    Nope! Lots of us have been checking every day, but now tha they're over a week past their initial estimate, I'm no longer expecting it "any day now." My hope is that we'll see it in July, but even that now I'm starting to wonder about...
    Twitter: @dvdmon

  11. ehosey2's Avatar
    Posts
    309 Posts
    Global Posts
    776 Global Posts
    #131  
    Quote Originally Posted by enynite
    Damn, thats the feature that would have pushed me to purchase it. I don;t want to pull out my treo when I'm lsitening to music and a call comes in to see who it is.

    I guess I'll either get the sony BRM1D or continue to wait for a good bluetooth solution.

    Thanks ehosey2
    Hey Enynite,

    Conrad and myself are using SAG 1.06 and the caller ID works on the Sony's control unit whether streaming music or not. The difference is when in remote mode the music will pause and on the LCD the incoming number is displayed and on the Treo 650 it says No ID, and when using internal mode, no music can be streamed, which is correct operation by the way as it acts just as a normal BT headset and the incoming number is displayed on the Sony LCD and the Treo. Hope that helps. Hmm, July 14th is so far away. Just kidding !

    -------------------------------------
    Merlin S620 EVDO
    Treo 650 Sprint 1.13A
    Sony Ericsson HBH-DS970 with SAG 1.06 !

    -------------------------------------
  12. #132  
    I just posted my latest update on using the HBH-DS970 to the A2DP thread. ehosey2 had been posting more there, so I replied there. Sorry if this shifts discussion.
  13. #133  
    thanks ehosey! Thats cool.

    Can you post a pick of the headset next to the treo so I can get a relative idea of the size. (remember I thought the buttons looked huge in the manual).
  14. #134  
    can we go back to the globalsat BTH 820? I would like to order one but only have BT 1.0 and cannot find out how to get 1.2. Palm says no for the 650 1.03 VZW.
    ps finally got ptunes to work thanks to all your posts.
  15. #135  
    You can't just add bluetooth 1.2 to the 650 so you're out of luck there. I think it's a hardware thing. All you need to get the 820 to work is Softick's Audio Gateway app..
  16. #136  
    okay thanks. somewhere i read that the 820 req'd 1.1 or better. it is all too confusing for my pea brain.
  17. #137  
    any pics yet ehosey2?
Page 7 of 7 FirstFirst ... 234567

Posting Permissions