Page 1 of 2 12 LastLast
Results 1 to 20 of 24
  1.    #1  
    Hi All,

    I just applied the 1.20 update a few days ago. But the way in which the phone now works with my bluetooth headset is a little strange.

    Before the Update:

    I would have to click the button on my Bluetooth Headset to answer and hang up. If I just pressed answer on my screen it would go to the normal handset ear piece.

    After the Update:

    If my Bluetooth headset is in range and I hit answer on the phone's screen, it puts the call through to the headset rather than the handset. This is pretty annoying. Basically, whenever my headset is in range, I can't answer the phone using the handset alone.

    I have searched through all the setting but I see nothing on this.

    Any suggestions?
  2. #2  
    Turn off BT when you don't want to use the headset or turn off the headset.
  3. #3  
    I've complained about this new BT "feature" too, treo-mike. It appears the only solution is to a) restore your earlier software version, or b) live with it.

    The worst part is, I can't even ignore a call now. BT *forces* me to answer. Turning off BT or the headset is not a good option, because then what happens when I *want* to answer a call? I have to fumble around with the headset or phone to turn it back on. Then I'd probably miss the call anyway while I find the headset, hold the button for 3 seconds, then wait for it to connect. And I'd probably drive off the road while doing all this. What was wrong with a simple tap on my ear to answer a call, if I wanted to?

    I have considered creating a custom ROM using older BT files, but haven't gotten around to it yet and don't know if it would work anyway.

    Treo 650 - Cingular GSM
    Software:Treo650-1.20-ENA
    Firmware:01.71
  4. #4  
    Leave the Treo BT turned on and leave the headset off. When you *want* to answer the call, turn on the BT headset. I know it's not perfect....but what can you do?
  5. #5  
    Yes, I could work around the problem. But why did Palm make this change? Were users actually clamoring for this behavior? And why couldn't they have made it a user-configurable option? Just one simple checkbox: "Automatic BT call pickup".

    Why couldn't Palm have just left this feature alone! GRRRR!

    Feel free to ignore me. I'm just venting.

    Treo 650 - Cingular GSM
    Software:Treo650-1.20-ENA
    Firmware:01.71
  6.    #6  
    I figured this was a "Feature"...

    Unfortunately, I have a Moto HS 820 headset. Turning it off is not an option...because there is no way to turn it off other than to let the batteries run dead.

    I agree with mcdan333 - why couldn't they let you set the behavior you want? Who designs this crap? Do they ever think of the end user when they do it? I probably wouldn't mind as much if Palm has at least "mentioned" this new behavior in the release notes.

    How did I find out about it? I am driving and I go to answer my phone and I can't figure out why I can't hear anything!

    Even better, I keep my BT headset in the car - this morning I dialed out on my phone from the house - however I guess the garage was close enough to catch it - so it transferred the call to the headset - which was in the freaking garage. Really nice.
  7. #7  
    Can you tell me where you got the upgrade from? Do you have a link?

    Thanks
  8. #8  
    Quote Originally Posted by treo-mike
    Hi All,

    I just applied the 1.20 update a few days ago. But the way in which the phone now works with my bluetooth headset is a little strange.

    Before the Update:

    I would have to click the button on my Bluetooth Headset to answer and hang up. If I just pressed answer on my screen it would go to the normal handset ear piece.

    After the Update:

    If my Bluetooth headset is in range and I hit answer on the phone's screen, it puts the call through to the headset rather than the handset. This is pretty annoying. Basically, whenever my headset is in range, I can't answer the phone using the handset alone.

    I have searched through all the setting but I see nothing on this.

    Any suggestions?
    If you are running a custom ROM you can put the BT files from 1.13 in your ROM.
    PalmIII > PalmIIIx > PalmIIIxe > TRGPro > Handera 330 > Zire71 > Treo600 > Treo650 > Treo680 > Treo750 > Centro > TreoPro > iPhone 32GB 3GS

  9. #9  
    Quote Originally Posted by jamesgangut
    If you are running a custom ROM you can put the BT files from 1.13 in your ROM.

    Which files would needed to be swapped over?
  10. #10  
    PalmIII > PalmIIIx > PalmIIIxe > TRGPro > Handera 330 > Zire71 > Treo600 > Treo650 > Treo680 > Treo750 > Centro > TreoPro > iPhone 32GB 3GS

  11. #11  
    BlueTooth files removed to get 1.13 version BT (Assuming lang strip)
    BluetoothExt_Device.prc
    BtCommVdrvLib_Device.bprc
    BtCommVdrvLib_Device_enUS.oprc
    BtDeviceLib_Device.prc
    BtExgLib_Device.bprc
    BtExgLib_Device_enUS.oprc
    BtHandsfreePnl_Device.bprc
    BtHandsfreePnl_Device_enUS.oprc
    BtHsmLib_Device.prc
    BtLibLib_Device.bprc
    BtLibLib_Device_enUS.oprc
    BtManagerApp.bprc
    BtManagerApp_enUS.oprc
    BtManPnl.prc
    BtStackLib_Device.prc
    BtTransportLib_Device.bprc
    BtTransportLib_Device_enUS.oprc

    1.13 files put in ROM (Assuming lang strip)
    BtHandsfreePnl_Device_enUS.oprc
    BtHsmLib_Device.prc
    BtLibLib_Device.bprc
    BtLibLib_Device_enUS.oprc
    BtManagerApp.bprc
    BtManagerApp_enUS.oprc
    BtManPnl.prc
    BtStackLib_Device.prc
    BtTransportLib_Device.bprc
    BtTransportLib_Device_enUS.oprc
    BluetoothExt_Device.prc
    BtCommVdrvLib_Device.bprc
    BtCommVdrvLib_Device_enUS.oprc
    BtDeviceLib_Device.prc
    BtExgLib_Device.bprc
    BtExgLib_Device_enUS.oprc
    BtHandsfreePnl_Device.bprc
    In case anyone else needs it.
  12. #12  
    Quote Originally Posted by jamesgangut
    If you are running a custom ROM you can put the BT files from 1.13 in your ROM.
    Good news. Hopfully someday there will be a better stack to stuff in there...
  13. #13  
    Well, actually this is a feature. The fact that you had to hit the headset button in the first place (and not on all headsets was this true, BTW) was a bug. Later bluetooth revisions in POS have improved compatibility, thus resulting in your headset's automatically collecting a call when nearby. The problem really is that we got used to the buggy behavior.

    But... if you are answering the call from the headset anyway, there is a pretty quick fix if this does happen. Just tap the "headset cancel" button. It appears in the same place that "speakerphone" usually does, if audio has been transferred to a headset. Yes, you'll need to do this for each call... but if you can't easily get your hands on the headset to turn it off, it works pretty easily.
  14. #14  
    Quote Originally Posted by taroliw
    Well, actually this is a feature. The fact that you had to hit the headset button in the first place (and not on all headsets was this true, BTW) was a bug. Later bluetooth revisions in POS have improved compatibility, thus resulting in your headset's automatically collecting a call when nearby. The problem really is that we got used to the buggy behavior.

    But... if you are answering the call from the headset anyway, there is a pretty quick fix if this does happen. Just tap the "headset cancel" button. It appears in the same place that "speakerphone" usually does, if audio has been transferred to a headset. Yes, you'll need to do this for each call... but if you can't easily get your hands on the headset to turn it off, it works pretty easily.
    Ya!
  15. #15  
    Quote Originally Posted by treo-mike
    Hi All,

    I just applied the 1.20 update a few days ago. But the way in which the phone now works with my bluetooth headset is a little strange.

    Before the Update:

    I would have to click the button on my Bluetooth Headset to answer and hang up. If I just pressed answer on my screen it would go to the normal handset ear piece.

    After the Update:

    If my Bluetooth headset is in range and I hit answer on the phone's screen, it puts the call through to the headset rather than the handset. This is pretty annoying. Basically, whenever my headset is in range, I can't answer the phone using the handset alone.

    I have searched through all the setting but I see nothing on this.

    Any suggestions?
    I'm not getting it. The purpose of the headset being in range is to answer from the headset. I have not applied the update and if my headset is in range, and I answer the call, it is supposed to automatically go to the headset. I just click the cancel headset if I want to use the handset.


    AM I MISSING SOMETHING?
  16. #16  
    No you are not missing anything. Now please return to resetting your Treo regularly to avoid mysterious other problems...
  17.    #17  
    Quote Originally Posted by luvdldy
    I'm not getting it. The purpose of the headset being in range is to answer from the headset. I have not applied the update and if my headset is in range, and I answer the call, it is supposed to automatically go to the headset. I just click the cancel headset if I want to use the handset.


    AM I MISSING SOMETHING?
    You are not really missing anything. It's just that Palm changed the behavior...and oh....FORGOT to mention anything about it.

    Prior to the update - if you wanted to take the call on your BT headset, you had to click the button on your headset.

    After the update - it will go the headset whenever it's range - whether you want it to or not.
  18. #18  
    Quote Originally Posted by treo-mike
    You are not really missing anything. It's just that Palm changed the behavior...and oh....FORGOT to mention anything about it.

    Prior to the update - if you wanted to take the call on your BT headset, you had to click the button on your headset.

    After the update - it will go the headset whenever it's range - whether you want it to or not.
    Well, to their credit, this was Palm fixing a bluetooth compatibility problem...a BUG. The behavior you are experiencing now is the correct behavior, that should have been there all along. And I would point out that only *some* headsets experienced the problem that you had to tap their call buttons to transfer audio. Other headsets that were working from the very beginning had no such requirement, even on early 650 software releases.
  19.    #19  
    Quote Originally Posted by taroliw
    Well, to their credit, this was Palm fixing a bluetooth compatibility problem...a BUG. The behavior you are experiencing now is the correct behavior, that should have been there all along. And I would point out that only *some* headsets experienced the problem that you had to tap their call buttons to transfer audio. Other headsets that were working from the very beginning had no such requirement, even on early 650 software releases.
    That I was unaware of. Still, a nice little note that went beyond "Bluetooth Improvements" would have been nice. It would have taken all of 30 seconds!
  20. #20  
    Quote Originally Posted by taroliw
    Well, to their credit, this was Palm fixing a bluetooth compatibility problem...a BUG.
    When you say they fixed a BUG... is this behavior specified somewhere in the BT standard? If it is, then ok, I can see why Palm changed it. I still prefer the old way though, and it would be nice to have a user configurable option (even if not part of the standard).

    Treo 650 - Cingular GSM
    Software:Treo650-1.20-ENA
    Firmware:01.71
Page 1 of 2 12 LastLast

Posting Permissions