Results 1 to 7 of 7
  1. noc
    noc is offline
    noc's Avatar
    Posts
    74 Posts
       #1  
    I gave my old 600 (GSM on T-mobile) to my wife to use when I upgraded to the 650. She's been happily using it for about 6 months, until today... when it just completely died. Didn't happen while doing anything, first it froze, but the light was blinking. Tried a soft reset on the back, and it just extinguished. Can't power it up, can't reset it, can't charge it, nothing. It's a brick!

    Unit is way out of warranty so can't send it in. Anyone have any idea what the issue is? Any help would be appreciated.
  2. #2  
    Did you try a hard reset?
  3. #3  
    Depending on your carrier's rules you may be able to get a refurbished device for a small fee. VZW will replace my T600 for $50.
  4. noc
    noc is offline
    noc's Avatar
    Posts
    74 Posts
       #4  
    how do you accomplish a hard reset if the phone is dead? i mean dead.
  5. #5  
    does the phone work when plugged in? is the phone taking a charge? you should get a red light at the top of the phone when plugged in
    if not charging then you may have a bad motherboard or battery. go to fleabay for battery ~$17 shipped, otherwise I suggest you browse pdaparts

    hope this helps
  6. #6  
    Quote Originally Posted by noc
    how do you accomplish a hard reset if the phone is dead? i mean dead.
    That's a good question. I would just go through the motions and see if anything happens.
  7. noc
    noc is offline
    noc's Avatar
    Posts
    74 Posts
       #7  
    here's an update. after leaving it plugged into the charger over night, the next morning, it worked like nothing ever happened! everything normal. held a charge all day and worked fine. so what do you make of that?

Posting Permissions