Results 1 to 8 of 8
  1.    #1  
    Oh darn!

    So yesterday I took my home computer set-up apart to fix a wheel on the desk. When I put it back together, I put the wrong power adapter on my powered USB hub. This shorted it out, along with the device that was hooked to it, it seems. That device was my beloved Treo 600.

    I took it in to work to see if maybe the issue was the charger. plugging into my work charger gives me a "USB Device Not Recoginized" error, which means there's some spark of life left. Still the "charging" light stays dark and pressing the buttons does nothing.

    Does anyone have any suggestions?
  2. #2  
    Charging light stays dark? You may have shorted the power regulator on your Treo as well. Have you tried to soft reset?
  3.    #3  
    Quote Originally Posted by ronbo2000
    Charging light stays dark? You may have shorted the power regulator on your Treo as well. Have you tried to soft reset?
    Yessir, tried that first thing.
  4. #4  
    Ouch, what you have is a burned out circuit.
  5.    #5  
    Quote Originally Posted by ronbo2000
    Ouch, what you have is a burned out circuit.
    Siiiigh.

    Oh well. Time to start saving for that Treo 650 I've been lusting after.

    Using a T-Mobile Pocket PC Phone in the meantime. Nowhere near as good.
  6. #6  
    Have you tried a battery reset?
    Palm III > Palm V > Palm Vx > (Sprint) Kyo 6035 > Handspring Treo 300
    > Handspring Treo 600 Oct.'03 > Palm Treo 700P May'06 > Treo 755P Aug.'07 > Pre(-) June'09 + TouchPad July'11 LONG LIVE webOS!!!
  7.    #7  
    Quote Originally Posted by ChemEngr
    Have you tried a battery reset?
    Hnh. How does one do that, exactly?
  8.    #8  
    Okay, did a battery reset and actually got it to reset for a bit. It only resets when plugged in and isn't holding a charge. I'd already put it on eBay though (ending soon) and have decided to go for the 650 anyway.

Posting Permissions