Results 1 to 5 of 5
  1.    #1  
    I know this may/may not have been asked/answered on the forum before, but I need to know if there is any possible way whatsoever to prevent the Treo 650 BT DUN connection (T-Mobile via T-Zones) on the Mac (my PB G4) from stopping. I use my Bluetooth DUN connection with my Treo but after a few minutes it disconnects automatically telling me the other party stopped responding. The connection seems to stay connected only when i'm doing some browsing (without much stops between) continuously, but once I stop for about a minute it disconnects me again. Is this a T-Zones issue or can it be fixed on the mac/treo? In case this has already been replied to before in another thread, please guide this lost soul to the right path!

    - CMSNeuro
    Perfect as the wing of a bird may be, it will never enable the bird to fly if unsupported by the air. Facts are the air of science. Without them a man of science can never rise. - Ivan Pavlov
  2.    #2  
    Wow, no one replied to this one. I can understant why. So I think I have discovered something interesting regarding this disconnection problem.

    What I realized was that usually I was disconnected every 5 to 10 minutes of usage, sometimes even less. This annoyed me because I was never able to finish reading something online without being disconnected. I had to reconnect over and over again even when I left my PB idle for about a minute. I realized that usually the disconnection (at least in my case) seemed to be due to a lack of data activity going on in the computer. I could be 15 minutes online and not disconnected, as long as I was doing something with the connection (whether it was loading a page, downloading email, downloading a file, etc). The moment it stopped, no more than a minute later I was disconnected. This was impossible to live with, I hated having to be disconnected all the time!

    And so I did some research. (Of course, to some this may be old news, to others new, i'm not taking credit for it. All I did was look for answers online)

    Apparently, some guy who set up his T650 (using Cingular) had the same problem on his PB. The set up was different (he used other scripts, not the Sprint one I use). He then mentioned that if we were having connection troubles, such as disconnections every 5 to 10 minutes, we should change the PPP settings a bit. I use T-Mobile, so I wasn't sure if this would apply to me, but I decided to try anyway.

    My PPP settings are as follows:

    Service Provider - T-Zones
    Account Name - (blank)
    Password - (blank)
    Telephone Number - *99***1#
    Alt. Number - (blank)

    Now click on the "PPP Options" button right below.

    My settings now are:

    Checked: Redial if Busy
    Checked: Use TCP header compression

    If you have "Send PPP echo packets" checked (as most people do), uncheck it and see if it gives you lots more online time (i've been leaving the PB connected and Idle for the past 37 minutes, still connected and fully functional--the guy who wrote the article was on for 1.5 hours, he used Cingular).

    This of course may not work for everyone, but it sure worked for me (T-Mobile user) and to others using Cingular. Maybe it would work for other carriers, honestly I am not sure, but I hope this post helps all those of you who are frustrated with the constant disconnection from your T650 BT DUN connection.

    Let me know how it turns out for some of you.

    - CMSNeuro
    Last edited by CMSNeuro; 02/11/2006 at 11:10 AM.
    Perfect as the wing of a bird may be, it will never enable the bird to fly if unsupported by the air. Facts are the air of science. Without them a man of science can never rise. - Ivan Pavlov
  3. #3  
    Hi,
    I had the exact same problem. Now I use Sprint PCS, but here is the solution that I found step by step:
    1) On the Powerbook, open system preferences.
    2) Click on Network
    3) In the "Location" dropdown, select "New Location"
    4) Give the new Location a name, example "Treo DUN"
    5) Click on the "Show" dropdown list, and select "Network Port Configurations"
    6) Only have the Port Configuration "Bluetooth" checked On.
    7) Click Apply Now.
    8) Make sure your PPP settings are set to what they were when you were getting online for only 5 - 10 minutes.
    9) For Sprint PCS the telephone number is #777
    10) Lastly, when using bluetooth DUN, click on the the apple in the menu bar
    11) Under location pop out list, select "Treo DUN" or whatever you named that location.
    12) The connect like you normally would.
    13) When you are done, make sure you change the location back to "Automatic" if you connect to other networks or devices.

    This should fix the problem on any Phone network, but I am not 100% sure. I do know that it will work on Sprint PCS.
  4. #4  
    "6) Only have the Port Configuration "Bluetooth" checked On."

    When you toggle through these options, only one of them is EVER checked; the one you are currently working on.

    It's weird. I can't figure it out. Sometimes I've been able to stay connected for over 4 hours, disconnecting myself at the end of a session. Who knows how long I would have stayed connected had I given it a chance?

    Other times, I get 3 to 5 minutes tops. Today I peaked at 45 minutes, but have mostly seen between 3 and 10 minutes. When I get booted, the message is invariably "the other side has stopped responding." Three out of four times, I reconnect with no issues. But that fourth (or so) time I get the dreaded "Failed to open an RFCOMM serial channel" message when I try to reconnect, in which case I have to turn Bluetooth off and on again on my Mac.

    The patterns I've noticed are: Disconnection due to inactivity seems to happen fairly often - usually when I'm typing a forum reply like this one. It seems to me that I can reconnect without the Bluetooth error in these cases. Other times, the failure seems to come during heavy use - in tonight's case trying to use DUN in conjunction with a P2P file-sharing programme (Azureus). I've been watching the download speeds, which have to my delight peaked at 18.1 kbps, but then after a while it drops to nil and web pages cease loading. After a minute or two of inactivity, I get the "other side has quit responding" message.

    No amount of fiddling with network prefs on the Treo or modem scripts on the Mac have given me any amount of joy with this. I find myself more desperate than you lot, as my Treo is my ONLY means of connecting to the Internet, at least at home. I freelance as an audio engineer, so I don't have an office to go to when I need a connection. I eschew cable TV, and don't have a home phone. It's the Treo or nothing.

    Sprint loves me, I'm sure.
  5. Erch63's Avatar
    Posts
    66 Posts
    Global Posts
    69 Global Posts
    #5  
    Turn of the multiple ping setting in bluetooth preferences this will stop all the disconnects.

Posting Permissions