Hi.
I have version 1.20 APR on my 650 and need to install 1.20 LAP. I get an error message 1312 = 'Device version invalid'
I guess It's doing some sort of version validation. Therfore I need to roll back to a version from where I can update from.
Now, I do not have a prior version of the firmware, so I would need the "how to" and the file to update from.

Thanks....