Results 1 to 5 of 5
  1.    #1  
    WTF??? I ran the updater on my 650 that had the latest experimental firmware on it - 1.71 - and the updater says "Your GSM (Pacific Rim Edition) device revision cannot be updated cannot be updated to a Unkown device revision 1.20." I bought this phone in NYC from JandR computers. Has anybody ever heard of this?
  2. #2  
    Quote Originally Posted by DigitalEarth
    WTF??? I ran the updater on my 650 that had the latest experimental firmware on it - 1.71 - and the updater says "Your GSM (Pacific Rim Edition) device revision cannot be updated cannot be updated to a Unkown device revision 1.20." I bought this phone in NYC from JandR computers. Has anybody ever heard of this?
    Yes, you cannot update a phone from a different region than the updater package is for. The solution is to downgrade with an SD card installation to an earlier version. Search through the threads on this latest upgrade and you will find the SD version of 1.28. Install that then install the 1.71-1.20 upgrade. Several people have had to go this route.
  3.    #3  
    Okay, I installed 1.51. The error message is gone on updating but the update fails on the updating screen. Tried it 5 times. Will not work.
  4. #4  
    Hi Digital Earth. I had the same problem. I did what someone on the boards said.

    Downgrade to 1.28. Then upgrade to 1.13 then run the standard PC updater. Everything working fine for me now.
  5.    #5  
    Yes, I finally got it to work on a Mac using jamesgangut files. Seems ok so far.

Posting Permissions