Results 1 to 8 of 8
  1.    #1  
    hello, need help w/ verizoned sprint treo 600 that won't recharge. The treo has worked great since March 2004 however recently for no apparent reason it won't charge. I tried four different charge cables and the "red" charge light will not light, nor is the battery charge indicator on. The Treo will HotSync but it won't charge. It seems like the bottom charge connector might be broken. I looked at pdaparts but they do not sell sell this part

    Anyone have a fix?
    thanks
  2. #2  
    This same thing started with my Treo 600.

    You might try a soft reset while the Treo is trying to be charged, as that usually works for me.
  3.    #3  
    DHAnderson, thanks for the suggestion. I tried but it did not fix the problem. I tried both a soft reset & a hard reset with the charge cable connected and the the "red" charge light will not light, nor is the battery charge indicator on

    I will keep you posted if I can resolve this problem
  4. #4  
    Probably time for a new battery.
  5. #5  
    Quote Originally Posted by dlbrummels
    Probably time for a new battery.
    I agree. I can't imagine that you could break the bottome connector (since it's in the treo housing.)

    You can get them ebay pretty cheap now. There are threads on how to do it to.
    Palm III-->Palm IIIxe-->Palm 505-->Samsung i300-->Treo 600-->PPC 6600-->Treo 650-->Treo 700wx-->BB Pearl--> BB Curve

  6. #6  
    This is a similar question: I recently bought a treo 600 on Ebay, and it has been working perfectly. I forgot to bring home the charger over the weekend and completely discharged the battery. Now I am having problems getting it to charge. When I plug it in, the lightning bolt comes on, but it is a green bolt and it does not seem to be charging.

    Might I have toasted my battery by letting it fully discharge??

    Matt
  7.    #7  
    Quote Originally Posted by dlbrummels
    Probably time for a new battery.
    I replaced the battery but that did not seem to help as it still won't charge. I tried four different charge cables and the "red" charge light will not light, nor is the battery charge indicator on. The Treo will HotSync but it won't charge

    anyone have any ideas how to fix?

    thanks
  8.    #8  
    Good News / Bad News - turns out my verizoned sprint treo 600's motherboard went bad and that was causing the no charging issue. The good folks at pdaparts diagnosed this for me (didn't charge me). So I went to fleabay and purchased a parts/repair verizon treo 600 w/ a bad screen for $56 and I swapped my good screen to the verizon treo. All is well.
    BTW, this saga took about 25 days in which time VZW/ Asurion declined my claim ( after 14 months of paying insurance). I got back $80 from VZW (so I am now $24 ahead). I purchased a new battery ( not the problem - original 25 month old battery still good). I tried & returned new VZW 650 and then 700W. I still think 600 is the best due to larger phone dial pad & larger phone pad #s
    Thank you to all that responded and hope this helps

Posting Permissions