Page 1 of 3 123 LastLast
Results 1 to 20 of 47
  1.    #1  
    Original post:

    Hi - I have been using Goodlink for many months with no problem. Recently, I did an OTA upgrade to 4.5 and have had fatal errors ever since. Here is the what the error message says:

    C:\build\release\maxwell\4_5_0\build_65\client_server_all\gx\system\src\palm\gxdevicepalm.cpp:238GX_ ASSERT in ffs2.cpp @ 1434

    with the last four numbers changing each time it freezes and shows an error message.

    I have gone to the Goodlink website to no avail. Has anyone else seen this error? It usually happens when the Goodlink software tries to connect. I've done a hard reset and tried to re-install but still get the error. Any ideas would be very helpful.


    UPDATED: I saw your repsonse re: reprovisioning phone. I am not 100% sure what that means, but I know that I managed to hard reset the phone so many times that I had to call Sprint and have them reset all of my data/network connections because the phone wouldn't synch or connect to the Internet. I am back to a functioning Treo but no matter what I do (including re-installing the Sprint f/w 1.12 update), I keep getting the error at the end of the Goodlink OTA download/initiating. Thoughts?
    J.
    Palm, Palm III, Palm Vx, Treo 300, Treo 600, Treo 650, Treo 700p, Treo 755p, and Palm Pixi
  2. #2  
    Let me send that error off to our tech guys and see what they come back with.
  3. #3  
    Is this a 600 or a 650? I am assuming a 650. The initial response I am getting is saying that it is a ROM issue and I am checking on possible fixes.
  4. #4  
    According to my tech folks, the error you are getting is a ROM issue. The only sure fire fix they know of is to replace the device. Sorry, not what you wanted to hear, I am sure.
  5. #5  
    Quote Originally Posted by jquinn14
    Original post:

    Hi - I have been using Goodlink for many months with no problem. Recently, I did an OTA upgrade to 4.5 and have had fatal errors ever since. Here is the what the error message says:

    C:\build\release\maxwell\4_5_0\build_65\client_server_all\gx\system\src\palm\gxdevicepalm.cpp:238GX_ ASSERT in ffs2.cpp @ 1434

    with the last four numbers changing each time it freezes and shows an error message.

    I have gone to the Goodlink website to no avail. Has anyone else seen this error? It usually happens when the Goodlink software tries to connect. I've done a hard reset and tried to re-install but still get the error. Any ideas would be very helpful.


    UPDATED: I saw your repsonse re: reprovisioning phone. I am not 100% sure what that means, but I know that I managed to hard reset the phone so many times that I had to call Sprint and have them reset all of my data/network connections because the phone wouldn't synch or connect to the Internet. I am back to a functioning Treo but no matter what I do (including re-installing the Sprint f/w 1.12 update), I keep getting the error at the end of the Goodlink OTA download/initiating. Thoughts?
    I get a similar error message if I don't start goodlink until after I have something else, web browsing, etc., that seems to take up some memory. You have to take the battery out to get a soft reset...but if you initiate goodlink first this error does not seem to occur and it is the other apps that will not start....
  6.    #6  
    Thanks for the feedback. Normally getting a new phone wouldn't be a problem but it would seem that somewhere over the last year, my phone insurance dropped from my Sprint bill and they are saying I can't swap the phone out. Guess I'll be goodlink-less until a new Treo model comes out that I upgrade to...Bummer
    J.
    Palm, Palm III, Palm Vx, Treo 300, Treo 600, Treo 650, Treo 700p, Treo 755p, and Palm Pixi
  7. #7  
    Quote Originally Posted by zamiv
    I get a similar error message if I don't start goodlink until after I have something else, web browsing, etc., that seems to take up some memory. You have to take the battery out to get a soft reset...but if you initiate goodlink first this error does not seem to occur and it is the other apps that will not start....
    I too have had the exact same message when I run an app that takes up a lot of memory before running Goodlink. If I do a soft reset, then launch Goodlink first, then it's ok. I can also then go and launch the other apps I want/need.

    Have you tried this?
    Waynew73

    (m105 => IIIxe => VIIx =>Tungsten T => i705 => Treo 600 => T-MO MDA => HTC Tytn = HTC Tilt & T-MO Dash => HTC TouchPro & HTC S740 => Palm Pre)
    Man, I've spent a lot of money and time on these things!!
  8. #8  
    I'm also having the same issue on multiple Treos on different versions of Good. Sound like this issue is starting to get more common.

    GoodGuy, have you heard anything other then to replace the phone?
  9. #9  
    No, I have not heard anything else.
  10. #10  
    We are starting to see this on many of our devices (600's and 650's). Good also told us it's a ROM issue; however we went into the GL console and disabled the password policy (just troubleshooting) and the problem went away. I believe part of the error code (ASSERT in ffs2.cpp) is related to the FIPs security module.

    We are seeing this on about 4% of our devices...... We haven't seen this as a result of an upgrade, it just seems to pop up unexpectedly. I am attempting to get the issue out of the help desk on into engineering (with Good).

    On a sidenote, when we first saw this issue about 3 weeks ago, we RMA'd the Treo650 to our carrier and they tested it out and said it wasn't bad and charged us full price for the replacement... That's not Good

    Hey GoodGuy, any buzz out there about this??
  11. #11  
    Sorry, have not heard anything. Let me see if I can find anything else out.
  12. #12  
    I, too, have had issues since migrating to the new 4.5 software.

    My device worked fine for ~3 months on the old software, but since installing the new 4.5 load it has been nothing but trouble. I have uninstalled, reinstalled and reprovisioned so many times I have lost count. Device apparently cannot maintain contact with the GL service and constantly 'reinitializes GoodLink', 'rebuilds radio traffic' and ultimately reboots.

    I thought all was solved (magically) recently when the device worked for almost a week with no issues. However today, it was back to reinitializing, rebuilding and rebooting all over again.

    Anyone out there with advice?
  13. #13  
    bascially based on my extensive research on message boards, with sprint, with good its the memory (cache) problem: the 650 doesn't have enough built in and Good is a cache hog.

    i had to pay $50 to get a replacement phone and prayed that re-installing 4.5 would work. so far so it works.

    i tried everything on my last phone but nothing worked. i love Good but believe that they need to take more ownership along with sprint/palm to fix the problem. but since the 700 is out i doubt that anything will be done.
  14. #14  
    I too paid the $50 to replace the 650 through sprint's replacement plan with a refurbished (looked new) treo. I then did a fresh install of 4.5 and had the exact same issue.

    What i think happened after trying to add this new 650 to our good server with there support team i found that it was already in Good's system under a different account meaning someone else had this phone and probably had the same issue sent it back to Sprint and they fixed it (new shell) and sent it to me as a replacement.

    From what Good is telling us they are working with Palm to release a fix.
  15. #15  
    i hope they release a fix, but i doubt they will. there is no reason for them to since it only affects a small percentage of peeps.

    i also had the same problem with my first replacement but immediately told sprint that the replacement didn't work either, so they sent me yet another one which seems to be working now.
  16.    #16  
    So, is it just me or everyone who wonders how the ROM gets screwed up by using Goodlink but is apparently not their problem to fix? How else would this one piece of ROM not work? My Treo works fine otherwise. I am perplexed as to why I need to get a whole new device all of a sudden. Thoughts?
    J.
    Palm, Palm III, Palm Vx, Treo 300, Treo 600, Treo 650, Treo 700p, Treo 755p, and Palm Pixi
  17. #17  
    i don't think the ROM gets screwed up. there is just not enough of it to allow good to work. i guess when there is an overflow of the ROM, it crashes. i'm not sure why ROM on a "newer" device would handle the overflow better. it's funny because i have used good for the last 2 years and on my last 650, it worked fine for 7-8 months with the newest firmware and Good update, then all of a sudden, fatal errors.
  18.    #18  
    This sounds like a Good issue to me.
    J.
    Palm, Palm III, Palm Vx, Treo 300, Treo 600, Treo 650, Treo 700p, Treo 755p, and Palm Pixi
  19. #19  
    Hi, I am having the same problem. I have used Good on my Cingular 650 for the past year or so. Then my Treo 650 started restarting itself constantly. Fed up I did a hard restart erasing everything intent on JUST RUNNING GOOD and nothing else as I rely on it daily. When I went to reinstall I keep getting:

    e:\build\release\kahlua_rtm1\4_7_0\build_25\client_server_all\gx\system\src\palm\gxdevicepalm.cpp:24 3 GX_ASSERT in ffs2.cpp @ 1678

    This is extremely infuriating. What is the quickest thing to do? Call cingular and request a new phone??? Seems like it's a software issue.
  20. #20  
    I had the same problem a few months ago. I tried eveything, but the error constantly came back. I was told the issue was with the device and that replacement was the only solution. I was VERY skeptical, but the replacement worked. I am currently working with custom ROMs to fix another memory issue with my unlocked Treo 650 users which may help as well. I would get the device replaced first since I have been through this before. I would not be happy owning something that may be an issue later on. I manage a large amount of Goodlink Treo devices and the issue seems rare. (> 1%)
Page 1 of 3 123 LastLast

Posting Permissions