Results 1 to 7 of 7
  1.    #1  
    Hello,

    First time post here.

    Very recently, my battery, which is about a week old, has been draining fast...about 10-12% and hour. The back of my 650 remains quite warm.

    There are no applications running that I know of and I am not using the phone at all. The signal is at 5 bars, so the phone is not searching for the netowrk. I am using Sprint, which I know alongside Verizon takes more juice, but I've had this phone 5 months, and this behaviour is really an abnormal.

    Today, I've loaded a few new programs. Snappermail (no auto checking of mail), eWallet, and Kmaps. Don't know if this has to do with anything.

    Any advice with what's going on is appreciated.

    Peter
  2. #2  
    I'd keep an eye on the latest apps that you've added. Take out one at a time to try to find the culprit.
    When I started using Versamail to check my gmail accounts my 650's battery drained super fast so I switched back to forwarding my gmail to my regular POP account and use Snappermail and that works much better for my battery. The last couple of days though my battery is going down fast again so this morning I removed AvantGo and will see if it improves today. If that's not it, I'll remove Kmaps which I've had since last weekend.
  3. #3  
    Heleo Peter!

    Read thru this thread, it will give some great insight:

    http://discussion.treocentral.com/sh...d.php?t=101233

    Cheers, Perry
  4. #4  
    My Sprint treo 650 has gone into turbo drain mode like you describe a couple of times now. In both cases, I noticed that the little 'cross-hair' location privacy indicator in the middle of the top row of the display was sort of shimmering (rather than being solid as it usually is). All I had to do to get it back to normal was to open up the battery compartment and press the reset button--voilla, solid cross hairs and no turbo drain.

    -Phil
  5. #5  
    Leaving the DUN on will also drain your battery. Make sure the little laptop icon isn’t on in the upper right hand corner.
  6. #6  
    There is a phone glitch, at least on unlocked GSM Treo: call a number which you know is busy, wait for busy signal and dismiss the call. Now call any number that is not busy: before getting connected you'll hear busy signal. This means that Treo either does not actually disconnect if the line is busy, or simply keeps giving busy signal after disconnect -- in any case this is a cause of major battery drain, so it is recommended to always make a call to a non-busy number after you get busy signal.

    Wonder if Palm is aware of this...
    Pilot Pro > 2Mb+IrDA upgrade > Clie T615C > Treo 650
  7. #7  
    Quote Originally Posted by pwest
    My Sprint treo 650 has gone into turbo drain mode like you describe a couple of times now. In both cases, I noticed that the little 'cross-hair' location privacy indicator in the middle of the top row of the display was sort of shimmering (rather than being solid as it usually is). All I had to do to get it back to normal was to open up the battery compartment and press the reset button--voilla, solid cross hairs and no turbo drain.

    -Phil
    At times mine also is shimmering I didn't think much of it, but I also thought I suffered from Turbo drain and what seemed to of fixed it was letting the battery go through a full cycle meaning let it drain way down into the red then charge it for 12 hours do this about 3 times. There has been a significant difference since I have done this also if B/T is enabled make sure discoverable is set to "NO"
    Phil might be right about the shimmering icon also................

Posting Permissions