Page 1 of 2 12 LastLast
Results 1 to 20 of 25
  1.    #1  
    Just installed PalmVNC on the 650 and can't seem to get it to work. Left the Server side settings as default except the password. Typed in teh IP on the setup on the 650 (the IP that shows up when I hover over the server icon on my desktop?). Left everything else as default. Am I missing something here? It just fails to connect whenever I try to run it?
  2. naivete's Avatar
    Posts
    636 Posts
    Global Posts
    640 Global Posts
    #2  
    Make sure your hostname is !! and if your computer is behind a firewall, make sure that your firewall is configured to allow the traffic.
  3. #3  
    More info would be helpful.
    Is this at work? At home? How is your computer connected to the internet?

    If not a firewall (which everyone should use, but that's another thread) you might be using a router (such as a Linksys or DLink, etc). If so, the IP of your machine is likely something like 192.168.1.100. This will not work. You would need to configure your router to forward the VNC traffic to your computer. You would then connect to the public IP of your router.
    "Common sense is the collection of prejudices acquired by age eighteen."
    - Albert Einstein
  4.    #4  
    It is at home and I do have a DSL router and a linksys wireless router. Can you give me some more details as to how I need to set this up? I am using te IP as you described above and this appears to be why it is not working. Thanks.
  5. #5  
    you need to setup port forwarding on the linksys router, using port 5900 (default), and pointing to the vnc server IP...

    Then in PalmVNC, you put in the IP of your linksys router....it will be listening on port 5900 and will forward all traffic through to the server.

    This works great by the way. (And if you have more than one server at home, you can change the port that VNC is running on (i.e., 5901, 5902, etc.) for each machine....
  6. #6  
    Quote Originally Posted by delta_baggage
    you need to setup port forwarding on the linksys router, using port 5900 (default), and pointing to the vnc server IP...

    Then in PalmVNC, you put in the IP of your linksys router....it will be listening on port 5900 and will forward all traffic through to the server.

    This works great by the way. (And if you have more than one server at home, you can change the port that VNC is running on (i.e., 5901, 5902, etc.) for each machine....
    Could not have been said better!
  7. #7  
    Also, dont forget to put the IP address in the link from the tre0, ie:

    xxx.xxx.xxx.xxx:5900
    Click for Free iPod Nano or better. - really works!
  8.    #8  
    Ok, here is what I have done.

    In the application and gaming port range forward of the Linksys I put 5900 to 5900 for start and end port. Protocol to Both. IP to Ip of the server that is running. Clicked enable. Not sure exactly what IP to put in the treo? I put the local IP address in the first screen of the Linksys Maintenance and it still will not connect. Tries to connect to local IP I mention above, error. Then tries to connect to IP of server and another error. Any thoughts?
  9. #9  
    You should be using the public IP of the linksys. This is NOT the one that starts with 192.168.1.x.

    If you can't find it, just go to your computer and browse to http://whatismyip.com . Use that IP in the VNC client on your Treo.

    BTW, 5900 TCP should be fine, no need for UDP. You should never open more than you need...as a general rule.

    Good luck.
    "Common sense is the collection of prejudices acquired by age eighteen."
    - Albert Einstein
  10.    #10  
    Still no dice. Any other settings you can think of that I might need to change? I got the IP as described above. What about Port triggering and the other settings under applications and gaming in the linksys?
  11. #11  
    No need for port triggering. Forward the port under applications and gaming. Make sure that you actually enabled that, and that you specified the correct IP of your "server". Also, note that you are specifying a dynamic IP for that server, so if you rebooted it, it may have gotten a new IP.

    Once that is all setup, make sure that VNC server is actually running on your PC. Does it have windows firewall enabled? That could be blocking you. Do you have another pc to test that connection on your internal network?

    If all of that is working, you could then try to telnet to your public IP on port 5900 to see if it is listening. Or maybe just have a friend try to connect to you from their home computer.
    "Common sense is the collection of prejudices acquired by age eighteen."
    - Albert Einstein
  12. naivete's Avatar
    Posts
    636 Posts
    Global Posts
    640 Global Posts
    #12  
    In your Linksys configuration page, make sure that you have "Block WAN Request" disabled. It is enabled by default.
  13.    #13  
    I tried to telnet to the IP from my work computer and get a could not connect error. Could be because the work PC is bocking it. All other settings look right according to what is in this thread. Not sure what else to try?
  14. naivete's Avatar
    Posts
    636 Posts
    Global Posts
    640 Global Posts
    #14  
    Quote Originally Posted by mjferguson
    I tried to telnet to the IP from my work computer and get a could not connect error. Could be because the work PC is bocking it. All other settings look right according to what is in this thread. Not sure what else to try?
    Depending on the network configuration at work, you might have to establish a vpn connection before launching palmvnc. Also, take a look at PSSH and Micro VNC.
  15.    #15  
    Tried turning off ALL security and still says unable to connect. Does the Remote Router Access function in the linksys setup have anything to do with it? I am about to give up, although this tool seems like it would be cool.
  16. #16  
    Okay, just one quickie first: Do NOT include the port in the the IP entry on your treo's PalmVNC connection settings (it is pre-specificied under the "advanced" settings; this is where you would change it if you were running the vnc server on an alternate port as I described in my original reply).

    Also, I suggest that you use fixed (static) IP addressing on your internal network, because you may find that the vnc server (internal pc you are trying to "publish") is changing its IP, which can unexpectedly break the port forwarding, which relies on a static IP.

    Now, let's try to do this simply:

    Linksys Router External IP (assigned by ISP): 66.xxx.xxx.xxx
    (this is typically dynamic; and thus it can be useful to use a dynamic dns service)

    Linksys Router Internal IP (typically default): 192.168.1.1

    Internal PC IP (vnc server to be published): 192.168.1.10 (whatever internal address you are using)

    On the router, under port forwarding, you will enable tcp on 5900 to 5900 pointing to IP 192.168.1.10

    On your treo, you will input the external linksys IP (66.xxx.xxx.xxx) under the connection settings (NO port specification)

    Final repeat: Make SURE that any PC firewall (such as the builtin XP firewall) is either completely disabled (bad) or that exceptions are allowed AND that vnc is specifically checked under the program exceptions list (better).
  17. naivete's Avatar
    Posts
    636 Posts
    Global Posts
    640 Global Posts
    #17  
    If you are using Windows NT/2K/XP, make sure that you entered your NT username and password in the palmvnc connection profile.
  18. #18  
    Quote Originally Posted by naivete
    If you are using Windows NT/2K/XP, make sure that you entered your NT username and password in the palmvnc connection profile.
    His original message says: "Left the Server side settings as default except the password." So I believe he is only using the vnc connection password option.
  19.    #19  
    This is exactly what I have already done a number of times and I can't connect. I guess maybe it just won't work for me with me ISP or something? Oh well.
  20. #20  
    Quote Originally Posted by mjferguson
    This is exactly what I have already done a number of times and I can't connect. I guess maybe it just won't work for me with me ISP or something? Oh well.
    mj,

    If you want some offline help, send me a PM and I will help walk you through this over IM. I seriously doubt your ISP is the issue.
    "Common sense is the collection of prejudices acquired by age eighteen."
    - Albert Einstein
Page 1 of 2 12 LastLast

Posting Permissions