After alot of reading and searching, I still did not see a solution for my calendar syncronization problems.

I know if you use Versamail active sync, it automatically set Calendar syncronization to "Do Nothing" because active sync is suppose to take care of syncing the calendar.

Here's my problem:
I removed the active sync account and I setup an IMAP account. Versa mail still sets my calendar to "Do Nothing". When I go to Hot Sync-> Custom and try to change the setting from "Do Nothing" to "Syncronize", "Desktop overwrites handheld" or "Handheld overwrites Desktop", Hot Sync crashes most of the time. If it doesn't crash, it just automatically sets itself back to "Do Nothing"

It seems like even though I removed the active sync account in versamail, it still trying to disable my calendar sync.

Any suggestions?