Results 1 to 6 of 6
  1.    #1  
    I had the following completely unhelpful discussion with tech support about a bug in Hotsync Manager, namely that under some circumstances it changes the COM port assigned in Setup on its own. It causes great troubles because it invariably will choose a port that is not used for hotsync. I hope that this posting will help in alerting a person that can actually fix this problem

    Dear ...,

    As we do not develop or provide USB to serial adapters, we cannot certify they will work as you desire.

    Kind Regards,
    ...
    Palm Technical Support

    Original Message Follows:
    ------------------------
    Dear Mrs ...,

    I am sorry, but this absolutely does not address the problem.

    The problem is that when the Hotsync Manager version 6.01 is running, I cannot use my USB to serial adapter anymore, because Hotsync grabs/opens the port and so prevents the application that I want to use with the adapter from using this port.

    On my system, COM5 is used for Bluetooth communication with the Treo, and I set Hotsync Manager to use that port. Now I plug in an USB to Serial adapter, which makes COM8 available. When I now look in the configuration for Hotsync Manager, the port is changed to COM8! And of course, no other application can open COM8 anymore, until I change the assignment back in Hotsync Manager. To reiterate, the only thing I am doing here is inserting the adapter! I get the impression, Hotsync Manager thinks its clever by changing my settings, but in reality it is just an unruly three year old boy!

    Now how do I prevent Hotsync Manager from doing these changes?

    Kind Regards,
    ...

    -----Original Message-----
    From: Palm European Technical Support
    Sent: Thursday, 24 November, 2005

    Dear ....,

    Thank you for contacting Palm Technical Support.

    You do not need to worry about which COM-port is in use as long as you synchronize via USB and not Bluetooth.

    If you have any further questions please contact us again.

    Kind Regards,
    ...
    Palm Technical Support

    Detailed Description: The HotSync Manager version 6.01 has a very annoying habit of changing the COM port I have selected in settings. Namely, whenever I insert an USB device that causes a COM port to become newly active, that COM port is automatically grabbed by HotSync. I have manually selected the correct COM port to use, but the software always changes this. This makes using the software very annoying, and I hope that you will be able to quickly resolve this issue. ThirdParty Apps: None, this has been observed with a fresh install on multiple computers.
  2. #2  
    As much as you don't want to hear this....it really isn't a Palm issue. It's a Windows issue. You noted that when you plug the adapter into the slot then it changes to COM8 - that's the fault of the driver for the device.....and as Palm noted. They don't support such devices. This is a Windows driver failure for this very special adapter that you are using.

    I would suggest, although I'm not sure it's possible, to unistall everything and with the adapter in the slot - then reinstall the Palm desktop and see if you can "force" the COM port as you desire.
    Moose Man
    Welcome my son, welcome to the machine.
    iPhone 3G, Treo 750, 680, 650, 600 and T5, T3, T, M515, M505, Vx, V, Prizm, Visor, IIIc, IIIe, Palm Pilot Professional, Palm Pilot (ok boys and girls a whopping 128k of memory - those were the days) and former Palm Beta tester.
  3.    #3  
    The problem is not that the COM port assignments as seen by Windows change. They remain constant. COM5 is always my Bluetooth port, and COM8 is always my serial to USB adapter. The problem is that I have manually told Hotsync Manager to use COM5 for local synchronisations, but when I plug in the adapter, Hotsync Manager changes my manual assignment, and suddenly decides that it has to use COM8 for synchronisation. This is the problem, that Hotsync Manager switches to the wrong port on its own. And it is definitely a programming fault with Hotsync Manager.

    I will make another try to clarify this with support.

    PS: How much are you willing to bet that this is not a Hotsync Manager problem?
  4. #4  
    Windows forces the Palm devices to use the highest port possible to avoid potential conflicts with the modem. Windows - controls all ports and when it sees the new device (your USB to Serial adapter) it tells HotSync to change - it's semantics so no bet.

    But are you trying this? Shut down hotsync manager with it set for Com 5. Install your USB to Serial device and plug in whatever device your using with it and then relaunch HotSync to see what it then does......

    Hot Sync does not have to load with Windows boot in order to work. You can load it manually and hotsync should be fine. Yeah sure, it's a pain but maybe the best work around your going to get?
    Moose Man
    Welcome my son, welcome to the machine.
    iPhone 3G, Treo 750, 680, 650, 600 and T5, T3, T, M515, M505, Vx, V, Prizm, Visor, IIIc, IIIe, Palm Pilot Professional, Palm Pilot (ok boys and girls a whopping 128k of memory - those were the days) and former Palm Beta tester.
  5. #5  
    I have the same local serial port changes problem when enabling bluetooth adapter for sync thru bluetooth. No solution for this problem. However, to life a bit easier, I created a palmBluetoothSync.reg file, which force hotsync to use correct serial port and enable local sync. After enabling bluetooth adapter, double click this reg file to modify the hotsync registry. Here is the content in the palmBluetoothSync.reg.


    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\U.S. Robotics\Pilot Desktop\HotSync Manager]
    "Local"=dword:00000001
    "DirectComPort"="COM6"
  6. #6  
    That is a really annoying bug in HotSync.

    Go into configuration setting in HotSync to say use 'Com1'.

    Then, later, you boot up Windows, and HotSync complains that 'Com4' is not available. ARG.

    So, go into HotSync, to say use 'COM1' again. (that is the only comport that is listed in the drop down)

Posting Permissions