Page 9 of 10 FirstFirst ... 45678910 LastLast
Results 161 to 180 of 186
Like Tree29Likes
  1. #161  
    OK seems like I got a bit further and got working touchpanel now On to profile, Impostah and those fun things now

    Solution was quite easy in the end:

    Code:
    stop hidd
    PmTpUpdater -a
    PmTpUpdater -f
    start hidd
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
    MartinH@webos and Rnp like this.
  2. #162  
    I guess it was pure luck, 2nd TP Go, doesn't want to update Touchpanel. Any suggestions are welcome
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  3. #163  
    Quote Originally Posted by Herrie View Post
    I guess it was pure luck, 2nd TP Go, doesn't want to update Touchpanel. Any suggestions are welcome
    OK 2nd one seems to be updating now as well after a number of retries, reboots and just trying PmTpUpdater -f 10+ times each reboot

    [edit]
    Seems like it didn't complete... I guess I need some more trial & error to get through
    [/edit]
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
    MartinH@webos likes this.
  4. #164  
    Quote Originally Posted by Herrie View Post
    OK 2nd one seems to be updating now as well after a number of retries, reboots and just trying PmTpUpdater -f 10+ times each reboot

    [edit]
    Seems like it didn't complete... I guess I need some more trial & error to get through
    [/edit]
    Be careful, if you corrupt the True Touch Cypress 395 chip the only way I have been able to recover was to use the Cypress MiniProg3 programmer to reprogram the chip...

    If the firmware took, but it is not calibrating use the catnip command in the PmTpUpdater instead of re-flashing the 395 and the two 375 chips, or you might corrupt the PSoC chip logic...
  5. #165  
    Quote Originally Posted by John Steffes View Post
    Be careful, if you corrupt the True Touch Cypress 395 chip the only way I have been able to recover was to use the Cypress MiniProg3 programmer to reprogram the chip...

    If the firmware took, but it is not calibrating use the catnip command in the PmTpUpdater instead of re-flashing the 395 and the two 375 chips, or you might corrupt the PSoC chip logic...
    375 seems OK, just 395 seems to fail :S Which catnip command for calibration? For the TP Go that flashed OK, the touch is about 1cm off to the right.
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  6. #166  
    man!!!... tempting now.. very - seems both devices are running 99% ? webos.
  7. #167  
    man!!!... tempting now.. very - seems both devices are running 99% ? webos.
    Well yes and no... Both can see webOS but only 1 registers touch (but it's off a bit from where you touch (I need to touch 0,5 to 1cm to the right of what I actually want to touch)). I used modified TPDebrick from jcsullins and it seemed that the token didn't get flashed properly, causing the Doctor not to work for example and maybe also causing the TP firmware update to have issues. I will do some more testing and document steps. Also found some interesting files on some Chinese board again that I need to look into :-)


    -- Sent from my TouchPad using Communities
    Last edited by Herrie; 11/29/2013 at 01:38 AM.
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  8. #168  
    Quote Originally Posted by Herrie View Post
    Well yes and no... Both can see webOS but only 1 registers touch (but it's off a bit from where you touch (I need to touch 0,5 to 1cm to the right of what I actually want to touch)). I used modified TPDebrick from jcsullins and it seemed that the token didn't get flashed properly, causing the Doctor not to work for example and maybe also causing the TP firmware update to have issues. I will do some more testing and document steps. Also found some interesting files on some Chinese board again that I need to look into :-)


    -- Sent from my TouchPad using Communities
    Well back to square one... Doctor worked properly after I manged to DD the token back in, however it tried to do a Touchpanel update on the working Touchscreen, which failed with the 395 update again (375 seemed OK) and now the touchscreen is not responsive anymore.

    It seems I have some lemons or maybe my Go's are using a slightly different version of the Touchpanel causing it not to be able to flash somehow?
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  9. #169  
    Quote Originally Posted by Herrie View Post
    Well back to square one... Doctor worked properly after I manged to DD the token back in, however it tried to do a Touchpanel update on the working Touchscreen, which failed with the 395 update again (375 seemed OK) and now the touchscreen is not responsive anymore.

    It seems I have some lemons or maybe my Go's are using a slightly different version of the Touchpanel causing it not to be able to flash somehow?
    Herrie I PMed you...

    Also updating the firmware on the TouchPanel (on the Touchpad Go) is very risky, during the Doctor/PmTpUpdater the version (.ver file has the incorrect version and will force an install even when it is already installed).

    During the install the CMTA395 chip gets reset, which sometimes works, sometimes fails when it fails the firmware gets corrupt, this causes the USB bridge to disappear then the kernel can no longer talk to the True Touch Chips.

    Fixing this is not for the faint of heart to fix one must use the MiniProg3 and create a Serial pin out (the wires are the size of a human hair and if they touch you can fry the chip).
  10. #170  
    Quote Originally Posted by Herrie View Post
    Well yes and no... Both can see webOS but only 1 registers touch (but it's off a bit from where you touch (I need to touch 0,5 to 1cm to the right of what I actually want to touch)). I used modified TPDebrick from jcsullins and it seemed that the token didn't get flashed properly, causing the Doctor not to work for example and maybe also causing the TP firmware update to have issues. I will do some more testing and document steps. Also found some interesting files on some Chinese board again that I need to look into :-)


    -- Sent from my TouchPad using Communities
    Isn't there a calibration tool to fix the off-set of the touch?..or is this the issue of the firmware?
  11. #171  
    Quote Originally Posted by daexpression View Post
    Isn't there a calibration tool to fix the off-set of the touch?..or is this the issue of the firmware?
    Maybe John Steffes can also advise further??

    TP 32Gb 4G. 3.0.5 / CM10. ~ Pre3 16Gb GSM. 2.2.4. ~ TS2 BT Audio-Dock ~ HP iPaq. hx-2790b.
    TP 32Gb Wifi. 3.0.5 / CM10. ~ Veer (Wht.) 8Gb GSM. 2.2.4. ~ HP Omen-15-5206tx. 256Gb SSD. i7-O/C@3.39Ghz. Win10.
  12. #172  
    Quote Originally Posted by Mutoidi View Post
    Maybe John Steffes can also advise further??
    Quote Originally Posted by daexpression View Post
    Isn't there a calibration tool to fix the off-set of the touch?..or is this the issue of the firmware?
    Quote Originally Posted by Herrie View Post
    375 seems OK, just 395 seems to fail :S Which catnip command for calibration? For the TP Go that flashed OK, the touch is about 1cm off to the right.
    Reposted from here: 4G TouchPad Owners Lounge

    Startup Calibration - Touchpad

    Quote Originally Posted by John Steffes View Post
    There are many ways to calibrate the Digitizer, using PmTpUpdater -c this might force an firmware update as well...

    If you just want to calibrate the Digitizer using catnip use the following commands (in novaterm):
    stop hidd
    catnip resume
    catnip --i2c-only cal -s 64
    catnip suspend
    start hidd

    This will fix the I tapped here but the ripple showed there...

    This will work if you can talk to the True Touch Chips, if you see an i2c error then most likely the cmta395 USB HSSP bridge firmware is corrupt?
  13. #173  
    Ok

    picked up 2 webos go devices.

    First one 64GB - Touchpad go running android 2.3.3. (3G) - not checked modem type.
    screen - corners are dim (not sure if this is a display issue of just a driver issue).
    Fixed a cache problem - (no cache) had to put it into sdcard - and link it.
    has SIM slot - put in a 3G sim card you get H+
    installed marketplace and was able to download android apps and install.
    (cache issue seems to reappear when you do a reboot using the following shell commands)

    You gonna need Android Terminal Simulator or equivalent terminal app. This will also require your Android rooted.
    Type ’su’ (root permission request will be showned, you need to approve it).
    Type ‘cd /’
    Type ‘umount /cache’
    Type ‘mount -o rw,remount -t rootfs rootfs /’ (to set the folder access to rw – read write)
    Type ‘rmdir /cache’ (delete cache folder)
    I personally using root explorer to do point 5-6
    Type ‘mkdir /sdcard/cache’
    Type ‘ln -s /sdcard/cache /cache’ (to link cache folder to /sdcard/cache – which shoud have bigger partition size)



    Second one 32GB - Touchpad go running android 2.3.3 (3G) - not checked the modem type
    Screen - perfect.
    have not tested..
    Last edited by daexpression; 12/02/2013 at 09:48 PM.
    Rnp likes this.
  14. Michau's Avatar
    Posts
    54 Posts
    Global Posts
    68 Global Posts
    #174  
    Quote Originally Posted by Herrie View Post
    Actually not, still stuck :-( I might put up some instructions on how to backup some partitions in the next day or so. I guess restoring the bootie partition from a working TP Go that runs webOS with QPST is the only way to get it working right now. I'll dig up the instructions and post them here :-)

    -- Sent from my TouchPad using Communities
    OK, I'll be waiting
  15. #175  
    Well here we go again! Thanks to lemanho who suggested to use NovaDeviceInstaller (NDI) and force TouchPanel update there I'm back in business on 1 Go! TouchPanel firmware update failed with NDI as well bit could do the following after a reboot :-)

    Code:
    stop hidd
    PmTpUpdater -a
    PmTpUpdater -f
    start hidd
    The touch is still 1 cm off, but at least back :-) Will try the other Go soon too :-)

    -- Sent from my TouchPad using Communities
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
    Rnp likes this.
  16. #176  
    regarding this issue of no space, apparently the solution i found is temporary. I can after doing the steps install marketplace apps, but after a while (say 1 day), the error appears again. So am now researching a permanent solution for this problem.
    it might be the case that the android image used - as it was a testing environment, ;the testers/ developers didn't cater for large cache sizes for installation purposes.
    If anyone has insight into this would appreciate it.
  17. #177  
    It's been a while, been busy with a bathroom renovation project and family + friends visiting over the holiday period, but finally had some time today to play with my 3rd TP Go.

    I managed to get it to webOS fairly easy using a modified TPDebrick004 and some help of jcsullins.

    It's as easy as:

    1. Putting the Go in "Qualcomm HS-USB QDLoader 9008" with Power+Home+Volume Down.
    2. Run modified TPDebrick004.
    3. Put token (otherwise cellular, WiFi and BT won't work).
    4. Run Nova Device Installer to flash Go rootfs.tar, update Modem, TouchPanel and A6.

    The 3rd Go also has the problem of the tap ripple being about 1cm off to the left from where I touched. I tried the catnip cal from above but that doesn't solve the problem unfortunately.

    The 2nd Go still is broken and will probably need to be sent off to John for fixing.

    Still some outstanding issues:

    1. Charging on the Touchstone doesn't work for me. I'm not sure what's required for that? I noticed 1 Go only had 6 pins, other 7 pins. Some backs only have 6 pins, others 8.

    2. Is there a way to find what kind of Go it is (board type, serial number etc) somewhere on the mainboard? It seems my stickers on the back and Ericsson card aren't belonging together.
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  18. Gwidion's Avatar
    Posts
    215 Posts
    Global Posts
    216 Global Posts
    #178  
    Quote Originally Posted by Herrie View Post
    1. Charging on the Touchstone doesn't work for me. I'm not sure what's required for that? I noticed 1 Go only had 6 pins, other 7 pins. Some backs only have 6 pins, others 8.
    My two TPgo (both with webOS) have 8 Pins, both function with Touchstone, but you have to control the fixation of the backside because sometimes there is the contact broken.
  19. #179  
    Quote Originally Posted by Gwidion View Post
    My two TPgo (both with webOS) have 8 Pins, both function with Touchstone, but you have to control the fixation of the backside because sometimes there is the contact broken.
    Could it be that some of my pins are broken? I could just place new ones and it might work? Anyone who tried?
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  20. #180  
    Herrie: this is awesome. I have a tp go running android 2.3.1 that I am looking to convert.
    This space for rent or lease. Inquire within.
    Rnp likes this.
Page 9 of 10 FirstFirst ... 45678910 LastLast

Similar Threads

  1. 3rd old news HP touchpadgo opal android version
    By lemanho in forum Android on webOS
    Replies: 27
    Last Post: 09/28/2013, 03:44 AM
  2. The Great webOS Nation Giveaway: webOS haiku, four HP Pre3s to win, for AT&T
    By Derek Kessler in forum webOSNation.com - Site News, Feedback & Help
    Replies: 2
    Last Post: 04/13/2013, 11:09 AM
  3. HP TouchpadGO stuck after IPK install
    By henri_p in forum HP TouchPad
    Replies: 65
    Last Post: 11/23/2012, 01:09 AM
  4. Replies: 10
    Last Post: 02/21/2012, 04:44 AM
  5. Replies: 7
    Last Post: 03/06/2011, 05:45 AM

Posting Permissions