Page 8 of 9 FirstFirst ... 3456789 LastLast
Results 141 to 160 of 170
  1. #141  
    Quote Originally Posted by k3dar View Post
    woodmaster: be sure you have downloaded latest Makefile
    Yep, you never know that "a bunny" could have broken

    I sent the devs a patch to avoid most out of space errors, but it seems I missed some dashes here and there... Fortunately they have been fixed... in the latest makefile
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  2.    #142  
    Updated makefile and reflashed image & kernel, now bootr doesn't load. Will reinstall bootr and post back.
    ᛖᚲ ᚹᛁᛏᚲᛁ ᚱᛁᛊᛏ ᚱᚢᚾᚠᚱ
  3.    #143  
    bootr reinstalled, still same results when I try to boot SHR: just goes into boot loop and reloads bootr infinitely until I choose webOS :-(
    Last edited by woodmaster; 05/17/2011 at 10:05 AM. Reason: wrong emoticon
    ᛖᚲ ᚹᛁᛏᚲᛁ ᚱᛁᛊᛏ ᚱᚢᚾᚠᚱ
  4. #144  
    NuttyBunny: i send patch before hour, with fixing minimal size counting, as pre have 6.7 and plus/2 have 14.3 in factory media partition size

    woodmaster: Bootr you have installed using Makefile ?

    edit: try this over novaterm:
    Code:
    md5sum /boot/uImage-palmpre.bin
    mount /dev/store/fso /media/card
    df -h /media/card
    ls -l /media/card
    ls -l /media/card/sbin/init*
    and paste output here
    Last edited by k3dar; 05/17/2011 at 10:22 AM.
  5.    #145  
    Quote Originally Posted by k3dar View Post
    NuttyBunny: i send patch before hour, with fixing minimal size counting, as pre have 6.7 and plus/2 have 14.3 in factory media partition size

    woodmaster: Bootr you have installed using Makefile ?

    edit: try this over novaterm:
    Code:
    md5sum /boot/uImage-palmpre.bin
    mount /dev/store/fso /media/card
    df -h /media/card
    ls -l /media/card
    ls -l /media/card/sbin/init*
    and paste output here
    Yes, reinstalled bootr via makefile.
    Code:
    # md5sum /boot/uImage-palmpre.bin
    51e32bcc7fd4195fe78611c312406b8b  /boot/uImage-palmpre.bin
    # mount /dev/store/fso /media/card
    # df -h /media/card
    Filesystem                Size      Used Available Use% Mounted on
    /dev/store/fso            7.7G    145.8M      7.2G   2% /media/card
    # ls -l /media/card
    drwx------    2 root     root         16384 Dec 31  1999 lost+found
    # ls -l /media/card/sbin/init*
    ls: /media/card/sbin/init*: No such file or directory
    ᛖᚲ ᚹᛁᛏᚲᛁ ᚱᛁᛊᛏ ᚱᚢᚾᚠᚱ
  6. #146  
    woodmaster: kernel you have installed correct, but fso partition is empty. This is issue why Bootr don't start SHR...
  7.    #147  
    why would it b empty? Pretty sure I followed install correctly.
  8. #148  
    Nevermind... there are several issues that arise when you run install-all. Lemme fix them, commit the file and then you can test
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  9. #149  
    i try some test, and with dot is not problem, i think because woodmaster have 9GB partition, is need more time for erasing before mounting, i send now next patch to devs with correct checking if some is wrong (changed true to false and with removing sending mkfs.ext3 to background

    woodmaster: edit Makefile and replace "&>" with ">" (is only once in Makefile)
    or use this command
    sed -i 's/&>/>/' Makefile

    and do again: make flash-image
    and paste output here
  10. #150  
    Quote Originally Posted by k3dar View Post
    i try some test, and with dot is not problem, i think because woodmaster have 9GB partition, is need more time for erasing before mounting, i send now next patch to devs with correct checking if some is wrong (changed true to false and with removing sending mkfs.ext3 to background

    woodmaster: edit Makefile and replace "&>" with ">" (is only once in Makefile)
    or use this command
    sed -i 's/&>/>/' Makefile

    and do again: make flash-image
    and paste output here
    The dot does make a difference with the bootr installation

    I'm checking the Makefile to try to fill all the voids we have, so the install-all option work (right now it doesn't)

    -- Sent from my Palm Pre using Forums
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  11.    #151  
    I will try. How could I lower that 9GB? It is really more than I wanted to allocate for Shr. I have 14 GB set for media, so not sure how it got 9GB unless on my initial attempts, it got that way. Also, @NuttyBunny, I am ok with not using "all"(although it should b made to work.) I got as far as I have by following the manual instructions.
  12. #152  
    Quote Originally Posted by woodmaster View Post
    I will try. How could I lower that 9GB? It is really more than I wanted to allocate for Shr. I have 14 GB set for media, so not sure how it got 9GB unless on my initial attempts, it got that way. Also, @NuttyBunny, I am ok with not using "all"(although it should b made to work.) I got as far as I have by following the manual instructions.
    Please, test with this Makefile, it has k3dar's and my latest changes.
    It DOES run install-all properly now

    just rename it to Makefile

    This, until they update the git repo
    Attached Files Attached Files
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  13.    #153  
    worked! I did not remove any of my media either(200 or so songs plus other randomness) It backed up & restored everything. On first boot attempt to SHR it locked up @ a blank screen. Did battery pull and it booted SHR. Had to shut SHR down via battery pull and it boots webOS(2.1.0 meta-dr Vzw Pre+) Awesome work fixing this makefile guys!
    ᛖᚲ ᚹᛁᛏᚲᛁ ᚱᛁᛊᛏ ᚱᚢᚾᚠᚱ
  14.    #154  
    Quote Originally Posted by k3dar View Post
    NuttyBunny: nice repport older Makefile have too 5.5 as default in current is fixed downloading of rootfs and reflashing image. Info and checking minimal size will be fixed soon.

    I don't test periph under SHR, but firmware for wifi is already in roofs, if you can more firmware for your testing, put extra script in subdir "scripts" and run "make extra", this copy firmware from webOS doctor to SHR rootfs
    I get errors on this.
    Code:
    make setup-extra
    Copying all extra files to extra directory ...
    [: 20: lib/firmware/helper_sd.bin: unexpected operator
    [: 20: lib/firmware/sd8686.bin: unexpected operator
    [: 20: lib/firmware/mfg_sd8686.bin: unexpected operator
    [: 20: lib/firmware/sd8686_ap.bin: unexpected operator
    [: 20: lib/modules/2.6.24-palm-joplin-3430/kernel/net/wifi/uap8xxx.ko: unexpected operator
    [: 20: lib/modules/2.6.24-palm-joplin-3430/kernel/net/wifi/sd8xxx.ko: unexpected operator
    [: 20: etc/camd/smia_ed.cfg: unexpected operator
    [: 20: etc/camd/vx6852-load-firmware: unexpected operator
    [: 20: etc/camd/vx6852-once-0.00.bin: unexpected operator
    [: 20: etc/camd/vx6852-once-0.10.bin: unexpected operator
    [: 20: etc/camd/vx6852-once-1.20.bin: unexpected operator
    [: 20: etc/camd/vx6852-once-2.21.bin: unexpected operator
    ᛖᚲ ᚹᛁᛏᚲᛁ ᚱᛁᛊᛏ ᚱᚢᚾᚠᚱ
  15. #155  
    Quote Originally Posted by woodmaster View Post
    I get errors on this.
    Code:
    make setup-extra
    Copying all extra files to extra directory ...
    [: 20: lib/firmware/helper_sd.bin: unexpected operator
    [: 20: lib/firmware/sd8686.bin: unexpected operator
    [: 20: lib/firmware/mfg_sd8686.bin: unexpected operator
    [: 20: lib/firmware/sd8686_ap.bin: unexpected operator
    [: 20: lib/modules/2.6.24-palm-joplin-3430/kernel/net/wifi/uap8xxx.ko: unexpected operator
    [: 20: lib/modules/2.6.24-palm-joplin-3430/kernel/net/wifi/sd8xxx.ko: unexpected operator
    [: 20: etc/camd/smia_ed.cfg: unexpected operator
    [: 20: etc/camd/vx6852-load-firmware: unexpected operator
    [: 20: etc/camd/vx6852-once-0.00.bin: unexpected operator
    [: 20: etc/camd/vx6852-once-0.10.bin: unexpected operator
    [: 20: etc/camd/vx6852-once-1.20.bin: unexpected operator
    [: 20: etc/camd/vx6852-once-2.21.bin: unexpected operator
    Did you do this while running webOS?

    -- Sent from my Palm Pre using Forums
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  16.    #156  
    no, ran make memload first...webOS needs to be running for it to work then?
    ᛖᚲ ᚹᛁᛏᚲᛁ ᚱᛁᛊᛏ ᚱᚢᚾᚠᚱ
  17. #157  
    Quote Originally Posted by woodmaster View Post
    no, ran make memload first...webOS needs to be running for it to work then?
    Sorry, wrong target... setup-extra runs on your host machine, and it really shouldn't be throwing those errors!!!

    delete your "extra" directory, if it exists, and try again.
    Or, create an "extra" directory if it isn't there, and do it again.
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  18.    #158  
    no luck, tried with both webOS running normal, and in memboot mode. got script from here: http://git.freesmartphone.org/?p=uti...setup-extra.sh
    Last edited by woodmaster; 05/19/2011 at 12:36 PM. Reason: bad link
    ᛖᚲ ᚹᛁᛏᚲᛁ ᚱᛁᛊᛏ ᚱᚢᚾᚠᚱ
  19. #159  
    Quote Originally Posted by woodmaster View Post
    no luck, tried with both webOS running normal, and in memboot mode. got script from here: http://git.freesmartphone.org/?p=uti...setup-extra.sh
    Edit the script, change:

    WEBOS_FILES="\
    lib/firmware/helper_sd.bin \
    lib/firmware/sd8686.bin \
    lib/firmware/mfg_sd8686.bin \
    lib/firmware/sd8686_ap.bin \
    lib/modules/2.6.24-palm-joplin-3430/kernel/net/wifi/uap8xxx.ko \
    lib/modules/2.6.24-palm-joplin-3430/kernel/net/wifi/sd8xxx.ko \
    etc/camd/smia_ed.cfg \
    etc/camd/vx6852-load-firmware \
    etc/camd/vx6852-once-0.00.bin \
    etc/camd/vx6852-once-0.10.bin \
    etc/camd/vx6852-once-1.20.bin \
    etc/camd/vx6852-once-2.21.bin \
    "

    for:
    WEBOS_FILES="lib/firmware/helper_sd.bin lib/firmware/sd8686.bin lib/firmware/mfg_sd8686.bin lib/firmware/sd8686_ap.bin lib/modules/2.6.24-palm-joplin-3430/kernel/net/wifi/uap8xxx.ko lib/modules/2.6.24-palm-joplin-3430/kernel/net/wifi/sd8xxx.ko etc/camd/smia_ed.cfg etc/camd/vx6852-load-firmware etc/camd/vx6852-once-0.00.bin etc/camd/vx6852-once-0.10.bin etc/camd/vx6852-once-1.20.bin etc/camd/vx6852-once-2.21.bin"

    You use cygwin?
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  20. #160  
    Quote Originally Posted by NuttyBunny View Post
    Edit the script, change:

    WEBOS_FILES="\
    lib/firmware/helper_sd.bin \
    lib/firmware/sd8686.bin \
    lib/firmware/mfg_sd8686.bin \
    lib/firmware/sd8686_ap.bin \
    lib/modules/2.6.24-palm-joplin-3430/kernel/net/wifi/uap8xxx.ko \
    lib/modules/2.6.24-palm-joplin-3430/kernel/net/wifi/sd8xxx.ko \
    etc/camd/smia_ed.cfg \
    etc/camd/vx6852-load-firmware \
    etc/camd/vx6852-once-0.00.bin \
    etc/camd/vx6852-once-0.10.bin \
    etc/camd/vx6852-once-1.20.bin \
    etc/camd/vx6852-once-2.21.bin \
    "

    for:
    WEBOS_FILES="lib/firmware/helper_sd.bin lib/firmware/sd8686.bin lib/firmware/mfg_sd8686.bin lib/firmware/sd8686_ap.bin lib/modules/2.6.24-palm-joplin-3430/kernel/net/wifi/uap8xxx.ko lib/modules/2.6.24-palm-joplin-3430/kernel/net/wifi/sd8xxx.ko etc/camd/smia_ed.cfg etc/camd/vx6852-load-firmware etc/camd/vx6852-once-0.00.bin etc/camd/vx6852-once-0.10.bin etc/camd/vx6852-once-1.20.bin etc/camd/vx6852-once-2.21.bin"

    You use cygwin?
    I tried this while in memload and it gave me this:

    Code:
    taylor@taylor-desktop:~/SHR$ make setup-extra
    Extract the webos doctor ...
    Copying all extra files to extra directory ...
    [: 21: lib/firmware/helper_sd.bin: unexpected operator
    [: 21: lib/firmware/sd8686.bin: unexpected operator
    [: 21: lib/firmware/mfg_sd8686.bin: unexpected operator
    [: 21: lib/firmware/sd8686_ap.bin: unexpected operator
    [: 21: lib/modules/2.6.24-palm-joplin-3430/kernel/net/wifi/uap8xxx.ko: unexpected operator
    [: 21: lib/modules/2.6.24-palm-joplin-3430/kernel/net/wifi/sd8xxx.ko: unexpected operator
    [: 21: etc/camd/smia_ed.cfg: unexpected operator
    [: 21: etc/camd/vx6852-load-firmware: unexpected operator
    [: 21: etc/camd/vx6852-once-0.00.bin: unexpected operator
    [: 21: etc/camd/vx6852-once-0.10.bin: unexpected operator
    [: 21: etc/camd/vx6852-once-1.20.bin: unexpected operator
    [: 21: etc/camd/vx6852-once-2.21.bin: unexpected operator
Page 8 of 9 FirstFirst ... 3456789 LastLast

Tags for this Thread

Posting Permissions