Page 7 of 9 FirstFirst ... 23456789 LastLast
Results 121 to 140 of 170
  1. #121  
    mine is installing now finally...... @nuttybunny your tip worked thank you!...however your tip was for a problem i wasnt having yet. when i first tried using thirteen my cygwin would tell me same thing(shr is -5 make webos smaller) i went into my make file and scrolled down to the first block for target-pre and changed the 7.5g to 13.0g and the 8.0g- line to 14.0g and for some reason that fixed it.... not to sure but i think it thought it was pre no matter what so i just changed its expectations of what a pre- should have?


    Code:
    ifeq (${TARGET},pre)
    NOVAINSTALLER = nova-installer-image-castle.uImage
    NOVA_IMAGE_NAME = nova-cust-image-castle.rootfs.tar.gz
    IMAGEFILENAME = full-palmpre.tar.gz
    KERNELFILENAME = uImage-palmpre.bin
    DOWNLOAD_BASE_URL = "${ORIGIN_URL}/palmpre"
    ifeq ($(shell expr '${CONFIG_WEBOS_MEDIA_TARGET_SIZE}' '<' '00.5G'),1)
    $(error CONFIG_WEBOS_MEDIA_TARGET_SIZE needs to be bigger than 00.5G)
    endif
    ifeq ($(shell expr '${CONFIG_WEBOS_MEDIA_TARGET_SIZE}' '>' '13.0g'),1)
    $(error $(shell echo |awk '{print 14.0 - ${CONFIG_WEBOS_MEDIA_TARGET_SIZE}}')G is left to FSO/SHR, It is too small .\
     You need to decrease CONFIG_WEBOS_MEDIA_TARGET_SIZE)
    endif
    endif
    for a fact i know i put preplus in the make file i have checked that over and over again. now... was what i did wrong?

    oh and by the way i think that its stuck on pre- due do the fact that 13.0g makes make file say "shr is -5' well 13-5 is 8 which is the size of the pre-!!!!

    update: installation seems sketchy with cygwin

    update 2: all goes fine until its time to talk to booty. Novaterm seems to disconect randomly through instalation causing terminal to freeze. I try reinstalling and its puts my phone in flash mode (which is normal)and hangs on a different spot everytime I reinstall.... Bunny maybe there is something VERY wrong with my terminal program... Cygwin seems fine just novaterm has issues
    Last edited by mannyfrehest; 05/12/2011 at 04:30 PM.
  2.    #122  
    I explained that 8 posts above Manny. It switches to pre after checking preplus is sized correctly since for all intents other than size of media, pre and preplus install method is the same. Had to do same. So you got it installed? Or no?
  3. #123  
    no I wanna update the novaterm cygwin uses and try again I'm having booty communication issues with installation
  4. #124  
    everything ok then, its tellin me this:



    Code:
    Creating backup/1c68b2af/media.tar.gz
    bin/tar: ./.palm/=2TIAWOOA=/=2RYBGK===/=2RMIHWJQ=/=2TIAWOJ7TKRVTTSDSKILA====/=2T
    APHUZPKKZTCB2RKEIOKZAEZUKGZMM2OH4======/=2REKGIJHPIVUSRCQ=/=2T4KEQL77/=2RACWKIXU
    KB4WHBQ4ZHTA====: File shrank by 21332 bytes; padding with zeros
    bin/tar: ./webos-patches.log: File shrank by 4634293 bytes; padding with zeros
    bin/tar: ./Messaging/1299396527153.photos-temp-0.jpg: Read error at byte 0, whil
    e reading 4608 bytes: Input/output error
    Total bytes written: 819896320 (782MiB, 2.7MiB/s)
    bin/tar: Error exit delayed from previous errors
    novacom: unexpected EOF from server
    then lvm resize works normall no errors but then...

    Code:
    Restoring your data to /media/internal ...
    mount: mounting /dev/mapper/store-media on /tmp/media failed: Device or resource
     busy
    novacom: unexpected EOF from server
    make: *** [restore-media] Error 255
    
    Jenny@Joey-PC ~
    #
    at least none of this messes my phone up, but i wish that it all would just work da first time....
    Attached Files Attached Files
  5.    #125  
    after the make backup exits, try shutting your device down, put into recovery mode by holding volume up button while plugging in usb to PC, then in terminal, memboot, then try to continue with make lvm-resize, make restore-media, etc..
    ᛖᚲ ᚹᛁᛏᚲᛁ ᚱᛁᛊᛏ ᚱᚢᚾᚠᚱ
  6. #126  
    I thought that an tried pickin up manual installation from restore media portion forward and no dice, same problem. should I try restore media steps from nova terminal(I seem to have 2 novaterms one works fine from my palm,inc folder and the one cygwin uses reports error after every keystroke and often freezes just trying to connect) and the go to flash kernel steps in cygwin? At this point I feel sorta ******** for not being able to install when nutty seemed to have no problem...
  7. #127  
    Ok, Mannyfrehest.... you seem to have a bad, very bad problem with your device.

    The lines:

    bin/tar: ./webos-patches.log: File shrank by 4634293 bytes; padding with zeros

    bin/tar: ./Messaging/1299396527153.photos-temp-0.jpg: Read error at byte 0, whil
    e reading 4608 bytes: Input/output error

    are NOT good at all, it seems to me that it encountered some error that left the media partition in a read-only state. Also I see that you used the "correct" way to boot into memload, so, the only idea I have is that you somehow unplugged your device while in usb mode, and it had errors, or that your device already have read error in the flash memory.

    This said, your backup file IS INCOMPLETE, and even if you try to restore it, you'll end with incomplete data.

    On the good side, it seems that your data didn't get erased, and the fso partition created correctly.

    On the bad side, the files .palm/=2TIAWOOA=/=2RYBGK===/=2RMIHWJQ==2TIAWOJ7TKRVTTSDSKILA====/=2T
    APHUZPKKZTCB2RKEIOKZAEZUKGZMM2OH4======/=2REKGIJHPIVUSRCQ=/=2T4KEQL77/=2RACWKIXU
    KB4WHBQ4ZHTA==== , webos-patches.log and Messaging/1299396527153.photos-temp-0.jpg are incomplete. That funny named file is an encrypted file, which goes inside /media/cryptofs, and ... well, we can't know what was its original name.

    You should boot webOS and see if you still can use your phone correctly. If you can, you may go with:
    make memboot flash-image flash-kernel install-bootr reboot

    (And hope it goes well).
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  8. #128  
    my device works fine but, I think my usb port on my phone must be broken sometimes when I plug in a charger it flashes repeatedly b4 actually charging. If its read-only shouldn't my device be completely incapable of saving data to media? Oh well I'll try flashin kernel and if not my device may be beat. I do run it into the ground so its kinda expected. I deleted the above error causing file it was a temp sms image. So just follow directions from flashin kernel forward or use commands:
    memboot flash-image
    flash-kernel
    install-bootr
    reboot
    Last edited by mannyfrehest; 05/13/2011 at 07:06 PM.
  9. #129  
    Quote Originally Posted by mannyfrehest View Post
    If its read-only shouldn't my device be completely incapable of saving data to media?
    On every reboot it checks for errors. On my Pre 2 it accounts for 30 seconds on every boot. o_O

    Quote Originally Posted by mannyfrehest View Post
    Oh well I'll try flashin kernel and if not my device may be beat. I do run it into the ground so its kinda expected. I deleted the above error causing file it was a temp sms image. So just follow directions from flashin kernel forward or use commands:
    memboot flash-image
    flash-kernel
    install-bootr
    reboot
    Yep. Do one at a time if you like



    -- Sent from my Palm Pre using Forums
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  10. #130  
    I know....I'm simple..... :'(
  11. #131  
    doctor deletes bootr that I installed for testing android? How would I find out?

    edit: never mind, read above post it explains all
    Last edited by mannyfrehest; 05/13/2011 at 10:30 PM.
  12.    #132  
    so Nuttybunny(or k3dar if he's still following), what can I look into to see why SHR just reboots on me instead of loading?
    ᛖᚲ ᚹᛁᛏᚲᛁ ᚱᛁᛊᛏ ᚱᚢᚾᚠᚱ
  13. #133  
    woodmaster: you have fso partition present ? try: lvdisplay /dev/store/fso
  14.    #134  
    not @ my linux PC atm but, yes lvdisplay shows fso present, around 6 GB allocated afaikafaikafaik
    ᛖᚲ ᚹᛁᛏᚲᛁ ᚱᛁᛊᛏ ᚱᚢᚾᚠᚱ
  15.    #135  
    Code:
    # lvdisplay /dev/store/fso
      --- Logical volume ---
      LV Name                /dev/store/fso
      VG Name                store
      LV UUID                Kgwwnv-fxsJ-v1aE-msQK-vqfJ-m3Gz-qHZKzn
      LV Write Access        read/write
      LV Status              available
      # open                 0
      LV Size                7.85 GB
      Current LE             1005
      Segments               2
      Allocation             inherit
      Read ahead sectors     auto
      - currently set to     256
      Block device           254:8
    ᛖᚲ ᚹᛁᛏᚲᛁ ᚱᛁᛊᛏ ᚱᚢᚾᚠᚱ
  16. #136  
    Quote Originally Posted by woodmaster View Post
    Code:
    # lvdisplay /dev/store/fso
      --- Logical volume ---
      LV Name                /dev/store/fso
      VG Name                store
      LV UUID                Kgwwnv-fxsJ-v1aE-msQK-vqfJ-m3Gz-qHZKzn
      LV Write Access        read/write
      LV Status              available
      # open                 0
      LV Size                7.85 GB
      Current LE             1005
      Segments               2
      Allocation             inherit
      Read ahead sectors     auto
      - currently set to     256
      Block device           254:8
    Have you tried reinstalling the kernel, and then the image?
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  17.    #137  
    how do I remove them? or do I just write over top?
    ᛖᚲ ᚹᛁᛏᚲᛁ ᚱᛁᛊᛏ ᚱᚢᚾᚠᚱ
  18. #138  
    Quote Originally Posted by woodmaster View Post
    how do I remove them? or do I just write over top?
    Over the top, if you use make flash-image and make flash-kernel it overwrites the old info

    -- Sent from my Palm Pre using Forums
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  19. #139  
    woodmaster: be sure you have downloaded latest Makefile
  20.    #140  
    will do and post back results.
    ᛖᚲ ᚹᛁᛏᚲᛁ ᚱᛁᛊᛏ ᚱᚢᚾᚠᚱ
Page 7 of 9 FirstFirst ... 23456789 LastLast

Tags for this Thread

Posting Permissions