Page 2 of 9 FirstFirst 1234567 ... LastLast
Results 21 to 40 of 170
  1. #21  
    Would it be possible to use the same process to run the Pandora OS on the Pre? The Pandora is open source and has a lot of nice games on it.

    http://openpandora.org/index.php?opt...mid=35&lang=en

    -- Sent from my Palm Pre using Forums
  2. #22  
    Quote Originally Posted by Dragone View Post
    This could be really interesting ....

    But as long as the procedure needs linux os I think I'll just pass
    All webOS devices RUN Linux

    -- Sent from my Palm Pre using Forums
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  3. #23  
    Quote Originally Posted by Dragone View Post
    This could be really interesting ....

    But as long as the procedure needs linux os I think I'll just pass
    Do you already have the Emulator from Palm installed?
    If so, then all you need is 1 file to have a Linux OS running on your desktop
    webOSroundup and Project Macaw contributor
    Remember, if I helped you, please click on the little or ♥ to the right
  4. Dragone's Avatar
    Posts
    60 Posts
    Global Posts
    226 Global Posts
    #24  
    Quote Originally Posted by NuttyBunny View Post
    All webOS devices RUN Linux

    -- Sent from my Palm Pre using Forums
    The procedure needs a Linux OS on the desktop, not on the WebOs device.
    And coz every WebOs is linux, my statement could only refer to the desktop world.
    Last edited by Dragone; 04/30/2011 at 04:47 AM.
  5. Dragone's Avatar
    Posts
    60 Posts
    Global Posts
    226 Global Posts
    #25  
    Quote Originally Posted by patrickc View Post
    Do you already have the Emulator from Palm installed?
    If so, then all you need is 1 file to have a Linux OS running on your desktop
    No, I don't have the Emulator, and anyway I think that an emulated Linux could require variations from the original installation procedure (mapping the usb device to the virtual machine, installing the novacom drivers on the virtual machine etc etc).

    Btw I could be in error, as far as I remember the Palm Emulator is a virtual machine for VirtualBox ...
  6. #26  
    Quote Originally Posted by Dragone View Post
    No, I don't have the Emulator, and anyway I think that an emulated Linux could require variations from the original installation procedure (mapping the usb device to the virtual machine, installing the novacom drivers on the virtual machine etc etc).

    Btw I could be in error, as far as I remember the Palm Emulator is a virtual machine for VirtualBox ...
    You dont need to map any USB devices or install Novacom. You just need Linux to make the doctor, then transfer the doctor to the hose computer via a USB stick or an online storage service (like Dropbox or adrive)
    I can help you get it set up and transferred if needed
  7. #27  
    Quote Originally Posted by patrickc View Post
    You dont need to map any USB devices or install Novacom. You just need Linux to make the doctor, then transfer the doctor to the hose computer via a USB stick or an online storage service (like Dropbox or adrive)
    I can help you get it set up and transferred if needed
    I think you're talking about something else

    The Makefile runs on Linux (perhaps Cygwin but if someone uses it I'll start slapping people). It backs up partitions, resizes partitions, creates the fso one (for SHR), restores the media partition (maybe the error happened here), and installs bootr and the alternate kernel.

    What is not clear is the size needed for the fso partition, I'd go for 1Gb, so, I'd have 1.5Gb free on /media/internal before trying this.

    This is NOT a MetaDoctor, so its restrictions don't apply here.

    You DO need to install novacom and jar (or unzip).

    I'm researching on how to use the same approach as used on Android to make a triple-boot device with no partition resizing, so it would be safer. But NOT today, it's my sister's wedding

    -- Sent from my Palm Pre using Forums
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  8. Dragone's Avatar
    Posts
    60 Posts
    Global Posts
    226 Global Posts
    #28  
    Rebooting your device in recovery mode...
    Done!
    Extracting webos doctor ...
    Transfer nova installer to device and reboot your device with it ...

    ****

    Waiting for this to finish ... I wonder how much time will this operation take ....

    EDIT : Ok, I managed to have it going forward ... Virtual Linux makes things harder as i said.
  9. #29  
    Quote Originally Posted by rsanchez1 View Post
    Would it be possible to use the same process to run the Pandora OS on the Pre?
    ...
    What "same process" you think?
    SHR have already kernel, rootfs, installation prepared for Pre(+/2)

    Quote Originally Posted by NuttyBunny View Post
    ...
    I'm researching on how to use the same approach as used on Android to make a triple-boot device with no partition resizing, so it would be safer.
    ...
    Research not need
    Last edited by k3dar; 04/30/2011 at 09:13 AM.
  10. #30  
    Quote Originally Posted by woodmaster View Post
    ...
    edit:and also replace second ".PHONY: wget-kernel" to ".PHONY: wget-image"
    I don't quite understand why you want me to do this. The makefile is wrong then?
    Yes, in Makefile this is 2x, then second line replace, without is not downloaded rootfs. Anyway this is not problem of your nonbootable Pre.
  11. #31  
    um so I already have cygwin installed from when I upgraded webos, and um I don't wanna get slapped so is it or is it not ok to install shr using cygwin? Also ...... Could auto scripts like the ones for android be made for this... It would be awesome to be able to do this in novaterm or even sdl terminal from my device!!!
  12. #32  
    Quote Originally Posted by mannyfrehest View Post
    um so I already have cygwin installed from when I upgraded webos, and um I don't wanna get slapped so is it or is it not ok to install shr using cygwin? Also ...... Could auto scripts like the ones for android be made for this... It would be awesome to be able to do this in novaterm or even sdl terminal from my device!!!
    I was just kidding, I think cygwin is safe in this case as we are not uncompressing anything that could mess up the installation

    -- Sent from my Palm Pre using Forums
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  13. Dragone's Avatar
    Posts
    60 Posts
    Global Posts
    226 Global Posts
    #33  
    I dunno how , but the procedure screwed my phone, and now every time i try to boot i see an "!" and "ROM NOT FOUND" or something similar ...

    WebOs Doctor stucks at 12% ... and can't recover my phone

    Did i lose my device ?
    Novacom commands in the bash still work from recover mode ...
    Can i try something to fix this ?

    Please help me
  14. #34  
    Quote Originally Posted by Dragone View Post
    I dunno how , but the procedure screwed my phone, and now every time i try to boot i see an "!" and "ROM NOT FOUND" or something similar ...

    WebOs Doctor stucks at 12% ... and can't recover my phone

    Did i lose my device ?
    Novacom commands still works from recover mode ...

    Please help me
    have you logged the doctor to see why it's failing?
  15. #35  
    Quote Originally Posted by Dragone View Post
    I dunno how , but the procedure screwed my phone, and now every time i try to boot i see an "!" and "ROM NOT FOUND" or something similar ...

    WebOs Doctor stucks at 12% ... and can't recover my phone

    Did i lose my device ?
    Novacom commands in the bash still work from recover mode ...
    Can i try something to fix this ?

    Please help me
    Really??? "Or something similar"??

    Seriously people, stop messing around with your phones if you don't know what you're doing.
  16. #36  
    Quote Originally Posted by NuttyBunny View Post
    Really??? "Or something similar"??

    Seriously people, stop messing around with your phones if you don't know what you're doing.
    +1
    If you don't know what your doing, don't do it. you can really mess up your phone. I am waiting on putting SHR on my phone, till I know it's easy, and no chance of hurting my phone. I do know, however, how to fix my phone if I do break it. and if my doctor doesn't finish running, I know to log the doctor, and go to someone who does know.
    If for some reason your doctor does fail, please provide a log so we can help you. We can't help you if you just say "The doctor failed..."
    webOSroundup and Project Macaw contributor
    Remember, if I helped you, please click on the little or ♥ to the right
  17. Dragone's Avatar
    Posts
    60 Posts
    Global Posts
    226 Global Posts
    #37  
    There are the logs on when it starts on hanging on 12%

    Thx for you help
    Attached Files Attached Files
  18. Dragone's Avatar
    Posts
    60 Posts
    Global Posts
    226 Global Posts
    #38  
    I was just following the procedure.
    After i restored the "media" backup with the command "make restore-media" I found myself in this situation

    EDIT :

    BTW I have these following files in my backup folder (created by SHR installation) :

    boot.tar.gz
    media.tar.gz
    mmcblk0p1.bak
    rootfs.tar.gz
    varfs.tar.gz

    I think something went wrong during the "make restore-media" step, i am repeating the procedure, hoping to restore the situation.

    Btw i noticed in the shr Makefile that "make restore-media" try to restore only media.tar.gz ...
    How can i restore the other files too ?
    Last edited by Dragone; 05/01/2011 at 05:43 PM.
  19. #39  
    Quote Originally Posted by Dragone View Post
    I was just following the procedure.
    After i restored the "media" backup with the command "make restore-media" I found myself in this situation
    How much space were you using for the fso partition?

    Could that be that you left too few space for your media space and it couldn't restore the backup?

    After reading the script I'd recommend manually backing up your media files and deleting from there before playing with this

    -- Sent from my Palm Pre using Forums
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  20. Dragone's Avatar
    Posts
    60 Posts
    Global Posts
    226 Global Posts
    #40  
    I wrote 15.5G in the makefile option, and this should mean I gave maximum space to WEBOS ... I am wrong ?? "CONFIG_WEBOS_MEDIA_TARGET_SIZE" is "the size you want to let on your media partition of WebOS"

    Btw I have all the SHR backups in safe locations (on my desktop), I won't lose them. That's not the problem.

    Now I am trying to restore again by that command.

    If I restore correctly the media.tar.gz do you think the WebOs Doctor is going to work again ? Do you see any hope ?
Page 2 of 9 FirstFirst 1234567 ... LastLast

Tags for this Thread

Posting Permissions