webOS Nation Forums >  webOS Discussion >  Open webOS General Discussion > Impressions of latest open webOS (ports) builds
Impressions of latest open webOS (ports) builds
  Reply
Like Tree69Likes

 
Thread Tools Display Modes
Old 10/19/2013, 12:51 PM   #1 (permalink)
Member
 
MudShark22's Avatar
 
Posts: 1,028
As I now install open webOS (ports) builds using an old Linux Mint 10 box; I decided to retire the other windows based thread (though the info is still generally good and usable).

First of all:
- All rules, warnings, prophecies found at Testing Gnex - WebOS-Ports are in full effect and should be heeded.
- I will not post direct links to the 'latest' images found on the staging feeds. Smart people perusing the webos-ports wiki will find the links there. I have already provided all the clues needed.
- I encourage others to d/l, install and share their experiences, issues, appreciation over these builds in this thread as well.

EDIT:
As of 13JUN2014, I have successfully installed latest zips via CWM, no sideload needed.

Onwards!

- T
__________________
This space for rent or lease. Inquire within.

Last edited by MudShark22; 06/13/2014 at 09:16 PM. Reason: Update my install method
MudShark22 is offline   Reply With Quote
Liked by RumoredNow likes this.
Thanked by PalmLives, RumoredNow
Old 10/19/2013, 01:31 PM   #2 (permalink)
Member
 
MudShark22's Avatar
 
Posts: 1,028
Build Installed: 18 October 2013

Remember: These are thoughts / observations; not criticisms, especially since I could never do all this myself! :-)

- First attempt at booting resulted in a bootloop at the Google opening screen necessitating a battery pull. DOH!

- re-pushed the image to the Gnex, rebooted to bootloader, fastbooted the kernel and voila!

Thoughts / observations:
- Fonts across top bar are not scaled correctly; date is correct
- gesture area is below launcher bar as expected
- Just type pill is there; but tapping it brings up app drawer
- launcher bar at bottom has four 'apps' using the standard "luna" image plus the classic app drawer arrow
- Bringing up the app drawer reveals a number of apps/services included:
Row 1: Memos, Snowshoe, Accounts, Testr, GMail, Contacts
Row 2: Calendar, Preware2, First Use, Wikipedia, Settings, Email
Row 3: Calendar (again?), Tweaks, Twitter, Clock, Phone, Calculator
- Given the size of the icons and text; there is enough space for at least 6 more rows it appears.

- Opened settings; has three sub categories: connectivity, services, and Core
- Connectivity has Wifi and Telephony. Turning on the WiFi switch to "on" brings up a choose network menu but does not appear to work as of yet (i.e. no connectivity possible); buttons for scanning for networks are not scaled correctly and do not appear to function. Swiping back on gesture area to attempt to return to top menu does not appear to work either. Swipe up in gesture area DOES minimize to card-size and flick/drag upwards to close does work as well.
- Once card was swiped away, cannot access launcher again. I noticed this with prior builds and it may just be a system delay due to resource constraints, similar to a buffering scenario (i.e. remember the commands and then executing later when resource available)

So that's it for now.... using adb to reboot back to CM10.1.3.
Will reboot this build again and try some different apps / services thought without WiFi, opening preware2 or gmail wont be too exciting :-)

Onwards!
__________________
This space for rent or lease. Inquire within.
MudShark22 is offline   Reply With Quote
Liked by Alan Morford, Pilotovef, renater and 3 others like this.
Old 10/19/2013, 01:42 PM   #3 (permalink)
Member
 
Posts: 3,797
wow great, thanks for letting us know where this stands
bluenote is offline   Reply With Quote
Old 10/20/2013, 11:01 AM   #4 (permalink)
pivotCE Developer
 
RumoredNow's Avatar
 
Posts: 2,231
I don't know what the issue is, but I have the hardest time downloading from that repository. I've had half a dozen fails in a row. I've been using Chrome. I know my WiFi isn't the fastest/best...

I'm trying again for the 18 October build, but I'm trying the DL in FireFox.
__________________
Lumia 1520.3 (the Beastly Unicorn): Windows 10 Mobile

Windows Central Senior Ambassador

Mobile Nations Devotee
RumoredNow is offline   Reply With Quote
Old 10/20/2013, 12:59 PM   #5 (permalink)
pivotCE Developer
 
RumoredNow's Avatar
 
Posts: 2,231
Nope... It's not the browser. It must be my BPL connection.
__________________
Lumia 1520.3 (the Beastly Unicorn): Windows 10 Mobile

Windows Central Senior Ambassador

Mobile Nations Devotee
RumoredNow is offline   Reply With Quote
Old 10/20/2013, 02:25 PM   #6 (permalink)
Member
 
MudShark22's Avatar
 
Posts: 1,028
When I d/l, it does take 5-7 minutes and that's with solid broadband
__________________
This space for rent or lease. Inquire within.
MudShark22 is offline   Reply With Quote
Old 10/20/2013, 03:40 PM   #7 (permalink)
Homebrew Developer
 
Posts: 870
Quote:
Originally Posted by MudShark22 View Post
- Once card was swiped away, cannot access launcher again. I noticed this with prior builds and it may just be a system delay due to resource constraints, similar to a buffering scenario (i.e. remember the commands and then executing later when resource available)
I see that in emulator all the time (did not find time to push the image to my gnex, yet). When you keep clicking onto the launcher-button luna-next usually restarts and responds again... of course it will also take all open apps with you.

Are you able to scroll in either Wikipedia or G-Mail?

Are your taps registered at the same position? Or is it off to the lower right?

There is quite a lot of progress. But still a way to go.
Garfonso is offline   Reply With Quote
Thanked By: MudShark22
Old 10/20/2013, 05:08 PM   #8 (permalink)
Member
 
MudShark22's Avatar
 
Posts: 1,028
I will reboot into the 18 Oct build tomorrow and try other stuff...
__________________
This space for rent or lease. Inquire within.
MudShark22 is offline   Reply With Quote
Old 10/23/2013, 11:58 AM   #9 (permalink)
Member
 
MudShark22's Avatar
 
Posts: 1,028
I see that there is a 21 Oct build, already d/l the image, will try to find time to push to GNex.
__________________
This space for rent or lease. Inquire within.
MudShark22 is offline   Reply With Quote
Old 10/23/2013, 01:35 PM   #10 (permalink)
Rnp
Member
 
Rnp's Avatar
 
Posts: 1,351
Hummm... Maybe I can buy a old GNex just for try this...


Best Regards...
__________________
"If A Man Isn't Willing To Take Some Risk For His Opinions, Either His Opinions Are No Good Or He's No Good!" - Ezra Pound (Poet & Critic)
(Happy A Lot, As A Good Carioca!)
Rnp is offline   Reply With Quote
Old 10/24/2013, 12:05 PM   #11 (permalink)
Member
 
MudShark22's Avatar
 
Posts: 1,028
Build installed 21 OCT 2013

1st attempt - booted into build, scaling is bang on...cannot register any finger input; as such, no launcher opening, app opening etc. Will boot 2nd time.

2nd attempt - whoohoo! finger input registered!! Trying settings app...started to freeze, was able to minimize to card, and swipe up/away. However, now app drawer will not come up, seems similar to 18OCT build in that regard. Will adb reboot and try 3rd time and different app.

3rd attempt - booted fine, finger input, open / close app drawer multiple times. Since wifi does not appear to be working (from 2nd attempt), opening memos app....opened fast!, however no keyboard opened for typing a memo, minimize memo app but dont swipe away; open Tweaks but appears as a blank card, no menus etc., minimize to card size; tap just type...works! No keyboard as with memos; opening contacts app looks like normal, asks to get started with your HP webOS account :-).....just crashed / force closed when swiping away contacts card, all open cards disappeared.

That's all the time I had for now; see if a new build arrives soon...

Onwards!
__________________
This space for rent or lease. Inquire within.
MudShark22 is offline   Reply With Quote
Thanked By: Rnp
Old 10/24/2013, 04:05 PM   #12 (permalink)
Member
 
kryptonite_2448's Avatar
 
Posts: 73
Quote:
Originally Posted by MudShark22 View Post
Build installed 21 OCT 2013

1st attempt - booted into build, scaling is bang on...cannot register any finger input; as such, no launcher opening, app opening etc. Will boot 2nd time.

2nd attempt - whoohoo! finger input registered!! Trying settings app...started to freeze, was able to minimize to card, and swipe up/away. However, now app drawer will not come up, seems similar to 18OCT build in that regard. Will adb reboot and try 3rd time and different app.

3rd attempt - booted fine, finger input, open / close app drawer multiple times. Since wifi does not appear to be working (from 2nd attempt), opening memos app....opened fast!, however no keyboard opened for typing a memo, minimize memo app but dont swipe away; open Tweaks but appears as a blank card, no menus etc., minimize to card size; tap just type...works! No keyboard as with memos; opening contacts app looks like normal, asks to get started with your HP webOS account :-).....just crashed / force closed when swiping away contacts card, all open cards disappeared.

That's all the time I had for now; see if a new build arrives soon...

Onwards!
I appreciate the updates!
__________________
Current: OnePlus One, Nexus 10
Retired: Palm Centro, Palm Pre+, HP Veer, HP TouchPad, Samsung Galaxy SIII, Moto X (2013), Nexus 7 (2012)

"It is better to keep your mouth shut and appear stupid than to open it and remove all doubt." - Mark Twain
kryptonite_2448 is offline   Reply With Quote
Old 10/24/2013, 07:52 PM   #13 (permalink)
Member
 
Posts: 110
Is GMail a standalone app or a browser shortcut?
trwrt is offline   Reply With Quote
Old 10/24/2013, 09:28 PM   #14 (permalink)
Member
 
MudShark22's Avatar
 
Posts: 1,028
Didn't open gmail as WiFi couldn't be set up. Will try and check
__________________
This space for rent or lease. Inquire within.
MudShark22 is offline   Reply With Quote
Liked by Rnp likes this.
Old 10/24/2013, 09:30 PM   #15 (permalink)
Member
 
MudShark22's Avatar
 
Posts: 1,028
Quote:
Originally Posted by Garfonso View Post
I see that in emulator all the time (did not find time to push the image to my gnex, yet). When you keep clicking onto the launcher-button luna-next usually restarts and responds again... of course it will also take all open apps with you.

Are you able to scroll in either Wikipedia or G-Mail?

Are your taps registered at the same position? Or is it off to the lower right?

There is quite a lot of progress. But still a way to go.
Didn't bother with Wikipedia or GMail as I can't get WiFi to work, but I can try anyway
__________________
This space for rent or lease. Inquire within.
MudShark22 is offline   Reply With Quote
Old 10/24/2013, 09:33 PM   #16 (permalink)
Member
 
Posts: 288
Quote:
Originally Posted by trwrt View Post
Is GMail a standalone app or a browser shortcut?

I doubt Gmail is working as a new application.

Remember that Openwebos was mostly ported from WebOS, so it's logical to assume the email application was also ported minus the connectors to email and 3rd party APIs. Until those connects are 'build' or integrated from say Android? -into synergy the way Webos does synergy-email -contacts will not be in place.

I'd also say that is the least of the issues - progress is there and I'm sure the guys working on it are doing something but with limited resources , they prioritize to the core requirements.
a. phone functionality
b. wifi.
c. stabilize drivers
d. connectors for synergy.
daexpression is offline   Reply With Quote
Liked by Rnp likes this.
Thanked by Gwidion, Rnp
Old 10/25/2013, 03:19 AM   #17 (permalink)
Homebrew Developer

 
Posts: 2,961
It are all browser shortcuts for now. Standard email app can work as well of course for Gmail

-- Sent from my TouchPad using Communities
__________________
HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
Herrie is offline   Reply With Quote
Liked by Rnp likes this.
Thanked by kryptonite_2448, Rnp
Old 10/26/2013, 03:28 AM   #18 (permalink)
Member
 
Posts: 6
Quote:
Originally Posted by daexpression View Post
I doubt Gmail is working as a new application.

Remember that Openwebos was mostly ported from WebOS, so it's logical to assume the email application was also ported minus the connectors to email and 3rd party APIs. Until those connects are 'build' or integrated from say Android? -into synergy the way Webos does synergy-email -contacts will not be in place.
We've ongoing work to create a synergy connector for carddav/caldav (https://github.com/webOS-ports/org.w...ntacts.carddav) which gives you together with the already existing connectors for IMAP/SMTP full access to gmail. All of this will appear in a new release soon.
morphis#WN is offline   Reply With Quote
Liked by Grabber5.0, bigdoby, Preemptive and 1 others like this.
Old 10/30/2013, 01:33 PM   #19 (permalink)
Member
 
MudShark22's Avatar
 
Posts: 1,028
Thanks morphis....look forward to the next image and the upcoming alpha3.

- T
__________________
This space for rent or lease. Inquire within.
MudShark22 is offline   Reply With Quote
Old 11/07/2013, 06:25 PM   #20 (permalink)
Member
 
MudShark22's Avatar
 
Posts: 1,028
I see there is a 04 NOV image.
Gonna try it soon and report back
__________________
This space for rent or lease. Inquire within.
MudShark22 is offline   Reply With Quote
Thanked by Grabber5.0, Preemptive
Reply

 

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I open network ports in webOS? bethel95 webOS Discussion Lounge 8 07/06/2013 11:33 PM
How to open network ports in webOS? bethel95 webOS Discussion Lounge 2 07/06/2013 07:34 PM
freeTether Open Ports? DWarrior WebOS Internals 0 08/06/2011 07:17 AM
T-Zones open Ports? dantekgeek North American Carriers (GSM) 2 09/12/2004 01:00 PM
Scanning for open ports?? slvr00gt Palm OS Devices & Apps 0 05/19/2004 11:58 PM


 


Content Relevant URLs by vBSEO 3.6.0