webOS Nation Forums >  webOS Discussion >  Open webOS General Discussion > Build problems
Build problems
  Reply
 
Thread Tools Display Modes
Old 01/09/2013, 04:27 PM   #1 (permalink)
Junior Member
 
Posts: 1
while buiding webos i am getting following errors. This is quite unusual as i am following general guidelines given at https://github.com/openwebos/build-w...ster/README.md

I was not able to checkout some of the modules by default and i have do it manually but i think it should not matter.


machine:~/work/source/openwebos/build-webos$ sudo make webos
cd BUILD-qemux86 && time make CONTINUOUS_BUILD_MARK= BBFLAGS='' webos # component webos for qemux86
make[1]: Entering directory `/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86'
unset LC_ALL; export LC_ALL; LANG=en_US.UTF-8 PATH=/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././openembedded-core/scripts:/home/gaurav/work/source/openwebos/build-webos/bitbake/bin:$PATH BUILDDIR=/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86 /home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././openembedded-core/scripts/bitbake webos
Pseudo is not present but is required, building this first before the main build
ERROR: ExpansionError during parsing /home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././meta-webos/recipes-upstreamable/ptmalloc3/ptmalloc3.bb: Failure expanding variable MACHINE_ARCH, expression was ${@[d.getVar('TUNE_PKGARCH', True), d.getVar('MACHINE', True)][bool(d.getVar('MACHINE', True))].replace('-', '_')} which triggered exception AttributeError: 'NoneType' object has no attribute 'replace'
ERROR: No recipes available for:
/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././meta-webos/recipes-support/sqlite/sqlite3_3.7.13.bbappend
/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././meta-webos/recipes-connectivity/dhcp/dhcp_4.2.3-P2.bbappend
/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././meta-webos/recipes-extended/bzip2/bzip2_1.0.6.bbappend
/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././meta-webos/recipes-support/genext2fs/genext2fs_1.4.1.bbappend
/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././meta-webos/recipes-extended/gzip/gzip_1.5.bbappend
/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././meta-webos/recipes-core/busybox/busybox_1.19.4.bbappend
/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././meta-webos/recipes-extended/bash/bash_4.2.bbappend
/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././meta-webos/recipes-bsp/v86d/v86d_0.1.10.bbappend
/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././meta-webos/recipes-support/e2fsprogs/e2fsprogs_1.42.1.bbappend
/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././meta-webos/recipes-support/curl/curl_7.26.0.bbappend
/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././meta-webos/recipes-support/lvm2/lvm2_2.02.85.bbappend
/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././meta-webos/recipes-support/libgcrypt/libgcrypt_1.5.0.bbappend
/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././meta-webos/recipes-connectivity/iproute2/iproute2_3.2.0.bbappend
/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././meta-webos/recipes-core/mm-common/mm-common_0.9.5.bbappend
/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86/.././meta-webos/recipes-extended/psmisc/psmisc_22.19.bbappend
ERROR: Command execution failed: Exited with 1

Summary: There were 3 ERROR messages shown, returning a non-zero exit code.
make[1]: *** [webos] Error 1
make[1]: Leaving directory `/home/gaurav/work/source/openwebos/build-webos/BUILD-qemux86'

real 0m3.621s
user 0m1.408s
sys 0m0.184s
make: *** [qemux86/webos] Error 2
Gaurav Jain1 is offline   Reply With Quote
Old 01/22/2013, 11:23 AM   #2 (permalink)
Member
 
Posts: 2
No idea what's going on...
kussface1 is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0