webOS Nation Forums >  webOS Discussion >  Open webOS General Discussion > problem in snap scroller in enyo
problem in snap scroller in enyo
  Reply
 
Thread Tools Display Modes
Old 06/14/2012, 10:26 PM   #1 (permalink)
Member
 
Posts: 4
i have 2 scroller in snap scroller.
when i add content in 2 sroller ,then it take size of maximum content scroller.
and therefore the other scroller is not properly shown it goes to bottom and maximum size scroller come at top.

I want to show then in same level

I have attach the image of both scroller.chek it out.
Attached Images
File Type: bmp slide.bmp (132.0 KB, 9 views) Email Attachment
palak patel is offline   Reply With Quote
Old 06/14/2012, 11:27 PM   #2 (permalink)
Member
 
Jake_M's Avatar
 
Posts: 1,473
I can't really discern what you're trying to say but I saw "same level" and so I'm assuming you're gonna wanna try to use
Quote:
align:"center"
on the parent element of those 2 scrollers
__________________
Quote:
Originally Posted by rwhitby View Post
We always prefer that people donate in response to tangible items they can use today, rather than for intangible promises about the future that may or may not be possible to achieve.
Jake_M is offline   Reply With Quote
Old 06/15/2012, 12:22 AM   #3 (permalink)
Member
 
Posts: 4
Quote:
Originally Posted by Jakeeeee View Post
I can't really discern what you're trying to say but I saw "same level" and so I'm assuming you're gonna wanna try to use on the parent element of those 2 scrollers
Actually align:center is also not working.

i want to show both slider on top.

the maximum size slider is properly on top.
but the 1st is goes down.
palak patel is offline   Reply With Quote
Old 06/22/2012, 02:36 AM   #4 (permalink)
Member
 
Posts: 4
I have nested snap scroller.
I want vertical scroller if content is overflow.
so i can see the content which is goes out of screen size.

Currently i have code which shows the vertical snapping but it is not stop in middle .

give me the solution of above problem.
palak patel is offline   Reply With Quote
Old 07/02/2012, 05:49 AM   #5 (permalink)
Member
 
Posts: 4
Not return respone while accesing webservice in enyo


While accessing webservice ,request goes to server but it didn't show the response .
gottext method returns undefine.
Here i have attach the code.

enyo.kind({
name: "LoginWebservice",
kind: enyo.Components,
components:
[

{name: "WebService1",
kind: "Classic.WebService",
onSuccess: "gottext",
onFailure: "gettextfail",
published: { method: "GET", handleAs: "text", headers: null, contentType: "application/x-www-form-urlencoded" } },
],

create: function ()
{
try{
this.inherited(arguments);
var logURL = "http://localhost:4863/Service1.asmx?op=HelloWorld";
this.$.WebService1.setUrl(logURL);
this.$.WebService1.call();
}catch(err){alert(err);}

},

gottext: function(inSender, inResponse) {
alert(inResponse.HelloWorldResult);
},

gettextfail: function(inSender, inResponse){
},
});

new LoginWebservice().write();
palak patel is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0