Results 1 to 9 of 9
  1.    #1  
    Before upgrading to Windows XP I installed a new 7200RPM hard drive...a noticable improvement over my previous 5400RPM unit. While XP installed without a single incident, it did christen my hard drive as e: instead of c:, which gets annoying.

    I don't recall ever being given the option to establish my primary hard drive as c:, d:, or e:, it seems to have happened with everything set on "autopilot".

    Is there a way to reassign the actual drive letters (as opposed to just the drive reference name) so that my primary hard drive is once again c:?
  2. #2  
    Are you using multiple hard drives? By default, the first HD with a valid MBR is set as the C: drive. Typically, a second drive will be assigned E: (leaving D: for a CD drive). I've never heard of a case where anything higher was assigned except when multiple drives are involved.

    If you do in fact have 2 HD's, the one assigned as E: is probably not your primary drive. If you only have a single HD, I'm stumped as to why it would be E:.
    .
    .....
    MarkEagle
    .....<a href="http://discussion.treocentral.com/tcforum/index.php?s=">TreoCentral</a> | <a href="http://discussion.visorcentral.com/vcforum/index.php?s=">VisorCentral</a> Forum Moderator - Forum Guidelines
    .....Sprint PCS Treo 650
    .....God bless America, my home sweet home...
  3. #3  
    Ahh, but the Windows 2000 kernal lets you make your drives whatever letter you want Just how....

    XP runs off a version of 2k of course, thats where the stability comes from. I don't know though if they inluded this utility. IN my version of 2k, its' in start->Administrative tools->Computer Management->Disk Management.

    In XP this might be a control panel - I don't know. In 98 it isn't possible though... Win2k is VERY powerful
    -Michael Ducker
    TreoCentral Staff
  4. #4  
    Well, I just installed another hard drive (32GB more space, woo!), and it moved everything over a letter rather than being named the last one. A: and C: stayed, but D: became E:, E: became F:, (If you're wondering, my E: is my Smartmedia adaptor), and the new HD became D:. Get all that?
  5. #5  
    Well I went to CompUSA today and looked at XP.

    Goto control-Panels ->
    Administrative Tools ->
    Comptuer Management ->
    Diskl Management ->
    Right click change drive letter.

    Ca-va?
    -Michael Ducker
    TreoCentral Staff
  6. #6  
    The only problem with Miradu's solution is that XP will not let you change the drive letter of the system or boot volume. (This is partly because of all the registry hooks that tie to the drive letter of your system and/or boot drives.) I've seen this happen before with beta versions of XP. I can't remeber how we fixed it, but I'll try and track down the individual who ran into the problem and try to find out.
    Sven

    If at first you do succeed, try not to look astonished.
  7. #7  
    Here is what I found. We had a tester that ran into this same problem when he installed Windows XP onto a new drive (master) with a separate data drive (slave) that was already formatted and contained files. When XP installed it partitioned and formatted the new drive, and then assigned it to E:, assigning the data drive to C:. He fixed the problem by disconnecting the data drive (so there was only one harddrive connected) and reinstalling XP from scratch. I have no idea why XP installs this way, especially when this problem doesn't occur with Windows 2000. Really stupid setup. I haven't been able to find a better answer/solution yet, but I'll keep looking. I hope this helps.
    Sven

    If at first you do succeed, try not to look astonished.
  8. #8  
    I found a few links at Microsoft's site that might be a little less painful. To change the drive letter of the system drive on XP try this.

    A more thorough description of what Miradu mentioned (good for changing the drive letter of non-system or non-boot drives) is described here.

    As always, no warranty is implied, and your results may vary.
    Sven

    If at first you do succeed, try not to look astonished.
  9.    #9  
    Thanks for the link to the tech page....it seems to address the issue. I may give it a try this weekend...I am not eager to do a full backup and risk a reinstall after having just done one last weekend. We will see how brave I am!

Posting Permissions