webOS Nation Forums >  Carrier Discussion >  North American Carriers (GSM) > DUN logon parameters for AT&T?
DUN logon parameters for AT&T?
  Reply
 
Thread Tools Display Modes
Old 02/16/2005, 03:51 PM   #1 (permalink)
Member
 
Posts: 94
I've finally gotten Shadowmite's DUN patch working on my 650 - credit goes to several other users who have posted methods allowing me to get past the problems that I was having a week ago.

Shadowmite's site offers logon parameters for Verizon, Sprint, and Cingular Orange, but not for Cingular Blue (ATTWS). When I've done this same connection using my Nokia phone, it's been pretty simple - just dial *99# and leave the userid and password blank. But that doesn't seem to work with DUN on the Treo.

Does anyone have DUN working with the AT&T network? If so, what parameters are you using to make the connection?
Gilliland is offline   Reply With Quote
Old 02/16/2005, 03:58 PM   #2 (permalink)
Member
 
Posts: 23
I'd love to know too. I wasn't able to get the Treo to connect to Cingular using the Cingular Treo 650 and Shadowmite's patch.

Now I have the unlocked GSM 650, and still can't connect to AT&T, Cingular or T-Mobile using their respective SIMs. *sigh* Generally, I can get every phone on the planet working for BT DUN-- even the tough ones like the Moto MPx220.

Anyone who has DUN working on GSM, can tell us if you've had to do anything special such as init strings? The standard init string listed in palmOne's GSM DUN pdf for the 650 haven't done the trick.

Giliand, you probably know this already: for AT&T you can usually leave the APN blank. However, if you do need to enter one, it's proxy (just the word proxy and nothing else). AT&T doesn't use a login name or password, and like all providers, they use DHCP for IP and DNS.
__________________
Lisa G.
Editor in Chief
www.MobileTechReview.com
pdagal is offline   Reply With Quote
Old 02/16/2005, 04:36 PM   #3 (permalink)
Member
 
Posts: 8
I've gotten Bluetooth DUN working with AT&T and Shadowmite's patch.

Here are the pertinent settings:
Phone #: *99***1#
Username: <blank>
Password: <blank>

And this was the trickier part:
I had to go to the "Standard Modem over Bluetooth link" modem in Control Panel->Phone and Modem Options.

Under the Advanced tab, I added:AT+CGDCONT=1, "ip", "proxy"

(replace proxy with appropriate APN if not AT&T) to "Extra initialization commands:"

At first I was able to dial in and connect to the phone, but when it was registering to the network it would give an error about PPP. Adding this line to the extra initialization commands made everything work great. I get about 80-90kbps and anywhere from 1.2 - 3.5sec latency -- which btw is higher than what I get with the trial version of PDAnet.
RecklessOne is offline   Reply With Quote
Old 02/16/2005, 05:27 PM   #4 (permalink)
Member
 
Posts: 94
Quote:
Originally Posted by pdagal
Giliand, you probably know this already: for AT&T you can usually leave the APN blank. However, if you do need to enter one, it's proxy (just the word proxy and nothing else).
No, I'm afraid I didn't know that already. What is an APN and where do you put it? I can't find any such terminology in any of the various settings windows on my laptop.


Quote:
Originally Posted by RecklessOne
I've gotten Bluetooth DUN working with AT&T and Shadowmite's patch.

Here are the pertinent settings:
Phone #: *99***1#
Username: <blank>
Password: <blank>

And this was the trickier part:
I had to go to the "Standard Modem over Bluetooth link" modem in Control Panel->Phone and Modem Options.

Under the Advanced tab, I added:AT+CGDCONT=1, "ip", "proxy"
Thank you, that seems to work here as well. I apparently have a different Bluetooth device in my laptop than you do (WIDCOMM), so my bluetooth modem has a different name, but that same string made it work. Can you tell me what it's doing? It's been a LONG time since I've tried to analyze any "AT" style dialing string <g>.

Oh, and one more question: What does that dialing string do that is different from my *99# string?

But this note is coming to you from Mozilla on my laptob via Bluetooth/DUN on my Treo650. So clearly something is working. Thanks again!
Gilliland is offline   Reply With Quote
Old 02/16/2005, 05:51 PM   #5 (permalink)
Member
 
Posts: 8
I actually picked up that AT string from PalmOne's website.

http://www.palmone.com/us/support/ha...GSM_DUN_UG.pdf

It's a PDF on how to setup Bluetooth DUN with an Unlocked GSM phone.

My understanding for the extra "***1" is that it tells the Treo which connection settings to use. In this case, it is telling it to use connection profile #1, but the 1 could be replaced with any other number so long as a profile exists to tell the phone how to connect. For most users, "1" should work fine.

Also, my instructions were for the Bluetooth stack included with XP SP2, so for Widcomm it will have a different name.

Glad to see you got it working!
RecklessOne is offline   Reply With Quote
Old 02/16/2005, 07:07 PM   #6 (permalink)
Member
 
Posts: 5
On ATT and with unlocked treo 650, I am leaving username and password blank. But everytime I connect, it hangs by stating "verifying username and password".
any suggestions?
paulux is offline   Reply With Quote
Old 02/16/2005, 07:21 PM   #7 (permalink)
Member
 
Posts: 94
Paulux, did you read the thread before you added your note? The answer is above.
Gilliland is offline   Reply With Quote
Old 02/17/2005, 01:20 AM   #8 (permalink)
Member
 
Posts: 23
Gilliland,
An APN is the wireless provider's data server name. AT&T's is called proxy, Cingular uses WAP.CINGULAR among others.
__________________
Lisa G.
Editor in Chief
www.MobileTechReview.com
pdagal is offline   Reply With Quote
Old 06/01/2005, 02:37 AM   #9 (permalink)
Member
 
Posts: 134
the other possible APN for former ATTWS folks is "public." This is the APN that doesn't go thru NAT.
swinokur is offline   Reply With Quote
Old 06/03/2005, 06:48 AM   #10 (permalink)
Member
 
Posts: 94
"public" or "proxy" - is there any particular benefit to one over the other?
Gilliland is offline   Reply With Quote
Old 06/03/2005, 01:54 PM   #11 (permalink)
Member
 
Posts: 134
public is the APN that doesnt go through the NAT. You will have a real IP address if you use public. This is necessary if you want to use VPN software, for example.
swinokur is offline   Reply With Quote
Old 06/03/2005, 10:51 PM   #12 (permalink)
Member
 
Posts: 94
Yeah, I understand what NAT does. But I couldn't think of any reason to prefer one over the other. And since neither of my VPN products cares whether or not I'm on NAT, I guess I still don't have any preference.
Gilliland is offline   Reply With Quote
Old 06/21/2005, 10:23 AM   #13 (permalink)
Member
 
Posts: 9
What a great forum and site!
Just upgraded my firmware for my att 650, did a search for the dun settings, found the above (Here are the pertinent settings:
Phone #: *99***1#
Username: <blank>
Password: <blank>)

That's all I needed.
Went to dsl reports, got 115 down and 21 up.
Not too shabby.

Thanks all
alsam is offline   Reply With Quote
Old 06/21/2005, 01:59 PM   #14 (permalink)
Member
 
Kahuna's Avatar
 
Posts: 145
I set up my dialup exactly like it shows below but I still get the PPP error during "registering your computer on the network" Any ideas?

Phone #: *99***1#
Username: <blank>
Password: <blank>
AT+CGDCONT=1, "ip", "wap.cingular"
__________________
My Splashblog
Kahuna is offline   Reply With Quote
Old 06/22/2005, 09:57 AM   #15 (permalink)
Member
 
anant's Avatar
 
Posts: 35
Hi - thanks for all this wonderful information on setting up the BT. Any chance that there is anyone out there who has managed setting up BT DUN on a Mac through an ex-ATTWS Treo? I tried the Cingular settings and they do not work. I've also tried the settings given above but I can;t get them to work either. for example, I don't know where the "trickier part" settoings given above for a PC would go on a Mac

------------------------------
And this was the trickier part:
I had to go to the "Standard Modem over Bluetooth link" modem in Control Panel->Phone and Modem Options.

Under the Advanced tab, I added:AT+CGDCONT=1, "ip", "proxy"
----------------------------------

Any and all help is appreciated! Following is where I am so far
- I enabled DUN on the Treo and my Powerbook recognizes there is a Bluetooth modem with DUN enabled.

I am using a generic 3G CID1 script.

I use the Phone number given above.

I tries to connect but immediately disconnects and says "Please check the settings on your modem"

Thanks!
anant is offline   Reply With Quote
Old 06/22/2005, 12:27 PM   #16 (permalink)
Member
 
Posts: 36
Quote:
Originally Posted by Kahuna
I set up my dialup exactly like it shows below but I still get the PPP error during "registering your computer on the network" Any ideas?

Phone #: *99***1#
Username: <blank>
Password: <blank>
AT+CGDCONT=1, "ip", "wap.cingular"

change your wap.cingular to WAP.CINGULAR

capital letters do matter.
XiiiXiii is offline   Reply With Quote
Old 07/21/2005, 10:30 PM   #17 (permalink)
Member
 
hdtvman's Avatar
 
Posts: 34
Hmm...
Caps or no caps, username or blank, etc.. tried all those combinations. That does not work for me - it still hangs on "registering..." has anyone successfully connected to wap.cingular using an unlocked Treo 650 with the latest firmware ?
BTW, PDAnet works fine. DUN OTOH.... does not.
__________________
Unlocked 650 on Cingular
SE HBH-660
Firmware: 01.71
Software: Treo650-1.20-ENA
Hardware: A
hdtvman is offline   Reply With Quote
Old 08/24/2005, 02:55 PM   #18 (permalink)
Member
 
Posts: 929
Switch to SLIP instead of PPP in Bluetooth connection settings (networking).
Mize is offline   Reply With Quote
Old 08/24/2005, 04:03 PM   #19 (permalink)
Member
 
Posts: 929
My error - I can connect this way but SLIP doesn't assign IP addresses so I'm still dead in the water.
Mize is offline   Reply With Quote
Old 08/25/2005, 01:13 PM   #20 (permalink)
Member
 
Posts: 929
Ah...figured it out. Have to use "ISP.CINGULAR" as the proxy and ISP@CINGULARGPRS.COM for username and CINGULAR1 for password. Now all works (with PPP) just fine.
Mize is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0