Results 1 to 4 of 4
  1.    #1  
    I use T-Mobile with my treo 600 and it seems to have an annoying problem.

    Frequently I get error messages like:
    "GPRS connection not available. Check your settings in Network Connections and/or try again later (Error: 0x7143)"

    My Network Preferences are set to use T-Mobile Internet (I have both unlimited Internet and T-Zones, but not VPN on my account since according to T-Mobile it is not possible to be enabled for all 3).

    However sometimes I catch a brief glimpse during the connection process and see that even though I've selected T-Mobile Internet, the Treo is actually mistakenly trying to connect to T-Mobile VPN. Then of course it waits for ages, and eventually the timeout occurs.

    It looks like T-Mobile may have set up the 3 different connection methods to "fallback" to each other if they fail to connect. I want to be able to change my Network Prefs so that I can remove the T-Mobile VPN from this chain of fallbacks. Is this possible? The Treo won't let me edit these settings and says they are "locked".

    Does anyone know how I could manually enter the correct settings for T-Mobile Internet and T-Zones in the Network Prefs? It looks like I would need to supply the username, password and APN. I could then use my own settings with fallbacks set up between the two. That way the Treo would never even attempt to connect to the VPN network.
  2. #2  
    Get rid of T-Zones - it's redundant with internet - and get VPN. I only ever connect with VPN and on the rare occasion it doesn't connect the first time, and it tries T-Mo internet as a second option, it doesn't connect.
  3.    #3  
    Quote Originally Posted by Alli
    Get rid of T-Zones - it's redundant with internet - and get VPN. I only ever connect with VPN and on the rare occasion it doesn't connect the first time, and it tries T-Mo internet as a second option, it doesn't connect.
    Why would I want VPN when I have Internet? What does VPN give me that T-Mobile Internet does not?

    Also, I'm trying to find a solution where the Treo never even tries to connect using the wrong network option. It sounds like your solution doesn't address my problem since it will still sometime fail to connect with VPN and then pointlessly try connecting using another method (that will certainly fail as well).

    If someone could tell me the settings I need I could set up my own entry in the network prefs (minus the fallback) and I wouldn't need to use the 3 badly configured standard connection preferences.

    Do you see what I'm getting at?
  4.    #4  
    I just found the settings in another thread.

    For internet:
    Username: <your phone number>
    Password: <your password on the T-mobile.com website>
    APN: internet2.voicestream.com

    For VPN:
    Username: <your phone number>
    Password: <your password on the T-mobile.com website>
    APN: internet3.voicestream.com

    For T-Zones:
    Username: <your phone number>
    Password: <your password on the T-mobile.com website>
    APN: wap.voicestream.com

Posting Permissions