Results 1 to 2 of 2
  1.    #1  
    Hi!

    I have a problem using wmodem and linux with gprs connection. Wmodem works right if I connect to a normal ISP, but if I try with gprs the connection end with "LCP terminated by peer".

    This is my pppd configuration:

    ---------------------------------------------
    /dev/ttyUSB1
    115200
    hide-password
    noauth
    connect "/usr/sbin/chat -v -f /etc/chatscripts/gprs"
    debug
    defaultroute
    noipdefault
    remotename gprs
    ipparam gprs
    lcp-echo-interval 90000
    -----------------------------------------------

    and this my chat script
    ----------------
    '' ATZ
    OK-AT-OK
    AT+cgdcont=1,"IP","internet.wind","0.0.0.0",0,0
    OK ATD*99#
    CONNECT \d\c
    -------------------
    and this is the log

    Connect: ppp1 <--> /dev/ttyUSB1
    Sep 5 20:37:58 skin pppd[7486]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x9a5685a> <pcomp> <accomp>]
    Sep 5 20:37:58 skin pppd[7486]: rcvd [LCP ConfRej id=0x1 <magic 0x9a5685a>]
    Sep 5 20:37:58 skin pppd[7486]: sent [LCP ConfReq id=0x2 <asyncmap 0x0> <pcomp> <accomp>]
    Sep 5 20:37:58 skin pppd[7486]: rcvd [LCP ConfAck id=0x2 <asyncmap 0x0> <pcomp> <accomp>]
    Sep 5 20:37:59 skin pppd[7486]: rcvd [LCP ConfReq id=0x1 <mru 1500> <asyncmap 0x0> <pcomp> <accomp> <auth pap>]
    Sep 5 20:37:59 skin pppd[7486]: sent [LCP ConfRej id=0x1 <auth pap>]
    Sep 5 20:37:59 skin pppd[7486]: rcvd [LCP ConfReq id=0x2 <mru 1500> <asyncmap 0x0> <pcomp> <accomp>]
    Sep 5 20:37:59 skin pppd[7486]: sent [LCP ConfAck id=0x2 <mru 1500> <asyncmap 0x0> <pcomp> <accomp>]
    Sep 5 20:37:59 skin pppd[7486]: sent [LCP EchoReq id=0x0 magic=0x0]
    Sep 5 20:37:59 skin pppd[7486]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <compress VJ 0f 01>]
    Sep 5 20:37:59 skin pppd[7486]: sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15> <bsd v1 15>]
    Sep 5 20:37:59 skin pppd[7486]: rcvd [LCP TermReq id=0x3]
    Sep 5 20:37:59 skin pppd[7486]: LCP terminated by peer
    Sep 5 20:37:59 skin pppd[7486]: sent [LCP TermAck id=0x3]
    Sep 5 20:37:59 skin pppd[7486]: rcvd [LCP EchoRep id=0x0 magic=0x0]
    Sep 5 20:38:02 skin pppd[7486]: Connection terminated.
    ---------------------------

    Thx in advance!
  2. #2  
    Depending on your provider, you may want to exclude the "0.0.0.0",0,0

    I am able to establish a GPRS connection with Windows 95, IrDA, and WModem. I am assigned an IP address, and the correct DNS addresses.

    However, my default gateway defaults to the SAME IP as was assigned to me, rather than the actual gateway address.

    I fix this with a route command, and although the connection does not drop, i cannot get external data.

    I'm thinking only small packets at a time; MSN Messenger makes an attempt to login (never does), but MSN Messenger logged in at a different computer says, 'You've been logged in at a different location..." so there must be SOME connection going...

    Need some Technical info

Posting Permissions