Results 1 to 7 of 7
  1.    #1  
    I am looking for someone that has the new firmware with an unlocked GSM 650 and is using a bluetooth headset that works fine and they are happy with the quality. I am posting this under 2 forums: "GSM-US" and under "Bluetooth" because I dont know which forum will garner the answers I need. I just recently upgraded my firmware on my unlocked GSM Treo 650 (w/T-Mobile now) and my SE HBH-660 bluetooth headset stopped working.

    I have used the HBH 660 fine for 5 months since I got it in December, but as soon as I upgraded the 650's firmware I can't get it to pair with the phone. It shows up as a "trusted device" but I cant get the phone to see it as a "Hands-free device." Calling Palm was no help. They said the 660 isnt on their "approved list" for the Treo 650 that is on their website. On it, there are only 8 headsets! Whats up with that?!?

    Please, if someone has an updated-firmware, unlocked GSM Treo 650 and is happy with their bluetooth headset, please let me know! I miss my BT badly!

    Thanks
  2. #2  
    Did you try resetting the headset?
    See Page 31 of 35:
    http://www.sonyericsson.com/downloads/HBH-660_662_UG_R3a_Multilingual2.pdf#search='HBH660%20manual'

    Try that, and then delete your bluetooth cache on the Treo. Re-pair.
    at&t Treo 680, SW 2.11-ATT
    Cingular Treo 650 Unlocked, SW 1.17-CNG/FW 1.51
  3. #3  
    I have 1.20 and I am happy with my BT headset. It is the Plantronics Voyager 510. Others have had issues with BT. Try doing a hard reset pairing it without your retored prefs etc. see if it works then.
    PalmIII > PalmIIIx > PalmIIIxe > TRGPro > Handera 330 > Zire71 > Treo600 > Treo650 > Treo680 > Treo750 > Centro > TreoPro > iPhone 32GB 3GS

  4.    #4  
    Thanks, yes, I did try pairing it after a hard reset and it acted exactly the same way. It will ask for the passcode for the BT any other time then when I am in the "Hands Free device" setup mode. When I tried my friend's BT headset, it paired fine - just the way mine did before I updated the FIRMWARE...
    Ah, the joys of trying to "update" technology...
  5.    #5  
    Thank you 'Mistercoffee1' for the advice - that worked perfectly. It was a bit more convoluted to get it to Pair, but in the end, it worked. I hope I dont have to do that everymorning! Thanks again!
  6. #6  
    Putting gas in my car made my front bumper fall off! lol.
  7. #7  
    Quote Originally Posted by Woogie
    Putting gas in my car made my front bumper fall off! lol.
    Gee, what a solid post - I want the last two minutes of my life back.

    This issue is not that uncommon when updating firmware, and sometimes requires you to reset your headset (particularly Sony Ericsson).
    Last edited by mistercoffee1; 03/24/2006 at 08:51 PM.
    at&t Treo 680, SW 2.11-ATT
    Cingular Treo 650 Unlocked, SW 1.17-CNG/FW 1.51

Posting Permissions