Results 1 to 6 of 6
  1.    #1  
    I recently ordered and purchased the Treo 650 and I'm having the many problems with it.

    I use my phone pretty much 24/7, as my job requires me to do so. Even in strong coverage areas, my phone is dropping nearly every call. I looked at the strength of the connection, and it was a good 2-3 bars, full battery charge.

    I first thought I was asccidentaly hitting the "hang up" button, so I held the phone away from my ear. It wasn't the problem

    I use a Bluetooth headset, so I thought that the Bluetooth was somehow interfering with the connection, so I turned the Bluetooth off. That wasn't the problem.

    So then I thought that they sent me a lemon. I went to the Sprint Store, and they gave me a new phone. And still, my phone is dropping nearly every call.

    I looked at PalmOne's "Knowledge" Library and it was absolutely no help.

    I need to fix this problem ASAP. I can't continue doing business when my phone drops every call. If this problem isn't fixed soon, I'll go back to my Treo 600, as I am tired of this.
  2. #2  
    I would say take your 650 to a store and get it exchanged. I have had my 650 for 5 days now and have not dropped any calls. So maybe yours has a defective radio.
  3.    #3  
    I switched it out about three days ago, and I'm having the same problems. Is it possible that they gave me two lemons? Possible, but not likely.

    It's not necessarily dropping calls because of a weak signal, rather, it's dropping calls because it's hanging up "by itself." As I said before, it keeps dropping them even if I have 2-3 bars.

    I don't think it's a signal issue, I think it has something to do with the programming. Is anyone having the same problem?
  4. #4  
    Quote Originally Posted by scondon
    I switched it out about three days ago, and I'm having the same problems. Is it possible that they gave me two lemons? Possible, but not likely.

    It's not necessarily dropping calls because of a weak signal, rather, it's dropping calls because it's hanging up "by itself." As I said before, it keeps dropping them even if I have 2-3 bars.

    I don't think it's a signal issue, I think it has something to do with the programming. Is anyone having the same problem?
    are you sure it's not a program causing the problem, that is, are you running apps that you brought over from your T600? have you tried calls after the unit's been hard reset, with no user data on it?

    i'm finding the more apps i gradually foist upon my T650, the more unstable it gets. i have plenty of free memory. i actually don't use my T650 all that much as a phone, so i don't have a ton of data. but i've not experienced any dropped calls on the few i've made/received.
    Paul Theodoropoulos
    <a href=http://www.anastrophe.com>www.anastrophe.com</a>
  5.    #5  
    The only program I have on my T650 is Docs to Go, which came with the T650 software. I brought over no files from my T600.
  6.    #6  
    Well, thanks for all of your help, but I couldn't get the darned thing to work. I exchanged it for a new T600. I really didn't want to give my T650 up, but I can't keep doing business with my phone dropping every call. I hope no one else has to deal through what I had to.

Posting Permissions