webOS Nation Forums >  webOS Developer Forums >  Nelsun Apps > Network Drives - Enyo Network Drive Mapper
Network Drives - Enyo Network Drive Mapper
  Reply
Like Tree35Likes

 
Thread Tools Display Modes
Old 03/07/2012, 10:51 AM   #161 (permalink)
Member
 
Posts: 288
Is there any way to add CIFS support to the stock WebOS kernel without installing Uberkernel (or another equivalent kernel with CIFS support)?
Semma2 is offline   Reply With Quote
Old 03/17/2012, 03:11 AM   #162 (permalink)
Member
 
Posts: 2
Quote:
Originally Posted by geekpeter View Post
usually a nas drive will have folder/share names inside the ip, typically the name of a HD inside the NAS.

Drive Path = IP Address of your NAS then the folder/hd name inside it.
Mount Point = Where woudl you browse to on your touchpad to access it (Default would be shares/yoursharename)

For example my Western Digital ones in Enyo Drive Mapper id have the following...

Drive Path = 192.168.0.25/Public (the NAS IP and its sharepoint folder)
Mount to Folder (Link on touchpad) shares/WD-NAS1

My Buffalo NAS Drives would be

Drive Path = 192.168.0.30/Games (the NAS IP and its sharepoint folder)
Mount to Folder (Link on touchpad) shares/NAS-Games

Drive Path = 192.168.0.31/Emulation (the NAS IP and its sharepoint folder)
Mount to Folder (Link on touchpad) shares/NAS-Emu

Drive Path = 192.168.0.32/Video (the NAS IP and its sharepoint folder)
Mount to Folder (Link on touchpad) shares/NAS-Video

Drive Path = 192.168.0.33/Misc (the NAS IP and its sharepoint folder)
Mount to Folder (Link on touchpad) shares/NAS-Misc

This is different to my WD NAS as it has 1 sharepoint (or just a HD in general), my buffalo drives have 4 drives, so 4 sharepoints.

---

Username and password will be whatever you'd log into the NAS drives with to access settings, some default to admin/admin.
Thank you! Now my problem is that I can't save the settings. Everything is filled out and when I tap the save button nothing happens. Does anyone else have the same issue?
thank you.
gowebosgo is offline   Reply With Quote
Old 03/28/2012, 08:12 PM   #163 (permalink)
Member
 
Posts: 552
Quote:
Originally Posted by Ubuntite View Post
Does this work with any Enyo-capable device? Pre 2 w/ map update?

I got it installed on my Pre 2 but get "Connection Error - Can not access a needed shared library" when I try to mount a share.
Bump...
huladaddy is offline   Reply With Quote
Old 04/11/2012, 04:02 AM   #164 (permalink)
Homebrew Developer

 
Posts: 62
Did you watch the log while trying to attach a drive? Use Lumberjack (Homebrew)
MikeDeWitt is offline   Reply With Quote
Old 05/25/2012, 03:36 PM   #165 (permalink)
Member
 
Posts: 1
Quote:
Originally Posted by gowebosgo View Post
Thank you! Now my problem is that I can't save the settings. Everything is filled out and when I tap the save button nothing happens. Does anyone else have the same issue?
thank you.
I have the same problem, I cant save the settings.
gooh is offline   Reply With Quote
Old 05/31/2012, 01:51 AM   #166 (permalink)
Member
 
Posts: 1
Quote:
Originally Posted by gooh View Post
I have the same problem, I cant save the settings.
Same problem here.

Any solutions/troubleshooting steps?
mwolfod is offline   Reply With Quote
Old 07/15/2012, 11:02 AM   #167 (permalink)
Member
 
Posts: 1
Works with apple shares. I was able to successfully connect to my time capsule. Awesome!
indoldrums is offline   Reply With Quote
Liked by Norf likes this.
Thanked By: Norf
Old 07/24/2012, 11:06 PM   #168 (permalink)
Member
 
Posts: 62
Works great! Tested along with Wifi Sharing on a Pre.

Thanks Norf!
getsun is offline   Reply With Quote
Liked by Norf likes this.
Thanked By: Norf
Old 08/29/2012, 01:29 PM   #169 (permalink)
Member
 
geekpeter's Avatar
 
Posts: 3,687
app author has his code on 1st link, i was wondering if either him or another genious was able to add an option to use the davfs2 method of gaining our box.net accounts as a mounted share added into this package... if possible? it would be purely amazing if our box.net share appeared in the enyo drive mapper list of shares.

i have davfs2 mounted/used as part of my touchpad/ubuntuchroot (pretty handy tbh but obv means i need ubuntuchroot open all the time) but wondered as suggested above if its possible to have native, esp more useful for those of us using the likes of touchplayer/kalem media player or anything else similar, seems like a useful way for some apps/packages to aquire a poor mans native storage cloud (maybe abuse slightly to patch our software manager to backup selected apps to cloud?) without having to use an app as a middleman to access our files.
__________________
Touchpad Keyboard Themes - >> Click Me <<
geekpeter is offline   Reply With Quote
Old 10/08/2012, 05:09 PM   #170 (permalink)
Member
 
Posts: 4
Installed the app to check it out. Touchpad starting acting weird (Expose not going full screen, app didn't seem to be saving information, etc). I figured it was a bad install.

Here's the thing. I can't get it to uninstall. Tried finding it in Preware, and it doesn't show. Tried deleting it from the Software Manager, but it locks up the TP.

Suggestions?
Ikrion is offline   Reply With Quote
Old 10/08/2012, 05:37 PM   #171 (permalink)
Member
 
Posts: 4
Quote:
Originally Posted by Ikrion View Post
Installed the app to check it out. Touchpad starting acting weird (Expose not going full screen, app didn't seem to be saving information, etc). I figured it was a bad install.

Here's the thing. I can't get it to uninstall. Tried finding it in Preware, and it doesn't show. Tried deleting it from the Software Manager, but it locks up the TP.

Suggestions?
Update: I got it to uninstall, but using Expose, it still reduces the size of the Agenda screen (about 70% normal size).

Sounds like a WebOS Doctor item when I get home...
Ikrion is offline   Reply With Quote
Old 11/02/2012, 09:41 PM   #172 (permalink)
Member
 
Posts: 3
This no longer seems to works with webos 3.05 (I've tried 1.02 & 1.01 with latest the Uberkernal) and when you try to remove the application, it hangs the TP and you may need to use Webos Doctor to recover.

I had this working before, so I don't know what's wrong now. Maybe an update to Uberkernal or webos... I dunno.

Shame really. It was a really useful little App.

Last edited by Official-Heat; 11/02/2012 at 09:50 PM. Reason: grammar
Official-Heat is offline   Reply With Quote
Old 11/02/2012, 09:47 PM   #173 (permalink)
Member
 
geekpeter's Avatar
 
Posts: 3,687
Quote:
Originally Posted by Official-Heat View Post
This no longer works with webos 3.05 (tried 1.02 & 1.01 with latest Uberkernal) and when you try to remove the application, it may hang the TP and you may need to use Webos Doctor to recover.

I had this working before, so I don't know what's wrong now. Maybe an update to Uberkernal or webos... I dunno.

Shame really. It was a useful little App.
er it still works on touchpad/pre3, ive been using it for ages without any issues, use it to access my PC, laptops, NAS drives and other mobile devices all the time.
__________________
Touchpad Keyboard Themes - >> Click Me <<
geekpeter is offline   Reply With Quote
Old 11/02/2012, 09:54 PM   #174 (permalink)
Member
 
Posts: 3
Quote:
Originally Posted by geekpeter View Post
er it still works on touchpad/pre3, ive been using it for ages without any issues, use it to access my PC, laptops, NAS drives and other mobile devices all the time.
Hangs my Touchpad after I had to do a clean install from Webos Doctor (and re-installing Uber etc.). Same as some of the other posts. Won't let me save profile info and then gets worse from there on...
Official-Heat is offline   Reply With Quote
Old 11/02/2012, 10:13 PM   #175 (permalink)
Member
 
geekpeter's Avatar
 
Posts: 3,687
Quote:
Originally Posted by Official-Heat View Post
Hangs my Touchpad after I had to do a clean install from Webos Doctor (and re-installing Uber etc.). Same as some of the other posts. Won't let me save profile info and then gets worse from there on...
doctoring the device doesnt do a 100% cleanup, theres plenty of leftovers that survive, likely some leftovers giving you grief or something not being fixed when you doctored, if the app works for some and not others then the app cant be broken, it must be a local issue of some kind, just a case of tracking down what that may be.
__________________
Touchpad Keyboard Themes - >> Click Me <<
geekpeter is offline   Reply With Quote
Old 11/03/2012, 06:05 AM   #176 (permalink)
Member
 
Posts: 3
Quote:
Originally Posted by geekpeter View Post
doctoring the device doesnt do a 100% cleanup, theres plenty of leftovers that survive, likely some leftovers giving you grief or something not being fixed when you doctored, if the app works for some and not others then the app cant be broken, it must be a local issue of some kind, just a case of tracking down what that may be.
Ok, I got it working again. I carried on and installed some of the other webos patches I had on there previously (including internalz and it's prerequisite patches). After which, installing network drives worked again.
Network drives must require another patch as well as Unerkernel. I only wish I new which one it was that fixed it so that I could report it back for the others that are seeing this issue.
Official-Heat is offline   Reply With Quote
Old 11/03/2012, 08:05 AM   #177 (permalink)
Member
 
geekpeter's Avatar
 
Posts: 3,687
Quote:
Originally Posted by Official-Heat View Post
Ok, I got it working again. I carried on and installed some of the other webos patches I had on there previously (including internalz and it's prerequisite patches). After which, installing network drives worked again.
Network drives must require another patch as well as Unerkernel. I only wish I new which one it was that fixed it so that I could report it back for the others that are seeing this issue.
well it works again, your not sure how but at least you can use it again.
__________________
Touchpad Keyboard Themes - >> Click Me <<
geekpeter is offline   Reply With Quote
Old 12/01/2012, 07:19 PM   #178 (permalink)
Member
 
Posts: 220
Hi, I wonder if anybody can help? I've tried installing Bash/USB flash mount with dev mode on and off but I am still unable to access my files on USB stick. What do I need to do/What am I doing wrong?
Thanks in advance.
Paulscarbs is offline   Reply With Quote
Old 12/11/2012, 08:41 AM   #179 (permalink)
Homebrew Developer
 
Posts: 42
Quote:
Originally Posted by rigged11 View Post
I recently purchased an Asus RT-N66U router and connected a 1TB drive to it.

I enabled the samba share feature in the router and I can browser and view all of the files from my Windows computer.

I just don't know how to mount this share with my touchpad.

I don't know what IP address I should use.

Can anyone help?

did you ever get this to work.... I have the same problem with Asus RT-N56U... using the internal IP (often 192.168.1.1)

I keep getting error "No such device or address"
gderoiste is offline   Reply With Quote
Old 12/11/2012, 12:42 PM   #180 (permalink)
Member
 
geekpeter's Avatar
 
Posts: 3,687
Quote:
Originally Posted by gderoiste View Post
did you ever get this to work.... I have the same problem with Asus RT-N56U... using the internal IP (often 192.168.1.1)

I keep getting error "No such device or address"
is the NAS drive on the same or any workgroup? MSHOME, WORKGROUP etc, any firewall or security type interference on the routers side? does the NAS have a fixed IP or dynamic, as fixed is ofc preferable or the touchpad likely wont see it.

Are you entering the username/password into drive mapper? common default being admin/admin or similar, is the NAS easily accessible from a "normal" desktop winblows/linux box?

the share will be accessible via the IP then device/drive/share name

ie: 192.168.0.10/MyVideoNASDrive

then enter your NAS drives username/password (same ones you use to web-login unl;ess you created more users etc on the device ofc) etc and that should be it.
__________________
Touchpad Keyboard Themes - >> Click Me <<
geekpeter is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0