webOS Nation Forums >  webOS Developer Forums >  Nelsun Apps > Network Drives - Enyo Network Drive Mapper
Network Drives - Enyo Network Drive Mapper
  Reply
Like Tree35Likes

 
Thread Tools Display Modes
Old 12/11/2012, 12:41 PM   #181 (permalink)
Homebrew Developer
 
Posts: 42
yes, everything in the same workgroup, using the ip address instead of the name and yes it works fine from windows

I am am also typing in the username and password for the rt-n56u....

does the drive have to be formatted in a specific way for the touchpad to see it ?

however my touch can see the shares on my windows 7 pc fine...
gderoiste is offline   Reply With Quote
Old 12/11/2012, 12:51 PM   #182 (permalink)
Member
 
geekpeter's Avatar
 
Posts: 3,686
Quote:
Originally Posted by gderoiste View Post
yes, everything in the same workgroup, using the ip address instead of the name and yes it works fine from windows

I am am also typing in the username and password for the rt-n56u....

does the drive have to be formatted in a specific way for the touchpad to see it ?

however my touch can see the shares on my windows 7 pc fine...
you mean you entered the username/password for your NAS drive yeah? and not your router?
__________________
Touchpad Keyboard Themes - >> Click Me <<
geekpeter is offline   Reply With Quote
Old 12/11/2012, 01:38 PM   #183 (permalink)
Homebrew Developer
 
Posts: 42
hi,

no , the username/password I entered is for the asus rt-n56u router.

there is just a large usb drive connected into the rt-n56u
gderoiste is offline   Reply With Quote
Old 12/11/2012, 02:08 PM   #184 (permalink)
Member
 
geekpeter's Avatar
 
Posts: 3,686
Quote:
Originally Posted by gderoiste View Post
hi,

no , the username/password I entered is for the asus rt-n56u router.

there is just a large usb drive connected into the rt-n56u
the program your using is for network devices, be it a windows/linux operating system "sharing" folders or by a proper network drive, NAS drives appear in your network, seemingly as another computer, as your attempting something out of the norm your probably going to need help specific to your router, to be honest tho ive never owned a router (or even heard of one till now) that had the ability to hook up usb devices beyond maybe a printer.

either way id guess youd need more than just the IP address, on a proper NAS you specify the ip and device/drive name.

192.168.0.10/DeviceName

maybe you need something similar, tho again your probably best re-reading your routers manual or looking for a forum via google that has had a similar question asked.
__________________
Touchpad Keyboard Themes - >> Click Me <<
geekpeter is offline   Reply With Quote
Old 12/11/2012, 02:34 PM   #185 (permalink)
Homebrew Developer
 
Posts: 42
thanks , but the router together with the usb drive acts the same as a nas... Jyst not with the touchpad
gderoiste is offline   Reply With Quote
Old 12/11/2012, 03:28 PM   #186 (permalink)
Member
 
geekpeter's Avatar
 
Posts: 3,686
Quote:
Originally Posted by gderoiste View Post
thanks , but the router together with the usb drive acts the same as a nas... Jyst not with the touchpad
"acts like" isnt the same as "actually is", still better off reading the specific info for the router in question, esp as its "faking it", the fact that you cant get it to work with ease, to me would say id need to check google for others with a usb/nas related issue for that router, bound to be others with similar issues.
__________________
Touchpad Keyboard Themes - >> Click Me <<
geekpeter is offline   Reply With Quote
Thanked By: don_falcone
Old 12/13/2012, 01:38 PM   #187 (permalink)
Member
 
kayphoonstar's Avatar
 
Posts: 630
Quote:
Originally Posted by gderoiste View Post
thanks , but the router together with the usb drive acts the same as a nas... Jyst not with the touchpad
Hey. I've got an rt-ac66u which should be similar. I didn't have to do anything special just "192.168.1.1/USBShareName" - no username, password, or workgroup entries.
kayphoonstar is offline   Reply With Quote
Liked by geekpeter likes this.
Old 12/16/2012, 08:18 AM   #188 (permalink)
Homebrew Developer
 
Posts: 42
Quote:
Originally Posted by kayphoonstar View Post
Hey. I've got an rt-ac66u which should be similar. I didn't have to do anything special just "192.168.1.1/USBShareName" - no username, password, or workgroup entries.
ok i got it working now... I had initially a terabyte drive (with 2 partitions) plugged into the router. I have now plugged in a maxtor 500gb drive , with just one partition, and it works great, so it must be something specific regarding the first drive... I might try reformatting it ....


great app !!
gderoiste is offline   Reply With Quote
Liked by geekpeter likes this.
Old 05/24/2013, 03:28 AM   #189 (permalink)
Member
 
Posts: 49
Hi all,

just wanted to share my experience.

Thanks to Nelsun Network Drives I can now sit at work with my Pre3 and listen to music streaming from an SD card that sits in a mobile WiFi hotspot.
Main ingredient: patience! The media indexer is not the quickest daemon
I use a 4G xsboxgo (without a SIM card), which can share a microSD card as a samba share.
The only other app that is involved is Internalz Pro and likely the ‹berKernel for the support of mounting a drive.
My setup:
I have my mp3s on the Pre3 in /media/internal/music/<artist>/<album>
On the share I have also the <artist>/<album> structure, directly in the main folder.
Using Internalz I created an additional folder /media/internal/music/4G
Next connect the Pre3 to the hotspot
In the Network Drive app I select the share from the hotspot as Drive Path and /media/internal/music/4G as Mount to Folder. I also set username and password and leave the domain blank, as I can not set that on the 4G thingy.
Now I can tap the profile to connect and when the tickmark is there, switch to Internalz
Internalz shows now all the folders from the share, but only if show hidden files is selected in the options.
The stock player however still only shows the 500 mp3s on my phone, so we need to encourage the media indexer to have a look.
I selected the info for the folder /media/internal/music and set the attribute to "hide from webOS". After swiping back, I undid that again, by setting the attribute (now from the .media folder) back to not hide.
When I now start the stock player, the main bit, mentioned above comes into play: patience!
After quite a while, the count of songs on the top starts to change and it took this morning a couple of minutes until it showed the final 2000 that I have loaded (1500 on the SD).

So: there is no reboot involved and no deleting of /var/luna/data/filenotify.db3 or stopping and resarting the filenotifyd.

Known problems:
Every now and then there is a small pause during a song. I don't know if due to connection problems or webOS doing something.
Simultaneous connection to data is working (I can access the internet) but it seems, that automatic receiving of emails is blocked as long as the wifi connection to the hotspot is active. Don't know, why that would be.

Not tested:
The best way to revert the mount. I guess the indexer can be persuaded to re-index just the same after unmounting the drive.
I also didn't put any other media on the card, yet, but I can't see, why it should behave differently with pictures.

Ah bummer. While I was happily writing that I did something that resulted in a total loss of any audio - no swoosh sound when closing an app, no dtmf when dialing, no music anymore. I tried to make a phone call.
A reboot of the device fixed it.

But still, I think I will try again and keep streaming music and hopefully my experience can help someone else, as well.

Regards,
UW
__________________
Handspring Visor -> Palm Centro -> HP Pre 3 / HP TP 4G
HerrSchwarz5 is offline   Reply With Quote
Liked by geekpeter likes this.
Thanked By: p41m3r
Old 08/01/2013, 03:36 PM   #190 (permalink)
pivotCE Developer
 
Posts: 2,115
works great on touchpad with synology nas, but on my Pre2 it seems my Uberkernel 2.2.4-89 is missing CIFS support, cause this error displays:
Connection Error
Can not access a needed shared library

Is there any Pre2 Kernel around having CIFS support like Pre3 ?
__________________
Patch Enhancing vCard Export -|- Your own cloud with Zarafa (EAS sync) -|-
Tasks-app of 2.x on 3.x incl.EAS sync -|- SYM key in Enyo on phones -|- My hidden webOS Tips and Tricks - like it ?
gizmo21 is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0