webOS Nation Forums >  webOS Developer Forums >  Navit > Navit 0.5.0.5287-1: new stable release
Navit 0.5.0.5287-1: new stable release
  Reply
Like Tree25Likes

 
Thread Tools Display Modes
Old 12/13/2012, 02:34 PM   #1 (permalink)
Homebrew Developer
 
Posts: 164
I just pushed a new build to the stable-feed which just brings webOS-users back to the bleading-edge of Navit upstream development

The Navit project fixed some memory leaks and did some stability work, appart from that nothing changed.

/Malte
noradtux is offline   Reply With Quote
Old 12/14/2012, 01:09 PM   #2 (permalink)
Member
 
Posts: 38
This time, all right !
I'm still testing.
Thank you !
s3rgei is offline   Reply With Quote
Old 12/14/2012, 01:38 PM   #3 (permalink)
Member
 
Posts: 19
Thank you so much for blessing webOS with a proper navigation app. We salute you.
lisalover1 is offline   Reply With Quote
Old 12/14/2012, 06:43 PM   #4 (permalink)
Member
 
Posts: 214
is it being pushed through preware?
Kenjo2009 is offline   Reply With Quote
Old 12/18/2012, 12:02 PM   #5 (permalink)
Member
 
Posts: 92
Quote:
Originally Posted by noradtux View Post
I just pushed a new build to the stable-feed which just brings webOS-users back to the bleading-edge of Navit upstream development

The Navit project fixed some memory leaks and did some stability work, appart from that nothing changed.

/Malte
Hi Malte,

cant get to work on my pixi plus again, even as the last two or three releases of navit.

The install itself works smooth, the program starts, and then, its in english. Ist this ok for this releases.

But besides this not so annoying issue, navit cant find my internal gps (there is no profile listed in the Vehicle section). This is also a new problem with the last 2 oder three new releases.

Again, there is my spare Pixi-plus to lend out to test and get things to work, if you want. PM me, and we can organize things.

Cheers

Achim from Gießen, germany
achimi is offline   Reply With Quote
Old 12/18/2012, 06:46 PM   #6 (permalink)
Member
 
johncc's Avatar
 
Posts: 4,192
Thank you. No problems with the update here.
johncc is offline   Reply With Quote
Old 12/19/2012, 02:28 PM   #7 (permalink)
Homebrew Developer
 
Posts: 164
Quote:
Originally Posted by achimi View Post
Hi Malte,

cant get to work on my pixi plus again, even as the last two or three releases of navit.

The install itself works smooth, the program starts, and then, its in english. Ist this ok for this releases.

But besides this not so annoying issue, navit cant find my internal gps (there is no profile listed in the Vehicle section). This is also a new problem with the last 2 oder three new releases.

Again, there is my spare Pixi-plus to lend out to test and get things to work, if you want. PM me, and we can organize things.

Cheers

Achim from Gießen, germany
Hmm, sounds like a problem with your config. If it doesn't list the "gps-vehicle" most probably the definition in the config is missing. My suggestion would be that you delete your config (USB-drive/appdata/org.webosinternals.navit) or move it out of the way.

/Malte
noradtux is offline   Reply With Quote
Old 12/21/2012, 01:26 AM   #8 (permalink)
Member
 
Posts: 92
Quote:
Originally Posted by noradtux View Post
Hmm, sounds like a problem with your config. If it doesn't list the "gps-vehicle" most probably the definition in the config is missing. My suggestion would be that you delete your config (USB-drive/appdata/org.webosinternals.navit) or move it out of the way.

/Malte
hi, malte,

thanx for your answer.

that was the 1. Thing i tried. I cleaned up all things related to navit and made a clean install, same thing: gui in english and no profiles available. Should i try to copy my config files and xmls over from my touchpad. There it is working allright.

besides: on my touch i have sn external bluetooth receiver. It is working, but the data transmission is seamingly very slow, so that the position on the map gets more sn more behind my real position, which is very bad for real navigation. Is therd sth. Known about that in the team ?

ciao achim
achimi is offline   Reply With Quote
Old 12/24/2012, 09:15 AM   #9 (permalink)
Homebrew Developer
 
Posts: 164
Quote:
Originally Posted by achimi View Post
hi, malte,

thanx for your answer.

that was the 1. Thing i tried. I cleaned up all things related to navit and made a clean install, same thing: gui in english and no profiles available. Should i try to copy my config files and xmls over from my touchpad. There it is working allright.
See PM.

Quote:
Originally Posted by achimi View Post
besides: on my touch i have sn external bluetooth receiver. It is working, but the data transmission is seamingly very slow, so that the position on the map gets more sn more behind my real position, which is very bad for real navigation. Is therd sth. Known about that in the team ?
Since I do not have a BT GPS receiver that code is more or less untested, and I am still amazed that it's working at all

Since Palm did never intended to use that API from a native application it's a real PITA to use outside of JavaScript-Code. I guess the only chance to get this working properly would be to put Navit into some kind of JavaScript wrapper. My programming skills are not sufficient for that and frankly, I don't feel like investing the time needed for this.

/Malte
noradtux is offline   Reply With Quote
Old 12/27/2012, 02:26 PM   #10 (permalink)
Member
 
Posts: 4
Hi, I`ve a similar problem: Palm Pre Plus, Navit worked fine before the update, now the app starts anything looks fine, but no profile is listed in the Vehicle section, the language is german and the main menu has new icons. I´ve deleted the navit directory in USB-Mode, then I installed Navit again. Navit Maps is installed too and I can choose maps in the menu of navit. Any Idea?
fmiproject is offline   Reply With Quote
Old 01/03/2013, 08:45 PM   #11 (permalink)
Member
 
patapoof's Avatar
 
Posts: 788
on veer 2.1 took off navit, deleted speech dispatcher and locale ...restarted luna ...reinstalled navit from preware via webosqi ...shows 2 (yes, two iinstances of org.webosinternals.locale in the dialog that results from clicking the "install" button) and speech dispatcher and asks for permission to install that ...proceeds and finishes fine but navit does not open via icon ...only tap ripple ...I am so sad !! hey, noradtux, make me happy !!
patapoof is offline   Reply With Quote
Old 01/11/2013, 01:24 PM   #12 (permalink)
Member
 
60RH's Avatar
 
Posts: 421
2 bugs: more annoying then anything else.
1.Broke integration with GMaps. Opens up Navit but doesn't show the route. Route is in recent locations so it's easy to work around that
2. The mute icon becomes active after rotation from portrait to landscape
60RH is offline   Reply With Quote
Old 01/12/2013, 02:37 AM   #13 (permalink)
Member
 
Posts: 16
Version 4787.M works fine on my Pre- 1.45.
GPS broke on a previous upgrade, version 5243.2, and this version has the same error.
The Navit log shows a software or compatibility error.
I guessing these newer verisions may require ENYO 2, as my device only has ENYO 1.

Navit Log Error:
'/media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/vehicle/libvehicle_webos.so: undefined symbol: PDL_GetParamJson
cosb3541 is offline   Reply With Quote
Old 01/18/2013, 02:58 PM   #14 (permalink)
Member
 
Posts: 4
dito! Palm Pre Plus WebOs 1.4.5 (WebOs doctored)
0.5.0.5243-2_armv7
0.5.0.5287-1_armv7 doesn`t work (no vehicle profile - gps)
log is the same.

0.5.0.4787-2_armv7 works perfect!

Franz aus Kölle
fmiproject is offline   Reply With Quote
Old 01/18/2013, 03:13 PM   #15 (permalink)
Member
 
patapoof's Avatar
 
Posts: 788
Quote:
Originally Posted by fmiproject View Post
dito! Palm Pre Plus WebOs 1.4.5 (WebOs doctored)
0.5.0.5243-2_armv7
0.5.0.5287-1_armv7 doesn`t work (no vehicle profile - gps)
log is the same.

0.5.0.4787-2_armv7 works perfect!

Franz aus Kölle
where can I find the last one that works so I can try it on my veer 2.1 att ??
patapoof is offline   Reply With Quote
Old 01/18/2013, 06:18 PM   #16 (permalink)
Member
 
Gwidion's Avatar
 
Posts: 195
Quote:
Originally Posted by patapoof View Post
where can I find the last one that works so I can try it on my veer 2.1 att ??
Direct in preware feed.
Gwidion is offline   Reply With Quote
Old 01/18/2013, 07:30 PM   #17 (permalink)
Member
 
Posts: 2
Hi Guys,

I get exactly the same PDL_GetParamJson-Error as described by cosb3541. Is there any chance to get back to an older version which didn't fabricate that error and where can I find it? In Preware there is only the current version available to download and apparently there is no other source on the internet where Navit for webOS might be downloaded from.

Greetings

D0n_Marco
D0n_Marco is offline   Reply With Quote
Old 01/18/2013, 07:32 PM   #18 (permalink)
Member
 
patapoof's Avatar
 
Posts: 788
Quote:
Originally Posted by D0n_Marco View Post
Hi Guys,

I get exactly the same PDL_GetParamJson-Error as described by cosb3541. Is there any chance to get back to an older version which didn't fabricate that error and where can I find it? In Preware there is only the current version available to download and apparently there is no other source on the internet where Navit for webOS might be downloaded from.

Greetings

D0n_Marco
ditto..
patapoof is offline   Reply With Quote
Old 01/19/2013, 04:21 AM   #19 (permalink)
Homebrew Developer
 
hape's Avatar
 
Posts: 556
Hi all,

yes you can go back to older versions. All Versions can be found here:
Index of /feeds/webos-internals/armv7/

HaPe
hape is offline   Reply With Quote
Thanked by Don_Marco, patapoof
Old 01/19/2013, 03:00 PM   #20 (permalink)
Member
 
Don_Marco's Avatar
 
Posts: 8
Thanks HaPe :-)

Version 0.5.0.4787-2 seems to work on Pre- running webOS 1.4.5

Last edited by Don_Marco; 01/20/2013 at 10:04 AM.
Don_Marco is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0