Page 3 of 6 FirstFirst 123456 LastLast
Results 41 to 60 of 107
Like Tree25Likes
  1. #41  
    Hi,

    Ive decided to build the Navit by myself, because of very old package in Preware. I just built the package with the current svn 0.5.0.5337-0.1 for my personal use and now decided to share it with you.

    The recent code contains a lot of translation changes and changes in the app itself. I feel the app start is faster and the app speed is faster also. Tested only on my Pre3.
    Because I have not enough space on my ftp server, I pushed the build here:

    org.webosinternals.navit_0.5.0.5337-0.1_armv7.ipk | Uloz.to

    It is a public and proven czech file storage server, just click Download and write captcha.
    Then install it using WebOS Quick Install or Preware.

    Good luck!
    Microsoft Lumia 535, the Google Maps, Maps, wInNeR, Gas&Oil, HERE maps for webOS development
  2. #42  
    Quote Originally Posted by 72ka View Post
    Hi,

    Ive decided to build the Navit by myself, because of very old package in Preware. I just built the package with the current svn 0.5.0.5337-0.1 for my personal use and now decided to share it with you.

    The recent code contains a lot of translation changes and changes in the app itself. I feel the app start is faster and the app speed is faster also. Tested only on my Pre3.
    Because I have not enough space on my ftp server, I pushed the build here:

    org.webosinternals.navit_0.5.0.5337-0.1_armv7.ipk | Uloz.to

    It is a public and proven czech file storage server, just click Download and write captcha.
    Then install it using WebOS Quick Install or Preware.

    Good luck!
    wow! thanks for continuing to develop for webOS!!

    i have Navit 0.5.0.5287-1 on my Pre2 now. should i uninstall first?

    or, will this either replace the existing, or install as a separate independent app?
  3. #43  
    Quote Originally Posted by 72ka View Post
    Hi,

    Ive decided to build the Navit by myself, because of very old package in Preware. I just built the package with the current svn 0.5.0.5337-0.1 for my personal use and now decided to share it with you.

    The recent code contains a lot of translation changes and changes in the app itself. I feel the app start is faster and the app speed is faster also. Tested only on my Pre3.
    Because I have not enough space on my ftp server, I pushed the build here:

    org.webosinternals.navit_0.5.0.5337-0.1_armv7.ipk | Uloz.to

    It is a public and proven czech file storage server, just click Download and write captcha.
    Then install it using WebOS Quick Install or Preware.

    Good luck!
    72ka is KING of maps!
  4. #44  
    Well i deleted navit (left voice dispatcher installed) installed this with quick install on a pre2 running 2.1. Downloaded florida map on the device and it actually worked where it has never worked for me before. And the voice works too. Thanks a lot

    I have to admit I have never quite figured out how to use navit tho,
  5. #45  
    Never had issues with Navit before once figured it out.
    Thanks to KING of the maps
    And yes Navit loads much faster and gives route even without GPS enabled and only Locations Service turned on, which previous version never did.
    I think I came across a post form the previous maintainers of Navit for webOS in these forums so maybe 72ka can contact them and upload that to preware so more people can get the update - not sure how many are using it anyway. I rarely launch it myself just because the patch portal was hacked and there's nothing new there
    Might get it out for a ride tomorrow but so far moving the map around is much more smoother than before as well
    Thanks again to 72ka!
  6. #46  
    Quote Originally Posted by 60RH View Post
    Never had issues with Navit before once figured it out.
    Thanks to KING of the maps
    And yes Navit loads much faster and gives route even without GPS enabled and only Locations Service turned on, which previous version never did.
    I think I came across a post form the previous maintainers of Navit for webOS in these forums so maybe 72ka can contact them and upload that to preware so more people can get the update - not sure how many are using it anyway. I rarely launch it myself just because the patch portal was hacked and there's nothing new there
    Might get it out for a ride tomorrow but so far moving the map around is much more smoother than before as well
    Thanks again to 72ka!
    Pre- 1.45 will not run this version. Version 4787 was the last version that runs 1.45. This updated version loads very quickly, loads the map , but car is not displayed.

    The NAVIT log has the same error as reported in POST #13.

    navitlugin_load:can't load '/media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/vehicle/libvehicle_webos.so', Error '/media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/vehicle/libvehicle_webos.so: undefined symbol: PDL_GetParamJson'

    On a Pre-, this new version will run if libvehicle_webos.so is replaced with the version from 4787. I saved the 4787 version, uninstalled Navit, installed new version & replaced libvehicle_webos.so.

    The new version loads very quick, and doesn't crash like 4787.

    I think the Pre- doesn't support the multiple profiles probably included in the new libvehicle_webos.so file. Even on Version 4787, only the CAR icon would display, no matter what profile was selected.


    Another Thanks to 72ka!
  7. #47  
    Hi all, very glad to see the feedback! It is not necessary to uninstall old version. My build is just the same, its a regular update of original package. I have also the armv6 version on my computer, so Ill upload it also.
    It would be great to push it to the preware. But... the most annoying thing on Navit from my point of view is, that the volume buttons sets the ring volume, not the speech volume. It always makes me crazy if I need to change the volume, must to launch e.g. Music, set the volume and then go back to Navit ....
    Id like to try to fix it, then push to preware.

    So, enjoy a small amount of new juice to your webOS phone
    Microsoft Lumia 535, the Google Maps, Maps, wInNeR, Gas&Oil, HERE maps for webOS development
    gizmo21, Preemptive and bigdoby like this.
  8. #48  
    Quote Originally Posted by cosb3541 View Post
    The NAVIT log has the same error as reported in POST #13.

    navitlugin_load:can't load '/media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/vehicle/libvehicle_webos.so', Error '/media/cryptofs/apps/usr/palm/applications/org.webosinternals.navit/lib/navit/vehicle/libvehicle_webos.so: undefined symbol: PDL_GetParamJson'
    Hi, interresting report, your issue is due your webOS version, check this:

    https://developer.palm.com/content/a...webos-2.1.html

    you can see that the PDL_GetParamJson is new since 2.1
    Microsoft Lumia 535, the Google Maps, Maps, wInNeR, Gas&Oil, HERE maps for webOS development
  9. #49  
    Quote Originally Posted by 72ka View Post
    Hi all, very glad to see the feedback! It is not necessary to uninstall old version. My build is just the same, its a regular update of original package. I have also the armv6 version on my computer, so Ill upload it also.
    It would be great to push it to the preware. But... the most annoying thing on Navit from my point of view is, that the volume buttons sets the ring volume, not the speech volume. It always makes me crazy if I need to change the volume, must to launch e.g. Music, set the volume and then go back to Navit ....
    Id like to try to fix it, then push to preware.

    So, enjoy a small amount of new juice to your webOS phone
    Tip: if you need to increase the volume in Navit do it from the hardware buttons on the side while Speech Dispatchers is talking. I believe it's the same with the on screen buttons. It just uses the current audio profile and when the dispatcher is not talking it's the ring volume. By default it's the Media profile.
    You can alternately use the Speech Dispatcher service I think to set different profiles for it to use.
    I think it was in the alpha feeds.
    Speech Dispatcher
  10. #50  
    Quote Originally Posted by 72ka View Post
    So, enjoy a small amount of new juice to your webOS phone
    @72ka - Thanks for this new navit. This is GREAT !

    I installed it without problems on my Pre3. It automatically replaced the previous navit version.
    New version appears to be a bit faster.
    Some items display without translation (to German language: Einstellungen:Northing)
    some issues remain: app crashes from time to time
    - I tried to use Lumberjack to trace some error logs - but nothing available so far

    Now I have used the new version with GPS for Navigation. It works as expected.
    - well - I did run into an issue after about 10 mins and the Pre3 crashed and then it rebooted. I've see this also with previous navit.

    I wonder if this new navit version would run on TP too.
    So far I run Navit v.0.5.0.5287-1 on TP and this includes a GPS via Bluetooth connection - so that I can use the Pre3 as GPS device to send position to Navit on TP via BT.
    Is this BT connection include in the new build too ?

    Thanks again !
    Last edited by MartinH@webos; 03/15/2014 at 07:04 PM. Reason: Updated afer using GPS navigation
  11. s3rgei's Avatar
    Posts
    43 Posts
    Global Posts
    44 Global Posts
    #51  
    Thank you very much 72ka !
  12. s3rgei's Avatar
    Posts
    43 Posts
    Global Posts
    44 Global Posts
    #52  
    Update:
    I don't know what you touch, you are a genius man !
    This version is more fast, and stable than 0.5.0.4887.
    Here, in Argentina, it run very, very good.
    I just try a course of 17 km round trip and it worked wonders.
    The first run fee and turned to her.
    Before breaking the software without any logic.
    Thank you very much for your contribution!
  13. #53  
    Hi,

    about the crashes on Pre3, I didnt noticed on my device. And agree, theres nothing in lumberjack log. The debug is different. If you have any troubles, please go to /media/internal/appdata/org.webosinternals.navit/ and read the file navit.log - this is the current log.

    About the bluetooth, it could be there, because as I said, I only built the new package from recent binaries, it was easy, without touch to the source code, nothing to be proud of it

    BUT, now after two days of setting-up the WIDK, I finally built the most recent navit code (against recent SVN which is r5754). It works, but withou any icons at all. The log contains

    Code:
    navit:graphics_image_new_scaled_rotated:No image for "path to the png icon, which is available"

    and I dont know why... so at this time Im trying to go deeply in the code. My challenge is to bring a most recent Navit version with all the recent features to webOS. Because Google Maps and Navit are my favorite apps
    Microsoft Lumia 535, the Google Maps, Maps, wInNeR, Gas&Oil, HERE maps for webOS development
  14. #54  
    There is an armv6 version (Pixi, etc..) as I promised:

    org-webosinternals-navit-0-5-0-5337-0-1-armv6-ipk

    Not tested at all... I dont have device to test it. Try it at your own risk.
    Microsoft Lumia 535, the Google Maps, Maps, wInNeR, Gas&Oil, HERE maps for webOS development
  15. #55  
    You are amazing. Any plans to touch the UI?
  16. #56  
    Quote Originally Posted by Grabber5.0 View Post
    You are amazing. Any plans to touch the UI?
    I absolutely agree. 72ka rocks.

    BTW what kind of changes do you want on the UI? The OSD is really configurable...
  17. #57  
    Quote Originally Posted by tylla View Post
    I absolutely agree. 72ka rocks.

    BTW what kind of changes do you want on the UI? The OSD is really configurable...
    AH - great: OSD Layouts - Navit's Wiki

    Anyone tried the NavitConfigurator on Win7 for webos navit configs?
  18. #58  
    Quote Originally Posted by tylla View Post
    I absolutely agree. 72ka rocks.

    BTW what kind of changes do you want on the UI? The OSD is really configurable...
    The UI is not very intuitive. I have no idea what half the icons mean or how to do most things. I feel like you should be able to figure out most things without reading the manual. I'm sure there is help somewhere, but I haven't wanted it bad enough to look.
  19. #59  
    Yeah, compared to sprint nav, its kinda hard to deal with

    -- Sent from my Palm Pre using Forums
  20. #60  
    Quote Originally Posted by laingman View Post
    Yeah, compared to sprint nav, its kinda hard to deal with

    -- Sent from my Palm Pre using Forums
    I must agree. The sprint nav UI was very friendly. Can it be simulated?
Page 3 of 6 FirstFirst 123456 LastLast

Posting Permissions